Releasing debian version 3:6.03+dfsg-10.
[syslinux-debian.git] / debian / patches / 0007-sysappend-fix-space-stripping.patch
bloba39bd9b3cb5b27ba02356f3bf09cd4f75ac6414c
1 Author: Dany St-Amant <dany.ephemeral.2014@icloud.com>
2 Description: SYSAPPEND: Fix space stripping
3 The description of SYSAPPEND for the DMI information states that the spaces
4 are replaced by underscores, but this replacement does not occur in 6.03 (Closes: #795596).
6 diff -Naurp syslinux.orig/com32/elflink/ldlinux/readconfig.c syslinux/com32/elflink/ldlinux/readconfig.c
7 --- syslinux.orig/com32/elflink/ldlinux/readconfig.c
8 +++ syslinux/com32/elflink/ldlinux/readconfig.c
9 @@ -330,7 +330,7 @@ static char *copy_sysappend_string(char
10 char c;
12 while ((c = *src++)) {
13 - if (c <= ' ' && c == '\x7f') {
14 + if (c <= ' ' || c == '\x7f') {
15 if (!was_space)
16 *dst++ = '_';
17 was_space = true;
18 diff -Naurp syslinux.orig/com32/menu/readconfig.c syslinux/com32/menu/readconfig.c
19 --- syslinux.orig/com32/menu/readconfig.c
20 +++ syslinux/com32/menu/readconfig.c
21 @@ -299,7 +299,7 @@ static char *copy_sysappend_string(char
22 char c;
24 while ((c = *src++)) {
25 - if (c <= ' ' && c == '\x7f') {
26 + if (c <= ' ' || c == '\x7f') {
27 if (!was_space)
28 *dst++ = '_';
29 was_space = true;
30 diff -Naurp syslinux.orig/core/sysappend.c syslinux/core/sysappend.c
31 --- syslinux.orig/core/sysappend.c
32 +++ syslinux/core/sysappend.c
33 @@ -35,7 +35,7 @@ static char *copy_and_mangle(char *dst,
34 char c;
36 while ((c = *src++)) {
37 - if (c <= ' ' && c == '\x7f') {
38 + if (c <= ' ' || c == '\x7f') {
39 if (!was_space)
40 *dst++ = '_';
41 was_space = true;