Adding upstream version 3.53.
[syslinux-debian/hramrach.git] / syslinux.spec
blobfb40df0236c9d85242f1545c4edece9a6dd805de
1 # -*- rpm -*-
2 %define RPMVERSION 3.53
3 %define VERSION 3.53
4 Summary: Kernel loader which uses a FAT, ext2/3 or iso9660 filesystem or a PXE network
5 Name: syslinux
6 Version: %{RPMVERSION}
7 Release: 1
8 License: GPL
9 Group: System/Boot
10 Source0: ftp://ftp.kernel.org/pub/linux/utils/boot/syslinux/%{name}-%{VERSION}.tar.gz
11 ExclusiveArch: i386 i486 i586 i686 athlon pentium4 x86_64
12 Packager: H. Peter Anvin <hpa@zytor.com>
13 Buildroot: %{_tmppath}/%{name}-%{VERSION}-root
14 BuildPrereq: nasm >= 0.98.38, perl
15 Autoreq: 0
16 %ifarch x86_64
17 Requires: mtools, libc.so.6()(64bit)
18 %define my_cc gcc
19 %else
20 Requires: mtools, libc.so.6
21 %define my_cc gcc -m32
22 %endif
24 # NOTE: extlinux belongs in /sbin, not in /usr/sbin, since it is typically
25 # a system bootloader, and may be necessary for system recovery.
26 %define _sbindir /sbin
28 %package devel
29 Summary: Development environment for SYSLINUX add-on modules
30 Group: Development/Libraries
31 Requires: syslinux
33 %description
34 SYSLINUX is a suite of bootloaders, currently supporting DOS FAT
35 filesystems, Linux ext2/ext3 filesystems (EXTLINUX), PXE network boots
36 (PXELINUX), or ISO 9660 CD-ROMs (ISOLINUX). It also includes a tool,
37 MEMDISK, which loads legacy operating systems from these media.
39 %description devel
40 The SYSLINUX boot loader contains an API, called COM32, for writing
41 sophisticated add-on modules. This package contains the libraries
42 necessary to compile such modules.
44 %package extlinux
45 Summary: The EXTLINUX bootloader, for booting the local system.
46 Group: System/Boot
47 Requires: syslinux
49 %description extlinux
50 The EXTLINUX bootloader, for booting the local system, as well as all
51 the SYSLINUX/PXELINUX modules in /boot.
53 %package tftpboot
54 Summary: SYSLINUX modules in /tftpboot, available for network booting
55 Group: Applications/Internet
56 Requires: syslinux
58 %description tftpboot
59 All the SYSLINUX/PXELINUX modules directly available for network
60 booting in the /tftpboot directory.
62 %prep
63 %setup -q -n syslinux-%{VERSION}
65 %build
66 make CC='%{my_cc}' clean
67 make CC='%{my_cc}' installer
68 make CC='%{my_cc}' -C sample tidy
70 %install
71 rm -rf %{buildroot}
72 mkdir -p %{buildroot}%{_bindir}
73 mkdir -p %{buildroot}%{_sbindir}
74 mkdir -p %{buildroot}%{_datadir}/syslinux
75 mkdir -p %{buildroot}%{_includedir}
76 mkdir -p %{buildroot}/boot/extlinux %{buildroot}/etc
77 mkdir -p %{buildroot}/tftpboot/pxelinux.cfg
78 make CC='%{my_cc}' install-all \
79 INSTALLROOT=%{buildroot} BINDIR=%{_bindir} SBINDIR=%{_sbindir} \
80 LIBDIR=%{_datadir} INCDIR=%{_includedir}
81 make CC='%{my_cc}' -C sample tidy
82 cp mkdiskimage sys2ansi.pl keytab-lilo.pl %{buildroot}%{_datadir}/syslinux
84 cp %{buildroot}%{_datadir}/syslinux/*.c32 %{buildroot}/boot/extlinux
85 cp %{buildroot}%{_datadir}/syslinux/memdisk %{buildroot}/boot/extlinux
86 ( cd %{buildroot}/etc && ln -s ../boot/extlinux/extlinux.conf . )
88 cp %{buildroot}%{_datadir}/syslinux/*.c32 %{buildroot}/tftpboot
89 cp %{buildroot}%{_datadir}/syslinux/pxelinux.0 %{buildroot}/tftpboot
90 cp %{buildroot}%{_datadir}/syslinux/memdisk %{buildroot}/tftpboot
92 %clean
93 rm -rf %{buildroot}
95 %files
96 %defattr(-,root,root)
97 %doc NEWS README* *.doc memdisk/*.doc COPYING
98 %doc sample
99 %{_bindir}/syslinux
100 %{_bindir}/ppmtolss16
101 %{_bindir}/lss16toppm
102 %{_bindir}/gethostip
103 %{_bindir}/sha1pass
104 %{_bindir}/md5pass
105 %{_datadir}/syslinux/*.com
106 %{_datadir}/syslinux/*.exe
107 %{_datadir}/syslinux/*.c32
108 %{_datadir}/syslinux/*.bin
109 %{_datadir}/syslinux/*.0
110 %{_datadir}/syslinux/memdisk
111 %{_datadir}/syslinux/*.pl
112 %{_datadir}/syslinux/mkdiskimage
114 %files devel
115 %{_datadir}/syslinux/com32
117 %files extlinux
118 %{_sbindir}/extlinux
119 /boot/extlinux
120 %config /etc/extlinux.conf
122 %files tftpboot
123 /tftpboot
125 %post extlinux
126 # If we have a /boot/extlinux.conf file, assume extlinux is our bootloader
127 # and update it.
128 if [ -f /boot/extlinux/extlinux.conf ]; then \
129 extlinux --update /boot/extlinux ; \
130 elif [ -f /boot/extlinux.conf ]; then \
131 mkdir -p /boot/extlinux && \
132 mv /boot/extlinux.conf /boot/extlinux/extlinux.conf && \
133 extlinux --update /boot/extlinux ; \
136 %postun
138 %changelog
139 * Thu Mar 15 2007 H. Peter Anvin <hpa@zytor.com>
140 - Move extlinux /boot stuff into /boot/extlinux.
142 * Thu Jan 25 2007 H. Peter Anvin <hpa@zytor.com>
143 - Hacks to make the 32-bit version build correctly on 64-bit machines.
145 * Mon Sep 19 2006 H. Peter Anvin <hpa@zytor.com>
146 - Add a syslinux-tftpboot module.
147 - Factor extlinux into its own package.
148 - Move to %{_datadir} (/usr/share).
150 * Wed Sep 21 2005 H. Peter Anvin <hpa@zytor.com>
151 - If /boot/extlinux.conf exist, run extlinux --update.
153 * Fri Sep 9 2005 H. Peter Anvin <hpa@zytor.com>
154 - Copy, don't link, *.c32 into /boot; rpm doesn't like breaking links.
156 * Tue Aug 23 2005 H. Peter Anvin <hpa@zytor.com>
157 - Put *.c32 into /boot.
159 * Thu Dec 30 2004 H. Peter Anvin <hpa@zytor.com>
160 - libsyslinux dropped in syslinux 3.00.
161 - Additional documentation.
162 - Add extlinux.
164 * Tue Dec 14 2004 H. Peter Anvin <hpa@zytor.com>
165 - Add a devel package for the com32 library added in 2.12.
167 * Wed Apr 16 2003 H. Peter Anvin <hpa@zytor.com> 2.04-1
168 - 2.04 release
169 - Add support for libsyslinux.so*
170 - Templatize for inclusion in CVS tree
172 * Thu Apr 10 2003 H. Peter Anvin <hpa@zytor.com>
173 - 2.03 release
174 - Add support for libsyslinux.a
175 - Add keytab-lilo.pl to the /usr/lib/syslinux directory
176 - Modernize syntax
177 - Support building on x86-64
179 * Thu Feb 13 2003 H. Peter Anvin <hpa@zytor.com>
180 - 2.02 release; no longer setuid
182 * Thu Jan 30 2003 H. Peter Anvin <hpa@zytor.com>
183 - Prepare for 2.01 release; make /usr/bin/syslinux setuid root
185 * Fri Oct 25 2002 H. Peter Anvin <hpa@zytor.com>
186 - Upgrade to 2.00.
188 * Tue Aug 27 2002 H. Peter Anvin <hpa@zytor.com>
189 - Upgrade to 1.76.
191 * Fri Jun 14 2002 H. Peter Anvin <hpa@zytor.com>
192 - Upgrade to 1.75.
194 * Sat Jun 1 2002 H. Peter Anvin <hpa@zytor.com>
195 - Upgrade to 1.74.
197 * Sun May 26 2002 H. Peter Anvin <hpa@zytor.com>
198 - Upgrade to 1.73.
200 * Tue Apr 23 2002 H. Peter Anvin <hpa@zytor.com>
201 - Upgrade to 1.72.
203 * Wed Apr 17 2002 H. Peter Anvin <hpa@zytor.com>
204 - Upgrade to 1.71.
205 - Update the title.
207 * Wed Apr 17 2002 H. Peter Anvin <hpa@zytor.com>
208 - Upgrade to 1.70.
210 * Sat Feb 3 2002 H. Peter Anvin <hpa@zytor.com>
211 - Upgrade to 1.67.
213 * Tue Jan 1 2002 H. Peter Anvin <hpa@zytor.com>
214 - Upgrade to 1.66.
216 * Sat Dec 15 2001 H. Peter Anvin <hpa@zytor.com>
217 - Upgrade to 1.65; make appropriate changes.
219 * Sat Aug 24 2001 H. Peter Anvin <hpa@zytor.com>
220 - Upgrade to 1.64.
222 * Mon Aug 6 2001 H. Peter Anvin <hpa@zytor.com>
223 - Upgrade to 1.63.
224 - Use make install since the stock SYSLINUX distribution now supports
225 INSTALLROOT.
227 * Sat Apr 24 2001 H. Peter Anvin <hpa@zytor.com>
228 - Upgrade to 1.62.
230 * Sat Apr 14 2001 H. Peter Anvin <hpa@zytor.com>
231 - Fix missing %files; correct modes.
233 * Fri Apr 13 2001 H. Peter Anvin <hpa@zytor.com>
234 - Upgrade to 1.61
235 - Install auxilliary programs in /usr/lib/syslinux
237 * Sat Feb 10 2001 Matt Wilson <msw@redhat.com>
238 - 1.52
240 * Wed Jan 24 2001 Matt Wilson <msw@redhat.com>
241 - 1.51pre7
243 * Mon Jan 22 2001 Matt Wilson <msw@redhat.com>
244 - 1.51pre5
246 * Fri Jan 19 2001 Matt Wilson <msw@redhat.com>
247 - 1.51pre3, with e820 detection
249 * Tue Dec 12 2000 Than Ngo <than@redhat.com>
250 - rebuilt with fixed fileutils
252 * Thu Nov 9 2000 Than Ngo <than@redhat.com>
253 - update to 1.49
254 - update ftp site
255 - clean up specfile
256 - add some useful documents
258 * Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
259 - add %%defattr (release 4)
261 * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
262 - automatic rebuild
264 * Thu Jul 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
265 - use %%{_tmppath}
266 - change application group (Applications/Internet doesn't seem
267 right to me)
268 - added BuildRequires
270 * Tue Apr 04 2000 Erik Troan <ewt@redhat.com>
271 - initial packaging