1 #!/bin/sh /usr/share/dpatch/dpatch-run
2 ## 03-define-clk-tck.dpatch by Timo Aaltonen <tjaalton@cc.hut.fi>
4 ## DP: Define CLK_TCK, since the com32 libc API does not have any idea about it,
5 ## DP: and its include files shadow /usr/include/time.h (which would provide
6 ## DP: CLOCKS_PER_SEC).
10 diff -Naur syslinux-3.50
-pre15.orig
/com32
/include
/time.h syslinux-3.50
-pre15/com32
/include
/time.h
11 --- syslinux-3.50
-pre15.orig
/com32
/include
/time.h
2007-05-23 06:28:22.000000000 +0000
12 +++ syslinux-3.50
-pre15/com32
/include
/time.h
2007-05-31 06:52:30.000000000 +0000
14 +#define CLK_TCK 1000000l
15 diff -Naur syslinux-3.50
-pre15.orig
/com32
/libutil
/include
/libutil.h syslinux-3.50
-pre15/com32
/libutil
/include
/libutil.h
16 --- syslinux-3.50
-pre15.orig
/com32
/libutil
/include
/libutil.h
2007-05-23 06:28:22.000000000 +0000
17 +++ syslinux-3.50
-pre15/com32
/libutil
/include
/libutil.h
2007-05-31 06:53:02.000000000 +0000
19 #ifndef LIBUTIL_LIBUTIL_H
20 #define LIBUTIL_LIBUTIL_H
22 +#define CLK_TCK 1000000l
26 # include <syslinux/idle.h>
27 diff -Naur syslinux-3.50
-pre15.orig
/com32
/samples
/keytest.c syslinux-3.50
-pre15/com32
/samples
/keytest.c
28 --- syslinux-3.50
-pre15.orig
/com32
/samples
/keytest.c
2007-05-23 06:28:22.000000000 +0000
29 +++ syslinux-3.50
-pre15/com32
/samples
/keytest.c
2007-05-31 06:53:53.000000000 +0000
34 - printf("CLK_TCK = %d\n", (int
)CLK_TCK
);
35 + printf("CLK_TCK = %d\n", (int
)1000000l);
36 printf("Press keys, end with Ctrl-C...\n");