2 %define RPMVERSION
3.69.8
3 %define VERSION
3.70-pre8
4 Summary: Kernel loader which uses a FAT
, ext2
/3 or iso9660 filesystem or a PXE network
10 Source0: ftp
://ftp.kernel.org
/pub
/linux
/utils
/boot
/syslinux
/%{name}-%{VERSION}.tar.gz
11 ExclusiveArch: i386 i486 i586 i686 athlon pentium4 x86_64
12 Packager: H. Peter Anvin
<hpa@zytor.com
>
13 Buildroot: %{_tmppath}/%{name}-%{VERSION}-root
14 BuildPrereq
: nasm
>= 0.98.39, perl
17 Requires: mtools
, libc.so
.6()(64bit
)
20 Requires: mtools
, libc.so
.6
21 %define my_cc gcc
-m32
24 # NOTE: extlinux belongs in /sbin, not in /usr/sbin, since it is typically
25 # a system bootloader, and may be necessary for system recovery.
26 %define _sbindir
/sbin
29 Summary: Development environment
for SYSLINUX add
-on modules
30 Group: Development
/Libraries
34 SYSLINUX is a suite of bootloaders
, currently supporting DOS FAT
35 filesystems
, Linux ext2
/ext3 filesystems
(EXTLINUX
), PXE network boots
36 (PXELINUX
), or ISO
9660 CD
-ROMs
(ISOLINUX
). It also includes a tool
,
37 MEMDISK
, which loads legacy operating systems from these media.
40 The SYSLINUX boot loader contains an API
, called COM32
, for writing
41 sophisticated add
-on modules. This package contains the libraries
42 necessary to compile such modules.
45 Summary: The EXTLINUX bootloader
, for booting the
local system.
50 The EXTLINUX bootloader
, for booting the
local system
, as well as all
51 the SYSLINUX
/PXELINUX modules
in /boot.
54 Summary: SYSLINUX modules
in /tftpboot
, available
for network booting
55 Group: Applications
/Internet
59 All the SYSLINUX
/PXELINUX modules directly available
for network
60 booting
in the
/tftpboot directory.
63 %setup -q
-n syslinux
-%{VERSION}
66 make CC
='
%{my_cc}' clean
67 make CC
='
%{my_cc}' installer
68 make CC
='
%{my_cc}'
-C sample tidy
72 mkdir -p
%{buildroot}%{_bindir}
73 mkdir -p
%{buildroot}%{_sbindir}
74 mkdir -p
%{buildroot}%{_datadir}/syslinux
75 mkdir -p
%{buildroot}%{_includedir}
76 mkdir -p
%{buildroot}/boot/extlinux %{buildroot}/etc
77 mkdir -p
%{buildroot}/tftpboot
/pxelinux.cfg
78 make CC
='
%{my_cc}'
install-all \
79 INSTALLROOT
=%{buildroot} BINDIR=%{_bindir} SBINDIR=%{_sbindir} \
80 LIBDIR
=%{_datadir} MANDIR=%{_mandir} INCDIR=%{_includedir}
81 make CC
='
%{my_cc}'
-C sample tidy
82 cp mkdiskimage syslinux2ansi.pl keytab
-lilo.pl
%{buildroot}%{_datadir}/syslinux
84 cp
%{buildroot}%{_datadir}/syslinux/*.c32 %{buildroot}/boot
/extlinux
85 cp
%{buildroot}%{_datadir}/syslinux/memdisk %{buildroot}/boot
/extlinux
86 ( cd %{buildroot}/etc
&& ln
-s ..
/boot
/extlinux
/extlinux.conf .
)
88 cp
%{buildroot}%{_datadir}/syslinux/*.c32 %{buildroot}/tftpboot
89 cp
%{buildroot}%{_datadir}/syslinux/pxelinux.0 %{buildroot}/tftpboot
90 cp
%{buildroot}%{_datadir}/syslinux/memdisk %{buildroot}/tftpboot
97 %doc COPYING NEWS doc
/*
101 %{_bindir}/ppmtolss16
102 %{_bindir}/lss16toppm
106 %{_datadir}/syslinux
/*.com
107 %{_datadir}/syslinux
/*.exe
108 %{_datadir}/syslinux
/*.c32
109 %{_datadir}/syslinux
/*.bin
110 %{_datadir}/syslinux
/*.0
111 %{_datadir}/syslinux
/memdisk
112 %{_datadir}/syslinux
/*.pl
113 %{_datadir}/syslinux
/mkdiskimage
116 %{_datadir}/syslinux
/com32
121 %config /etc
/extlinux.conf
127 # If we have a /boot/extlinux.conf file, assume extlinux is our bootloader
129 if [ -f
/boot
/extlinux
/extlinux.conf
]; then \
130 extlinux
--update
/boot
/extlinux
; \
131 elif [ -f
/boot
/extlinux.conf
]; then \
132 mkdir -p
/boot
/extlinux
&& \
133 mv
/boot
/extlinux.conf
/boot
/extlinux
/extlinux.conf
&& \
134 extlinux
--update
/boot
/extlinux
; \
140 * Thu Jan
10 2008 H. Peter Anvin
<hpa@zytor.com
>
143 * Mon Nov
19 2007 Bernard Li
<bernard@vanhpc.org
>
144 - Added netpbm
-progs
(provides pngtopnm
) to BuildPrereq
(this should be
145 changed to BuildRequires since it is deprecated...
)
147 * Thu Mar
15 2007 H. Peter Anvin
<hpa@zytor.com
>
148 - Move extlinux
/boot stuff into
/boot
/extlinux.
150 * Thu Jan
25 2007 H. Peter Anvin
<hpa@zytor.com
>
151 - Hacks to
make the
32-bit version build correctly on
64-bit machines.
153 * Mon Sep
19 2006 H. Peter Anvin
<hpa@zytor.com
>
154 - Add a syslinux
-tftpboot module.
155 - Factor extlinux into its own package.
156 - Move to
%{_datadir} (/usr
/share
).
158 * Wed Sep
21 2005 H. Peter Anvin
<hpa@zytor.com
>
159 - If
/boot
/extlinux.conf exist
, run extlinux
--update.
161 * Fri Sep
9 2005 H. Peter Anvin
<hpa@zytor.com
>
162 - Copy
, don't link
, *.c32 into
/boot
; rpm doesn't like breaking links.
164 * Tue Aug
23 2005 H. Peter Anvin
<hpa@zytor.com
>
165 - Put
*.c32 into
/boot.
167 * Thu Dec
30 2004 H. Peter Anvin
<hpa@zytor.com
>
168 - libsyslinux dropped
in syslinux
3.00.
169 - Additional documentation.
172 * Tue Dec
14 2004 H. Peter Anvin
<hpa@zytor.com
>
173 - Add a devel package
for the com32 library added
in 2.12.
175 * Wed Apr
16 2003 H. Peter Anvin
<hpa@zytor.com
> 2.04-1
177 - Add support
for libsyslinux.so
*
178 - Templatize
for inclusion
in CVS tree
180 * Thu Apr
10 2003 H. Peter Anvin
<hpa@zytor.com
>
182 - Add support
for libsyslinux.a
183 - Add keytab
-lilo.pl to the
/usr
/lib
/syslinux directory
185 - Support building on x86
-64
187 * Thu Feb
13 2003 H. Peter Anvin
<hpa@zytor.com
>
188 - 2.02 release
; no longer setuid
190 * Thu Jan
30 2003 H. Peter Anvin
<hpa@zytor.com
>
191 - Prepare
for 2.01 release
; make /usr
/bin
/syslinux setuid root
193 * Fri Oct
25 2002 H. Peter Anvin
<hpa@zytor.com
>
196 * Tue Aug
27 2002 H. Peter Anvin
<hpa@zytor.com
>
199 * Fri Jun
14 2002 H. Peter Anvin
<hpa@zytor.com
>
202 * Sat Jun
1 2002 H. Peter Anvin
<hpa@zytor.com
>
205 * Sun May
26 2002 H. Peter Anvin
<hpa@zytor.com
>
208 * Tue Apr
23 2002 H. Peter Anvin
<hpa@zytor.com
>
211 * Wed Apr
17 2002 H. Peter Anvin
<hpa@zytor.com
>
215 * Wed Apr
17 2002 H. Peter Anvin
<hpa@zytor.com
>
218 * Sat Feb
3 2002 H. Peter Anvin
<hpa@zytor.com
>
221 * Tue Jan
1 2002 H. Peter Anvin
<hpa@zytor.com
>
224 * Sat Dec
15 2001 H. Peter Anvin
<hpa@zytor.com
>
225 - Upgrade to
1.65; make appropriate changes.
227 * Sat Aug
24 2001 H. Peter Anvin
<hpa@zytor.com
>
230 * Mon Aug
6 2001 H. Peter Anvin
<hpa@zytor.com
>
232 - Use
make install since the stock SYSLINUX distribution now supports
235 * Sat Apr
24 2001 H. Peter Anvin
<hpa@zytor.com
>
238 * Sat Apr
14 2001 H. Peter Anvin
<hpa@zytor.com
>
239 - Fix missing
%files; correct modes.
241 * Fri Apr
13 2001 H. Peter Anvin
<hpa@zytor.com
>
243 - Install auxilliary programs
in /usr
/lib
/syslinux
245 * Sat Feb
10 2001 Matt Wilson
<msw@redhat.com
>
248 * Wed Jan
24 2001 Matt Wilson
<msw@redhat.com
>
251 * Mon Jan
22 2001 Matt Wilson
<msw@redhat.com
>
254 * Fri Jan
19 2001 Matt Wilson
<msw@redhat.com
>
255 - 1.51pre3
, with e820 detection
257 * Tue Dec
12 2000 Than Ngo
<than@redhat.com
>
258 - rebuilt with fixed fileutils
260 * Thu Nov
9 2000 Than Ngo
<than@redhat.com
>
264 - add some useful documents
266 * Tue Jul
18 2000 Nalin Dahyabhai
<nalin@redhat.com
>
267 - add %
%defattr (release
4)
269 * Wed Jul
12 2000 Prospector
<bugzilla@redhat.com
>
272 * Thu Jul
06 2000 Trond Eivind Glomsrød
<teg@redhat.com
>
274 - change application group
(Applications
/Internet doesn't seem
276 - added BuildRequires
278 * Tue Apr
04 2000 Erik Troan
<ewt@redhat.com
>