5 .
/usr
/share
/debconf
/confmodule
9 db_get extlinux
/install
10 _INSTALL
="${RET}" # boolean
19 _PATH
="/boot/extlinux"
23 _DEVICE
="$(findmnt --canonicalize --noheadings --output SOURCE --raw ${_PATH}/ | sed -r 's|[0-9]+$||;s|([0-9])p$|\1|')"
25 if [ -n "${_DEVICE}" ] ||
[ -z "${_PATH}" ]
30 _PATH
="$(dirname ${_PATH})"
33 extlinux-install
"${_DEVICE}"
37 if [ -x /etc
/kernel
/postinst.d
/zz-extlinux
]
39 /etc
/kernel
/postinst.d
/zz-extlinux
45 abort-upgrade|abort-remove|abort-deconfigure
)
50 echo "postinst called with unknown argument \`${1}'" >&2