Releasing debian version 4.04+dfsg-9.
[syslinux-debian/hramrach.git] / debian / extlinux.postinst
blobb09f61b9869c952413348a79dd9c8e8c0b2fb84b
1 #!/bin/sh
3 set -e
5 . /usr/share/debconf/confmodule
7 case "${1}" in
8 configure)
9 db_get extlinux/install
10 _INSTALL="${RET}" # boolean
12 db_stop
14 case "${_INSTALL}" in
15 true)
16 extlinux-update
18 _DEVICE="$(df -P /boot/extlinux | tail -1 | awk '{ print $1 }' | sed -e 's|[0-9]||g')"
20 extlinux-install "${_DEVICE}"
24 if [ -x /etc/kernel/postinst.d/zz-extlinux ]
25 then
26 /etc/kernel/postinst.d/zz-extlinux
29 esac
32 abort-upgrade|abort-remove|abort-deconfigure)
37 echo "postinst called with unknown argument \`${1}'" >&2
38 exit 1
40 esac
42 #DEBHELPER#
44 exit 0