6 include /usr
/share
/quilt
/quilt.make
8 LOG4TANGO_VERSION
:= $(shell egrep AC_INIT lib
/cpp/log4tango
/configure.in | cut
-f
2 -d
' ' | cut
-f
1 -d
',')
9 DEB_NOREVISION_VERSION
:= $(shell dpkg-parsechangelog | egrep
'^Version:' | cut
-f
2 -d
' ' | cut
-f
2 -d
'-')
16 build
: patch build-stamp
18 dh build
--before configure
19 dh_auto_configure
-- --with-omni
=/usr
--disable-dbcreate
--disable-java
22 touch lib
/cpp/log4tango
/aclocal.m4
23 touch lib
/cpp/log4tango
/Makefile.am
24 touch lib
/cpp/log4tango
/Makefile.in
25 touch lib
/cpp/log4tango
/Makefile
26 dh build
--after configure
29 install: build install-stamp
31 dh
install --until prep
32 # install dbconfig-common scripts
33 install -d debian
/tmp
/usr
/share
/dbconfig-common
/data
/tango-db
/install
34 install -p
-m
644 cppserver
/database
/create_db.sql debian
/tmp
/usr
/share
/dbconfig-common
/data
/tango-db
/install/mysql
35 # install scripts used during the configuration
36 install -d debian
/tmp
/usr
/share
/tango-db
37 install -p
-m
644 cppserver
/database
/create_db_tables.sql debian
/tmp
/usr
/share
/tango-db
/create_db_tables.sql
38 install -p
-m
644 cppserver
/database
/stored_proc.sql debian
/tmp
//usr
/share
/tango-db
/stored_proc.sql
39 install -p
-m
600 cppserver
/database
/my.cnf debian
/tmp
/usr
/share
/tango-db
/my.cnf
40 # install the pkg-config files
41 # log4tango.pc and tango.pc
42 install -d debian
/tmp
/usr
/lib
/pkgconfig
43 install -p
-m
644 lib
/cpp/log4tango
/log4tango.
pc debian
/tmp
/usr
/lib
/pkgconfig
/log4tango.
pc
44 install -p
-m
644 lib
/cpp/tango.
pc debian
/tmp
/usr
/lib
/pkgconfig
/tango.
pc
45 dh
install --remaining
-v
48 binary
: binary-arch binary-indep
50 dh binary-arch
--before
strip
51 dh_strip
-plibtango6
--dbg-package
=libtango6-dbg
52 dh_strip
-pliblog4tango4
--dbg-package
=liblog4tango4-dbg
53 dh_strip
-a
-Nlibtango6
-Nliblog4tango4
54 dh binary-arch
--after
strip --before gencontrol
55 dh_gencontrol
-pliblog4tango4
-- -v
$(LOG4TANGO_VERSION
)-$(DEB_NOREVISION_VERSION
)
56 dh_gencontrol
-pliblog4tango4-dev
-- -v
$(LOG4TANGO_VERSION
)-$(DEB_NOREVISION_VERSION
) -VRELUP
=$(LOG4TANGO_VERSION
)-$(DEB_NOREVISION_VERSION
)
57 dh_gencontrol
-pliblog4tango4-dbg
-- -v
$(LOG4TANGO_VERSION
)-$(DEB_NOREVISION_VERSION
) -VRELUP
=$(LOG4TANGO_VERSION
)-$(DEB_NOREVISION_VERSION
)
58 dh_gencontrol
-a
-Nliblog4tango4
-Nliblog4tango4-dev
-Nliblog4tango4-dbg
59 dh binary-arch
--after gencontrol
-v
62 dh binary-indep
--before gencontrol
63 dh_gencontrol
-pliblog4tango4-doc
-- -v
$(LOG4TANGO_VERSION
)-$(DEB_NOREVISION_VERSION
)
64 dh_gencontrol
-i
-Nliblog4tango4-doc
65 dh binary-indep
--after gencontrol
-v