Prepare new Release
[tcc4lua.git] / debian / rules
bloba730c9fcb3602b9959b09de9fdb391bae62a9050
1 #!/usr/bin/make -f
3 # Uncomment this to turn on verbose mode.
4 #export DH_VERBOSE=1
6 config: config-stamp
7 config-stamp:
8 dh_testdir
9 [ ! -d debian/patches ] || $(MAKE) -f /usr/share/quilt/quilt.make patch
10 touch $@
12 build: build-stamp
13 build-stamp: config
14 dh_testdir
15 $(MAKE) CFLAGS="$(CFLAGS)"
16 touch $@
18 clean:
19 dh_testdir
20 dh_testroot
21 rm -f build-stamp config-stamp
22 [ ! -f Makefile ] || $(MAKE) clean
23 [ ! -d debian/patches ] || $(MAKE) -f /usr/share/quilt/quilt.make unpatch
24 dh_clean
26 install: build
27 dh_testdir
28 dh_testroot
29 dh_prep
30 dh_installdirs
31 $(MAKE) DESTDIR=$(CURDIR)/debian/tcc4lua install
33 # Build architecture-independent files here.
34 binary-indep: install
36 # Build architecture-dependent files here.
37 binary-arch: install
38 dh_testdir
39 dh_testroot
40 dh_installchangelogs
41 dh_installdocs
42 dh_installexamples test examples/*
43 dh_install
44 # dh_installmenu
45 # dh_installdebconf
46 # dh_installlogrotate
47 # dh_installemacsen
48 # dh_installpam
49 # dh_installmime
50 # dh_python
51 # dh_installinit
52 # dh_installcron
53 # dh_installinfo
54 dh_installman
55 # dh_desktop
56 dh_link
57 dh_strip --dbg-package=tcc4lua-dbg
58 dh_compress
59 dh_fixperms
60 # dh_perl
61 # dh_makeshlibs
62 [ ! -e /usr/bin/dh_buildinfo ] || dh_buildinfo
63 dh_installdeb
64 dh_shlibdeps
65 dh_gencontrol
66 dh_md5sums
67 dh_builddeb
69 binary: binary-indep binary-arch
70 .PHONY: config build clean binary-indep binary-arch binary install