3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
14 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
20 configure
: configure-stamp
26 build-stamp
: configure-stamp
34 rm -f build-stamp configure-stamp
35 [ ! -f Makefile
] ||
$(MAKE
) clean
43 $(MAKE
) PREFIX
=/usr DESTDIR
=$(CURDIR
)/debian
/xl2tpd
install
44 cp
$(CURDIR
)/doc
/l2tpd.conf.sample
$(CURDIR
)/debian
/xl2tpd
/etc
/xl2tpd
/xl2tpd.conf
45 cp
$(CURDIR
)/doc
/l2tp-secrets.sample
$(CURDIR
)/debian
/xl2tpd
/etc
/xl2tpd
/l2tp-secrets
47 # Build architecture-independent files here.
48 binary-indep
: build
install
49 dh_link
-pl2tpd usr
/share
/doc
/xl2tpd usr
/share
/doc
/l2tpd
51 # Build architecture-dependent files here.
52 binary-arch
: build
install
55 dh_installchangelogs CHANGES
61 cp debian
/lintian-overrides \
62 debian
/xl2tpd
/usr
/share
/lintian
/overrides
/xl2tpd
67 chmod
600 $(CURDIR
)/debian
/xl2tpd
/etc
/xl2tpd
/l2tp-secrets
74 binary
: binary-indep binary-arch
75 .PHONY
: build
clean binary-indep binary-arch binary
install configure