Trophae v6
[trophae.git] / debian / rules
blobdbdd124e8dbe6c3959593b5987dfb60edf9590d3
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
12 DESTDIR = debian/trophae
14 configure:
16 build:
18 clean:
19 dh_testdir
20 dh_testroot
21 dh_clean
23 install:
24 dh_testdir
25 dh_testroot
26 dh_clean -k
27 mkdir -p $(DESTDIR)/opt/trophae
28 cp *.py $(DESTDIR)/opt/trophae/
29 mkdir -p $(DESTDIR)/usr/share/applications/hildon
30 cp trophae.desktop $(DESTDIR)/usr/share/applications/hildon/
31 mkdir -p $(DESTDIR)/usr/share/icons/hicolor/scalable/apps
32 cp trophae.png $(DESTDIR)/usr/share/icons/hicolor/scalable/apps
34 binary-arch:
36 binary-indep: install
37 dh_testdir
38 dh_testroot
39 dh_compress
40 dh_fixperms
41 dh_installdeb
42 dh_gencontrol
43 dh_md5sums
44 dh_builddeb
46 binary: binary-indep
48 .PHONY: build clean binary-indep binary-arch binary install configure