This is Tuleap 16.4.99.32
[tuleap.git] / shell.nix
blob5090349413f7e0294c02471744c5b8e4e55a2e58
1 { pkgs ? (import ./tools/utils/nix/pinned-nixpkgs.nix) {} }:
3 let
4   devShell = import ./tools/utils/nix/dev-tools { inherit pkgs; };
5 in devShell.overrideAttrs {
6   # Use the SSH client provided by the system (FHS only) to avoid issues with Fedora/RedHat default settings
7   GIT_SSH = if pkgs.lib.pathExists "/usr/bin/ssh" then "/usr/bin/ssh" else "ssh";
8   # Explicitly target linux/amd64, our base image are linux/amd64 only at this time and not specifying this does not
9   # play well when using Apple silicon
10   DOCKER_DEFAULT_PLATFORM = "linux/amd64";