2 %define version SVN
-trunk
4 %define prefix
%{_prefix}
7 Summary: Twisted is an event
-based framework
for internet applications.
11 Source: %{name}-%{version}.tar.bz2
13 Group: System
/Libraries
14 URL: http
://www.twistedmatrix.com
/
15 Requires: python
>= %{py_libver}
16 BuildRequires
: python
-devel
17 BuildRoot: %{_tmppath}/%{name}-buildroot
21 Twisted is an event
-based framework
for internet applications. It includes a
22 web server
, a telnet server
, a chat server
, a news server
, a generic client
23 and server
for remote object access
, and APIs
for creating new protocols and
24 services. Twisted supports integration of the Tk
, GTK
+, Qt or wxPython event
25 loop with its main event loop. The Win32 event loop is also supported
, as is
26 basic support
for running servers on top of Jython.
29 Summary: Twisted documentation and example programs
30 Group: Development
/Python
32 Twisted is an event
-based framework
for internet applications.
33 Install Twisted
-doc
if you need the API documentation and example programs.
36 %setup -n
%{name}-%{version}
40 [ -n "$RPM_BUILD_ROOT"
-a "$RPM_BUILD_ROOT"
!= / ] && rm -rf "$RPM_BUILD_ROOT"
41 mkdir -p "$RPM_BUILD_ROOT"
43 python setup.py
install --optimize
=2 --record
=installed
-files \
44 --root
="$RPM_BUILD_ROOT"
47 mkdir -p "$RPM_BUILD_ROOT"
/%{_mandir}/man1
/
48 cp
-a doc
/man
/*.1 "$RPM_BUILD_ROOT"
/%{_mandir}/man1
/
51 [ -n "$RPM_BUILD_ROOT"
-a "$RPM_BUILD_ROOT"
!= / ] && rm -rf "$RPM_BUILD_ROOT"
54 %defattr(755,root
,root
)
55 %doc CREDITS LICENSE README
57 %attr(644,-,-) %{_mandir}/man1
/*
58 %{_libdir}/python%{py_libver}/site
-packages
/twisted
/