cleanup
[ub0rlay.git] / media-tv / ivtv-utils / ivtv-utils-1.4.0.ebuild
blob36db929b197c9002a615132b9b8f6bfd2b85883d
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-tv/ivtv-utils/ivtv-utils-1.3.0-r1.ebuild,v 1.3 2009/03/03 16:48:58 beandog Exp $
5 inherit eutils linux-mod
7 DESCRIPTION="IVTV utilities for Hauppauge PVR PCI cards"
8 HOMEPAGE="http://www.ivtvdriver.org"
9 SRC_URI="http://dl.ivtvdriver.org/ivtv/archive/1.4.x/${P}.tar.gz"
10 SLOT="0"
11 LICENSE="GPL-2"
12 KEYWORDS="amd64 ppc x86"
13 IUSE="perl"
14 RDEPEND=">=sys-fs/udev-103"
15 DEPEND="app-arch/unzip
16         >=sys-kernel/linux-headers-2.6.29
17         !media-tv/ivtv"
18 PDEPEND=">=media-tv/ivtv-firmware-20070217
19         perl? (
20                 dev-perl/Video-Frequencies
21                 dev-perl/Video-ivtv
22                 dev-perl/Config-IniFiles
23                 virtual/perl-Getopt-Long
24                 dev-perl/perl-tk )"
26 pkg_setup() {
28         MODULE_NAMES="saa717x(extra:${S}/i2c-drivers)"
29         BUILD_TARGETS="all"
30         CONFIG_CHECK="EXPERIMENTAL HAS_IOMEM FW_LOADER I2C I2C_ALGOBIT
31                 VIDEO_DEV VIDEO_CAPTURE_DRIVERS VIDEO_V4L1 VIDEO_V4L2 VIDEO_IVTV"
33         if ! ( kernel_is ge 2 6 29 ); then
34                 eerror "This package is only for the fully in-kernel"
35                 eerror "IVTV driver shipping with kernel 2.6.29 and higher"
36                 eerror ""
37                 eerror "You will need to either:"
38                 eerror "a) emerge an older version of this package if your kernel is
39                 higher than 2.6.26"
40                 eerror "b) emerge a 2.6.29.x or higher kernel"
41                 eerror "c) emerge media-tv/ivtv"
42                 eerror ""
43                 eerror "See http://ivtvdriver.org/ for more information"
44                 die "This only works on 2.6.29 and newer kernels"
45         fi
47         ewarn ""
48         ewarn "Make sure that your I2C and V4L kernel drivers are loaded as"
49         ewarn "modules, and not compiled into the kernel, or IVTV will not"
50         ewarn "work."
51         ewarn ""
53         linux-mod_pkg_setup
55         BUILD_PARAMS="KDIR=${KV_DIR}"
58 src_unpack() {
59         unpack ${A}
60         cd "${S}"
61         epatch "${FILESDIR}"/${P}-2.6.29.patch
64 src_compile() {
65         emake  || die "failed to build"
68 src_install() {
69         make DESTDIR="${D}" PREFIX="/usr" install || die "failed to install"
70         use perl && dobin utils/perl/*.pl
72         cd "${S}"
73         dodoc README doc/* ChangeLog
74         use perl && dodoc utils/perl/README.ptune
77 pkg_postinst() {
78         elog ""
79         elog "This version of the IVTV utils supports the following hardware:"
80         elog "Hauppauge WinTV PVR-250"
81         elog "Hauppauge WinTV PVR-350"
82         elog "Hauppauge WinTV PVR-150"
83         elog "Hauppauge WinTV PVR-500"
84         elog "AVerMedia M179"
85         elog "Yuan MPG600/Kuroutoshikou iTVC16-STVLP"
86         elog "Yuan MPG160/Kuroutoshikou iTVC15-STVLP"
87         elog "Yuan PG600/DiamondMM PVR-550 (CX Falcon 2)"
88         elog "Adaptec AVC-2410"
89         elog "Adaptec AVC-2010"
90         elog "Nagase Transgear 5000TV"
91         elog "AOpen VA2000MAX-STN6"
92         elog "Yuan MPG600GR/Kuroutoshikou CX23416GYC-STVLP"
93         elog "I/O Data GV-MVP/RX"
94         elog "I/O Data GV-MVP/RX2E"
95         elog "Gotview PCI DVD (preliminary support only)"
96         elog "Gotview PCI DVD2 Deluxe"
97         elog "Yuan MPC622"
98         elog ""
99         ewarn ""
100         ewarn "IMPORTANT: In case of problems first read this page:"
101         ewarn "http://www.ivtvdriver.org/index.php/Troubleshooting"
102         ewarn ""
103         ewarn "If any of these conditions match your setup, you may want to look at the"
104         ewarn "README in /usr/share/doc/${PF}/"
105         ewarn ""
106         ewarn " - Using MythTV, a PVR-350 and the ivtvfb module"
107         ewarn " - Using the ivtv X driver and the ivtvfb module"
108         ewarn " - You want to manually build ivtv against v4l-dvb"
109         ewarn ""
110         ewarn "Also, the ivtv package comes with lots of documentation regarding setup,"
111         ewarn "proper use and debugging utilities."
112         ewarn "They are also located in /usr/share/doc/${PF}/"
113         ewarn ""
114         ewarn "For more information, see the IVTV driver homepage at:"
115         ewarn "http://www.ivtvdriver.org/"