3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
12 DESTDIR
=$(CURDIR
)/debian
/tmp
14 configure
: configure-stamp
23 build-stamp
: configure-stamp
33 rm -f build-stamp configure-stamp
35 # Add here commands to clean up after the build process.
46 # Add here commands to install the package into $(DESTDIR)
47 $(MAKE
) DESTDIR
=$(DESTDIR
) install
50 # Build architecture-independent files here.
51 binary-indep
: build
install
52 # We have nothing to do by default.
54 # Build architecture-dependent files here.
55 binary-arch
: build
install
58 # dh_installchangelogs
59 dh_install
--sourcedir
=debian
/tmp
66 binary
: binary-indep binary-arch
67 .PHONY
: build
clean binary-indep binary-arch binary
install configure