Added 'Longpress key repetition' option to ukeyboard control panel
[ukeyboard.git] / debian / rules
blob668a80928c06395ec00573a7061cad0e3fc70768
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
12 DESTDIR=$(CURDIR)/debian/tmp
14 configure: configure-stamp
15 configure-stamp:
16 dh_testdir
18 touch configure-stamp
21 build: build-stamp
23 build-stamp: configure-stamp
24 dh_testdir
26 $(MAKE)
28 touch build-stamp
30 clean:
31 dh_testdir
32 dh_testroot
33 rm -f build-stamp configure-stamp
35 # Add here commands to clean up after the build process.
36 $(MAKE) clean
38 dh_clean
40 install: build
41 dh_testdir
42 dh_testroot
43 dh_clean -k
44 dh_installdirs
46 # Add here commands to install the package into $(DESTDIR)
47 $(MAKE) DESTDIR=$(DESTDIR) install
50 # Build architecture-independent files here.
51 binary-indep: build install
52 # We have nothing to do by default.
54 # Build architecture-dependent files here.
55 binary-arch: build install
56 dh_testdir
57 dh_testroot
58 # dh_installchangelogs
59 dh_install --sourcedir=debian/tmp
60 dh_fixperms
61 dh_installdeb
62 dh_gencontrol
63 dh_md5sums
64 dh_builddeb
66 binary: binary-indep binary-arch
67 .PHONY: build clean binary-indep binary-arch binary install configure