3 # Uncomment this to turn on verbose mode.
6 # These are used for cross-compiling and for saving the configure script
7 # from having to guess our platform (since we know it already)
8 DEB_HOST_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_HOST_GNU_TYPE
)
9 DEB_BUILD_GNU_TYPE ?
= $(shell dpkg-architecture
-qDEB_BUILD_GNU_TYPE
)
10 ifneq ($(DEB_HOST_GNU_TYPE
),$(DEB_BUILD_GNU_TYPE
))
11 CROSS
= --build
$(DEB_BUILD_GNU_TYPE
) --host
$(DEB_HOST_GNU_TYPE
)
13 CROSS
= --build
$(DEB_BUILD_GNU_TYPE
)
17 config-stamp
: configure
19 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
20 cp
-f
/usr
/share
/misc
/config.sub config.sub
22 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
23 cp
-f
/usr
/share
/misc
/config.guess config.guess
25 .
/configure
$(CROSS
) \
27 --mandir=\
$${prefix}/share
/man \
28 --infodir=\
$${prefix}/share
/info \
29 --localstatedir
=/var \
30 --with-layout
=debian \
31 --program-transform-name
="s/isql/isql-v/" \
34 LDFLAGS
="-Wl,-z,defs -Wl,--no-undefined -Wl,--as-needed"
41 $(MAKE
) -C binsrc
/VirtuosoClient.Net
-f Makefile.mono
42 #docbook-to-man debian/virtuoso.sgml > virtuoso.1
48 rm -f config-stamp build-stamp
49 $(MAKE
) -C binsrc
/VirtuosoClient.Net
-f Makefile.mono
clean
50 [ ! -f Makefile
] ||
$(MAKE
) distclean
51 rm -f config.sub config.guess config.log config.cache config.nice
52 rm -f binsrc
/config
/ccdefs
53 rm -f
$$(find .
-name
"*.log")
54 rm -f binsrc
/tutorial
/make_tutorial_dav_vad.xml
55 rm -f binsrc
/tutorial
/make_tutorial_vad.output
56 rm -f binsrc
/tutorial
/make_tutorial_fs_vad.xml
57 rm -f appsrc
/ODS-Wiki
/version.base
58 rm -f appsrc
/ODS-Wiki
/version.curr
66 $(MAKE
) DESTDIR
=$(CURDIR
)/debian
/tmp
install
67 mv
$(CURDIR
)/debian
/tmp
/usr
/lib
/jdbc-2.0
/* $(CURDIR
)/debian
/libvirtuoso-java
/usr
/share
/java
/
68 mv
$(CURDIR
)/debian
/tmp
/usr
/lib
/jdbc-3.0
/* $(CURDIR
)/debian
/libvirtuoso-java
/usr
/share
/java
/
69 mv
$(CURDIR
)/debian
/tmp
/usr
/lib
/jena
/* $(CURDIR
)/debian
/libvirtuoso-java
/usr
/share
/java
/
70 mv
$(CURDIR
)/debian
/tmp
/usr
/lib
/sesame
/* $(CURDIR
)/debian
/libvirtuoso-java
/usr
/share
/java
/
73 # Build architecture-independent files here.
74 binary-indep
: build
install
76 # Build architecture-dependent files here.
77 binary-arch
: build
install
80 dh_installchangelogs ChangeLog
109 binary
: binary-indep binary-arch
110 .PHONY
: config build
clean binary-indep binary-arch binary
install