iIgnore folders which can not be properly converted to unicode (bug #602).
[wammu.git] / wammu.spec
blob1caed919dda6292a997a43d541f7eb0934306c51
1 %define name wammu
2 %define version 0.27
3 %define rel 1
4 %define extension bz2
6 %define python_gammu_req 0.24
8 %if %{!?py_ver:1}0 == 10
9 %define py_ver %(python -c "import sys; v=sys.version_info[:2]; print '%%d.%%d'%%v" 2>/dev/null || echo PYTHON-NOT-FOUND)
10 %endif
12 %define py_minver %py_ver
13 %define py_maxver %(python -c "import sys; a,b=sys.version_info[:2]; print '%%d.%%d'%%(a,b+1)" 2>/dev/null || echo PYTHON-NOT-FOUND)
15 Summary: Mobile phone manager
16 Name: %{name}
17 Version: %{version}
18 Release: %{rel}
19 Source0: %{name}-%{version}.tar.%{extension}
20 License: GPL
21 %if 0%{?suse_version}
22 Group: Hardware/Mobile
23 %else
24 Group: Applications/Communications
25 %endif
26 Packager: Michal Cihar <michal@cihar.com>
27 Vendor: Michal Cihar <michal@cihar.com>
28 Prefix: %{_prefix}
30 Requires: wxPython >= 2.6, python-gammu >= %{python_gammu_req}, python >= %py_minver, python < %py_maxver
31 BuildRequires: python, python-devel
33 Url: http://wammu.eu/
34 Buildroot: %{_tmppath}/%name-%version-root
35 BuildArch: noarch
37 %description
38 Mobile phone manager using Gammu as it's backend. It works with any phone Gammu
39 supports - many Nokias, Siemens, Alcatel, ... Written using wxGTK.
41 %prep
42 %setup
44 %build
45 CFLAGS="$RPM_OPT_FLAGS" python setup.py build --skip-deps
47 %install
48 python setup.py install --skip-deps --root=$RPM_BUILD_ROOT --record=INSTALLED_FILES --prefix=%{_prefix}
49 sed -i '/man1/ D' INSTALLED_FILES
51 %clean
52 rm -rf $RPM_BUILD_ROOT
54 %files -f INSTALLED_FILES
55 %defattr(-,root,root)
56 %doc README AUTHORS FAQ COPYING ChangeLog
57 %doc %{_mandir}/man1/*