1 # $Id: gdi.spec,v 1.3 1993/07/04 04:04:21 root Exp root $
7 1 pascal SetBkColor
(word long
) SetBkColor
(1 2)
8 2 pascal SetBkMode
(word word
) SetBkMode
(1 2)
9 3 pascal SetMapMode
(word word
) SetMapMode
(1 2)
10 4 pascal SetROP2
(word word
) SetROP2
(1 2)
11 5 pascal SetRelAbs
(word word
) SetRelAbs
(1 2)
12 6 pascal SetPolyFillMode
(word word
) SetPolyFillMode
(1 2)
13 7 pascal SetStretchBltMode
(word word
) SetStretchBltMode
(1 2)
14 8 pascal SetTextCharacterExtra
(word s_word
) SetTextCharacterExtra
(1 2)
15 9 pascal SetTextColor
(word long
) SetTextColor
(1 2)
16 10 pascal SetTextJustification
(word s_word s_word
) SetTextJustification
(1 2 3)
17 11 pascal SetWindowOrg
(word s_word s_word
) SetWindowOrg
(1 2 3)
18 12 pascal SetWindowExt
(word s_word s_word
) SetWindowExt
(1 2 3)
19 13 pascal SetViewportOrg
(word s_word s_word
) SetViewportOrg
(1 2 3)
20 14 pascal SetViewportExt
(word s_word s_word
) SetViewportExt
(1 2 3)
21 15 pascal OffsetWindowOrg
(word s_word s_word
) OffsetWindowOrg
(1 2 3)
22 16 pascal ScaleWindowExt
(word s_word s_word s_word s_word
)
23 ScaleWindowExt
(1 2 3 4 5)
24 17 pascal OffsetViewportOrg
(word s_word s_word
) OffsetViewportOrg
(1 2 3)
25 18 pascal ScaleViewportExt
(word s_word s_word s_word s_word
)
26 ScaleViewportExt
(1 2 3 4 5)
27 19 pascal LineTo
(word s_word s_word
) LineTo
(1 2 3)
28 20 pascal MoveTo
(word s_word s_word
) MoveTo
(1 2 3)
29 21 pascal ExcludeClipRect
(word s_word s_word s_word s_word
)
30 ExcludeClipRect
(1 2 3 4 5)
31 22 pascal IntersectClipRect
(word s_word s_word s_word s_word
)
32 IntersectClipRect
(1 2 3 4 5)
33 23 pascal Arc
(word s_word s_word s_word s_word s_word s_word s_word s_word
)
34 Arc
(1 2 3 4 5 6 7 8 9)
35 24 pascal Ellipse
(word s_word s_word s_word s_word
) Ellipse
(1 2 3 4 5)
36 25 pascal FloodFill
(word word word long
) FloodFill
(1 2 3 4)
37 26 pascal Pie
(word s_word s_word s_word s_word s_word s_word s_word s_word
)
38 Pie
(1 2 3 4 5 6 7 8 9)
39 27 pascal Rectangle
(word s_word s_word s_word s_word
) Rectangle
(1 2 3 4 5)
40 28 pascal RoundRect
(word s_word s_word s_word s_word s_word s_word
)
41 RoundRect
(1 2 3 4 5 6 7)
42 29 pascal PatBlt
(word s_word s_word s_word s_word long
) PatBlt
(1 2 3 4 5 6)
43 30 pascal SaveDC
(word
) SaveDC
(1)
44 31 pascal SetPixel
(word s_word s_word long
) SetPixel
(1 2 3 4)
45 32 pascal OffsetClipRgn
(word s_word s_word
) OffsetClipRgn
(1 2 3)
46 33 pascal TextOut
(word s_word s_word ptr word
) TextOut
(1 2 3 4 5)
47 34 pascal BitBlt
( word s_word s_word s_word s_word word s_word s_word long
)
48 BitBlt
(1 2 3 4 5 6 7 8 9)
49 35 pascal StretchBlt
( word s_word s_word s_word s_word word s_word s_word s_word s_word long
)
50 StretchBlt
(1 2 3 4 5 6 7 8 9 10 11)
51 36 pascal Polygon
(word ptr word
) Polygon
(1 2 3)
52 37 pascal Polyline
(word ptr word
) Polyline
(1 2 3)
53 39 pascal RestoreDC
(word s_word
) RestoreDC
(1 2)
54 40 pascal FillRgn
(word word word
) FillRgn
(1 2 3)
55 43 pascal PaintRgn
(word word
) PaintRgn
(1 2)
56 44 pascal SelectClipRgn
(word word
) SelectClipRgn
(1 2)
57 45 pascal SelectObject
(word word
) SelectObject
(1 2)
58 47 pascal CombineRgn
(word word word word
) CombineRgn
(1 2 3 4)
59 48 pascal CreateBitmap
(word word word word ptr
) CreateBitmap
(1 2 3 4 5)
60 49 pascal CreateBitmapIndirect
(ptr
) CreateBitmapIndirect
(1)
61 50 pascal CreateBrushIndirect
(ptr
) CreateBrushIndirect
(1)
62 51 pascal CreateCompatibleBitmap
(word word word
) CreateCompatibleBitmap
(1 2 3)
63 52 pascal CreateCompatibleDC
(word
) CreateCompatibleDC
(1)
64 53 pascal CreateDC
(ptr ptr ptr ptr
) CreateDC
(1 2 3 4)
65 54 pascal CreateEllipticRgn
(s_word s_word s_word s_word
)
66 CreateEllipticRgn
(1 2 3 4)
67 55 pascal CreateEllipticRgnIndirect
(ptr
) CreateEllipticRgnIndirect
(1)
68 56 pascal CreateFont
(s_word s_word s_word s_word s_word word word word
69 word word word word word ptr
)
70 CreateFont
(1 2 3 4 5 6 7 8 9 10 11 12 13 14)
71 57 pascal CreateFontIndirect
(ptr
) CreateFontIndirect
(1)
72 58 pascal CreateHatchBrush
(word long
) CreateHatchBrush
(1 2)
73 60 pascal CreatePatternBrush
(word
) CreatePatternBrush
(1)
74 61 pascal CreatePen
(s_word s_word long
) CreatePen
(1 2 3)
75 62 pascal CreatePenIndirect
(ptr
) CreatePenIndirect
(1)
76 63 pascal CreatePolygonRgn
(ptr word word
) CreatePolygonRgn
(1 2 3)
77 64 pascal CreateRectRgn
(s_word s_word s_word s_word
) CreateRectRgn
(1 2 3 4)
78 65 pascal CreateRectRgnIndirect
(ptr
) CreateRectRgnIndirect
(1)
79 66 pascal CreateSolidBrush
(long
) CreateSolidBrush
(1)
80 67 pascal DPtoLP
(word ptr s_word
) DPtoLP
(1 2 3)
81 68 pascal DeleteDC
(word
) DeleteDC
(1)
82 69 pascal DeleteObject
(word
) DeleteObject
(1)
83 72 pascal EqualRgn
(word word
) EqualRgn
(1 2)
84 73 pascal ExcludeVisRect
(word s_word s_word s_word s_word
)
85 ExcludeVisRect
(1 2 3 4 5)
86 74 pascal GetBitmapBits
(word long ptr
) GetBitmapBits
(1 2 3)
87 75 pascal GetBkColor
(word
) GetBkColor
(1)
88 76 pascal GetBkMode
(word
) GetBkMode
(1)
89 77 pascal GetClipBox
(word ptr
) GetClipBox
(1 2)
90 78 pascal GetCurrentPosition
(word
) GetCurrentPosition
(1)
91 79 pascal GetDCOrg
(word
) GetDCOrg
(1)
92 80 pascal GetDeviceCaps
(word s_word
) GetDeviceCaps
(1 2)
93 81 pascal GetMapMode
(word
) GetMapMode
(1)
94 82 pascal GetObject
(word word ptr
) GetObject
(1 2 3)
95 83 pascal GetPixel
(word s_word s_word
) GetPixel
(1 2 3)
96 84 pascal GetPolyFillMode
(word
) GetPolyFillMode
(1)
97 85 pascal GetROP2
(word
) GetROP2
(1)
98 86 pascal GetRelAbs
(word
) GetRelAbs
(1)
99 87 pascal GetStockObject
(word
) GetStockObject
(1)
100 88 pascal GetStretchBltMode
(word
) GetStretchBltMode
(1)
101 89 pascal GetTextCharacterExtra
(word
) GetTextCharacterExtra
(1)
102 90 pascal GetTextColor
(word
) GetTextColor
(1)
103 91 pascal GetTextExtent
(word ptr s_word
) GetTextExtent
(1 2 3)
104 93 pascal GetTextMetrics
(word ptr
) GetTextMetrics
(1 2)
105 94 pascal GetViewportExt
(word
) GetViewportExt
(1)
106 95 pascal GetViewportOrg
(word
) GetViewportOrg
(1)
107 96 pascal GetWindowExt
(word
) GetWindowExt
(1)
108 97 pascal GetWindowOrg
(word
) GetWindowOrg
(1)
109 98 pascal IntersectVisRect
(word s_word s_word s_word s_word
)
110 IntersectVisRect
(1 2 3 4 5)
111 99 pascal LPtoDP
(word ptr s_word
) LPtoDP
(1 2 3)
112 100 pascal LineDDA
(s_word s_word s_word s_word ptr long
)
114 101 pascal OffsetRgn
(word s_word s_word
) OffsetRgn
(1 2 3)
115 102 pascal OffsetVisRgn
(word s_word s_word
) OffsetVisRgn
(1 2 3)
116 103 pascal PtVisible
(word s_word s_word
) PtVisible
(1 2 3)
117 104 pascal RectVisibleOld
(word ptr
) RectVisible
(1 2)
118 105 pascal SelectVisRgn
(word word
) SelectVisRgn
(1 2)
119 106 pascal SetBitmapBits
(word long ptr
) SetBitmapBits
(1 2 3)
120 117 pascal SetDCOrg
(word s_word s_word
) SetDCOrg
(1 2 3)
121 128 pascal MulDiv
(s_word s_word s_word
) MulDiv
(1 2 3)
122 129 pascal SaveVisRgn
(word
) SaveVisRgn
(1)
123 130 pascal RestoreVisRgn
(word
) RestoreVisRgn
(1)
124 131 pascal InquireVisRgn
(word
) InquireVisRgn
(1)
125 134 pascal GetRgnBox
(word ptr
) GetRgnBox
(1 2)
126 148 pascal SetBrushOrg
(word s_word s_word
) SetBrushOrg
(1 2 3)
127 149 pascal GetBrushOrg
(word
) GetBrushOrg
(1)
128 150 pascal UnrealizeObject
(word
) UnrealizeObject
(1)
129 153 pascal CreateIC
(ptr ptr ptr ptr
) CreateIC
(1 2 3 4)
130 154 pascal GetNearestColor
(word long
) GetNearestColor
(1 2)
131 161 pascal PtInRegion
(word s_word s_word
) PtInRegion
(1 2 3)
132 162 pascal GetBitmapDimension
(word
) GetBitmapDimension
(1)
133 163 pascal SetBitmapDimension
(word s_word s_word
) SetBitmapDimension
(1 2 3)
134 172 pascal SetRectRgn
(word s_word s_word s_word s_word
) SetRectRgn
(1 2 3 4 5)
135 173 pascal GetClipRgn
(word
) GetClipRgn
(1)
136 179 pascal GetDCState
(word
) GetDCState
(1)
137 180 pascal SetDCState
(word word
) SetDCState
(1 2)
138 181 pascal RectInRegionOld
(word ptr
) RectInRegion
(1 2)
139 250 pascal Copy
(ptr ptr word
) Copy
(1 2 3)
140 345 pascal GetTextAlign
(word
) GetTextAlign
(1)
141 346 pascal SetTextAlign
(word word
) SetTextAlign
(1 2)
142 348 pascal Chord
(word s_word s_word s_word s_word s_word s_word s_word s_word
)
143 Chord
(1 2 3 4 5 6 7 8 9)
144 349 pascal SetMapperFlags
(word word
) SetMapperFlags
(1 2)
145 350 pascal GetCharWidth
(word word word ptr
) GetCharWidth
(1 2 3 4)
146 360 pascal CreatePalette
(ptr
) CreatePalette
(1)
147 361 pascal GDISelectPalette
(word word
) GDISelectPalette
(1 2)
148 362 pascal GDIRealizePalette
(word
) GDIRealizePalette
(1)
149 363 pascal GetPaletteEntries
(word word word ptr
) GetPaletteEntries
(1 2 3 4)
150 364 pascal SetPaletteEntries
(word word word ptr
) SetPaletteEntries
(1 2 3 4)
151 365 pascal RealizeDefaultPalette
(word
) RealizeDefaultPalette
(1)
152 370 pascal GetNearestPaletteIndex
(word long
) GetNearestPaletteIndex
(1 2)
153 375 pascal GetSystemPaletteEntries
(word word word ptr
)
154 GetSystemPaletteEntries
(1 2 3 4)
155 411 pascal GetCurLogFont
(word
) GetCurLogFont
(1)
156 440 pascal SetDIBits
(word word word word ptr ptr word
) SetDIBits
(1 2 3 4 5 6 7)
157 441 pascal GetDIBits
(word word word word ptr ptr word
) GetDIBits
(1 2 3 4 5 6 7)
158 442 pascal CreateDIBitmap
(word ptr long ptr ptr word
)
159 CreateDIBitmap
(1 2 3 4 5 6)
160 443 pascal SetDIBitsToDevice
(word s_word s_word word word word word word word ptr ptr word
)
161 SetDIBitsToDevice
(1 2 3 4 5 6 7 8 9 10 11 12)
162 444 pascal CreateRoundRectRgn
(s_word s_word s_word s_word s_word s_word
)
163 CreateRoundRectRgn
(1 2 3 4 5 6)
164 445 pascal CreateDIBPatternBrush
(word word
) CreateDIBPatternBrush
(1 2)
165 451 pascal CreatePolyPolygonRgn
(ptr ptr word word
)
166 CreatePolyPolygonRgn
(1 2 3 4)
167 465 pascal RectVisible
(word ptr
) RectVisible
(1 2)
168 466 pascal RectInRegion
(word ptr
) RectInRegion
(1 2)
169 468 pascal GetBitmapDimensionEx
(word ptr
) GetBitmapDimensionEx
(1 2)
170 469 pascal GetBrushOrgEx
(word ptr
) GetBrushOrgEx
(1 2)
171 470 pascal GetCurrentPositionEx
(word ptr
) GetCurrentPositionEx
(1 2)
172 471 pascal GetTextExtentPoint
(word ptr s_word ptr
) GetTextExtentPoint
(1 2 3 4)
173 472 pascal GetViewportExtEx
(word ptr
) GetViewportExtEx
(1 2)
174 473 pascal GetViewportOrgEx
(word ptr
) GetViewportOrgEx
(1 2)
175 474 pascal GetWindowExtEx
(word ptr
) GetWindowExtEx
(1 2)
176 475 pascal GetWindowOrgEx
(word ptr
) GetWindowOrgEx
(1 2)
177 476 pascal OffsetViewportOrgEx
(word s_word s_word ptr
)
178 OffsetViewportOrgEx
(1 2 3 4)
179 477 pascal OffsetWindowOrgEx
(word s_word s_word ptr
) OffsetWindowOrgEx
(1 2 3 4)
180 478 pascal SetBitmapDimensionEx
(word s_word s_word ptr
)
181 SetBitmapDimensionEx
(1 2 3 4)
182 479 pascal SetViewportExtEx
(word s_word s_word ptr
) SetViewportExtEx
(1 2 3 4)
183 480 pascal SetViewportOrgEx
(word s_word s_word ptr
) SetViewportOrgEx
(1 2 3 4)
184 481 pascal SetWindowExtEx
(word s_word s_word ptr
) SetWindowExtEx
(1 2 3 4)
185 482 pascal SetWindowOrgEx
(word s_word s_word ptr
) SetWindowOrgEx
(1 2 3 4)
186 483 pascal MoveToEx
(word s_word s_word ptr
) MoveToEx
(1 2 3 4)
187 484 pascal ScaleViewportExtEx
(word s_word s_word s_word s_word ptr
)
188 ScaleViewportExtEx
(1 2 3 4 5 6)
189 485 pascal ScaleWindowExtEx
(word s_word s_word s_word s_word ptr
)
190 ScaleWindowExtEx
(1 2 3 4 5 6)