6 import
-delay winmm.dll
13 debug_channels
(animate comboex commctrl datetime header hotkey imagelist ipaddress
14 listview message monthcal nativefont pager progress propsheet
15 rebar statusbar tab toolbar tooltips trackbar treeview updown
)
17 # Functions exported by the Win95 comctl32.dll
18 # (these need to have these exact ordinals, because some win95 dlls
19 # import comctl32.dll by ordinal)
20 # This list was created from a comctl32.dll v5.81 (IE5.01).
22 2 stdcall MenuHelp
(long long long long long long ptr
) MenuHelp
23 3 stdcall ShowHideMenuCtl
(long long ptr
) ShowHideMenuCtl
24 4 stdcall GetEffectiveClientRect
(long long long
) GetEffectiveClientRect
25 5 stdcall DrawStatusTextA
(long ptr str long
) DrawStatusTextA
26 6 stdcall CreateStatusWindowA
(long str long long
) CreateStatusWindowA
27 7 stdcall CreateToolbar
(long long long long long long ptr long
) CreateToolbar
28 8 stdcall CreateMappedBitmap
(long long long ptr long
) CreateMappedBitmap
29 9 stdcall DPA_LoadStream
(ptr ptr ptr long
) DPA_LoadStream
30 10 stdcall DPA_SaveStream
(ptr ptr ptr long
) DPA_SaveStream
31 11 stdcall DPA_Merge
(ptr ptr long ptr ptr long
) DPA_Merge
32 #12 stub Cctl1632_ThunkData32
33 13 stdcall MakeDragList
(long
) MakeDragList
34 14 stdcall LBItemFromPt
(long long long long
) LBItemFromPt
35 15 stdcall DrawInsert
(long long long
) DrawInsert
36 16 stdcall CreateUpDownControl
(long long long long long long long long long long long long
) CreateUpDownControl
37 17 stdcall InitCommonControls
() InitCommonControls
38 18 stdcall CreatePropertySheetPage
(ptr
) CreatePropertySheetPageA
39 19 stdcall CreatePropertySheetPageA
(ptr
) CreatePropertySheetPageA
40 20 stdcall CreatePropertySheetPageW
(ptr
) CreatePropertySheetPageW
41 21 stdcall CreateStatusWindow
(long str long long
) CreateStatusWindowA
42 22 stdcall CreateStatusWindowW
(long wstr long long
) CreateStatusWindowW
43 23 stdcall CreateToolbarEx
(long long long long long long ptr long long long long long long
) CreateToolbarEx
44 24 stdcall DestroyPropertySheetPage
(long
) DestroyPropertySheetPage
45 25 stdcall DllGetVersion
(ptr
) COMCTL32_DllGetVersion
46 26 stdcall DllInstall
(long ptr
) COMCTL32_DllInstall
47 27 stdcall DrawStatusText
(long ptr ptr long
) DrawStatusTextA
48 28 stdcall DrawStatusTextW
(long ptr wstr long
) DrawStatusTextW
49 29 stdcall FlatSB_EnableScrollBar
(long long long
) FlatSB_EnableScrollBar
50 30 stdcall FlatSB_GetScrollInfo
(long long ptr
) FlatSB_GetScrollInfo
51 31 stdcall FlatSB_GetScrollPos
(long long
) FlatSB_GetScrollPos
52 32 stdcall FlatSB_GetScrollProp
(long long ptr
) FlatSB_GetScrollProp
53 33 stdcall FlatSB_GetScrollRange
(long long ptr ptr
) FlatSB_GetScrollRange
54 34 stdcall FlatSB_SetScrollInfo
(long long ptr long
) FlatSB_SetScrollInfo
55 35 stdcall FlatSB_SetScrollPos
(long long long long
) FlatSB_SetScrollPos
56 36 stdcall FlatSB_SetScrollProp
(long long long long
) FlatSB_SetScrollProp
57 37 stdcall FlatSB_SetScrollRange
(long long long long long
) FlatSB_SetScrollRange
58 38 stdcall FlatSB_ShowScrollBar
(long long long
) FlatSB_ShowScrollBar
59 39 stdcall GetMUILanguage
() GetMUILanguage
60 40 stdcall ImageList_Add
(ptr long long
) ImageList_Add
61 41 stdcall ImageList_AddIcon
(ptr long
) ImageList_AddIcon
62 42 stdcall ImageList_AddMasked
(ptr long long
) ImageList_AddMasked
63 43 stdcall ImageList_BeginDrag
(ptr long long long
) ImageList_BeginDrag
64 44 stdcall ImageList_Copy
(ptr long ptr long long
) ImageList_Copy
65 45 stdcall ImageList_Create
(long long long long long
) ImageList_Create
66 46 stdcall ImageList_Destroy
(ptr
) ImageList_Destroy
67 47 stdcall ImageList_DragEnter
(long long long
) ImageList_DragEnter
68 48 stdcall ImageList_DragLeave
(long
) ImageList_DragLeave
69 49 stdcall ImageList_DragMove
(long long
) ImageList_DragMove
70 50 stdcall ImageList_DragShowNolock
(long
) ImageList_DragShowNolock
71 51 stdcall ImageList_Draw
(ptr long long long long long
) ImageList_Draw
72 52 stdcall ImageList_DrawEx
(ptr long long long long long long long long long
) ImageList_DrawEx
73 53 stdcall ImageList_DrawIndirect
(ptr
) ImageList_DrawIndirect
74 54 stdcall ImageList_Duplicate
(ptr
) ImageList_Duplicate
75 55 stdcall ImageList_EndDrag
() ImageList_EndDrag
76 56 stdcall ImageList_GetBkColor
(ptr
) ImageList_GetBkColor
77 57 stdcall ImageList_GetDragImage
(ptr ptr
) ImageList_GetDragImage
78 58 stub ImageList_GetFlags
79 59 stdcall ImageList_GetIcon
(ptr long long
) ImageList_GetIcon
80 60 stdcall ImageList_GetIconSize
(ptr ptr ptr
) ImageList_GetIconSize
81 61 stdcall ImageList_GetImageCount
(ptr
) ImageList_GetImageCount
82 62 stdcall ImageList_GetImageInfo
(ptr long ptr
) ImageList_GetImageInfo
83 63 stdcall ImageList_GetImageRect
(ptr long ptr
) ImageList_GetImageRect
84 64 stdcall ImageList_LoadImage
(long str long long long long long
) ImageList_LoadImageA
85 65 stdcall ImageList_LoadImageA
(long str long long long long long
) ImageList_LoadImageA
86 66 stdcall ImageList_LoadImageW
(long wstr long long long long long
) ImageList_LoadImageW
87 67 stdcall ImageList_Merge
(ptr long ptr long long long
) ImageList_Merge
88 68 stdcall ImageList_Read
(ptr
) ImageList_Read
89 69 stdcall ImageList_Remove
(ptr long
) ImageList_Remove
90 70 stdcall ImageList_Replace
(ptr long long long
) ImageList_Replace
91 71 stdcall Alloc
(long
) COMCTL32_Alloc
92 72 stdcall ReAlloc
(ptr long
) COMCTL32_ReAlloc
93 73 stdcall Free
(ptr
) COMCTL32_Free
94 74 stdcall GetSize
(ptr
) COMCTL32_GetSize
95 75 stdcall ImageList_ReplaceIcon
(ptr long long
) ImageList_ReplaceIcon
96 76 stdcall ImageList_SetBkColor
(ptr long
) ImageList_SetBkColor
97 77 stdcall ImageList_SetDragCursorImage
(ptr long long long
) ImageList_SetDragCursorImage
98 78 stdcall ImageList_SetFilter
(ptr long long
) ImageList_SetFilter
99 79 stub ImageList_SetFlags
100 80 stdcall ImageList_SetIconSize
(ptr long long
) ImageList_SetIconSize
101 81 stdcall ImageList_SetImageCount
(ptr long
) ImageList_SetImageCount
102 82 stdcall ImageList_SetOverlayImage
(ptr long long
) ImageList_SetOverlayImage
103 83 stdcall ImageList_Write
(ptr ptr
) ImageList_Write
104 84 stdcall InitCommonControlsEx
(ptr
) InitCommonControlsEx
105 85 stdcall InitMUILanguage
(long
) InitMUILanguage
106 86 stdcall InitializeFlatSB
(long
) InitializeFlatSB
107 87 stdcall PropertySheet
(ptr
) PropertySheetA
108 88 stdcall PropertySheetA
(ptr
) PropertySheetA
109 89 stdcall PropertySheetW
(ptr
) PropertySheetW
110 90 stdcall UninitializeFlatSB
(long
) UninitializeFlatSB
111 91 stdcall _TrackMouseEvent
(ptr
) _TrackMouseEvent
113 151 stdcall CreateMRUListA
(ptr
) CreateMRUListA
114 152 stdcall FreeMRUList
(ptr
) FreeMRUListA
115 153 stdcall AddMRUStringA
(long str
) AddMRUStringA
116 154 stdcall EnumMRUListA
(long long ptr long
) EnumMRUListA
117 155 stdcall FindMRUStringA
(long str ptr
) FindMRUStringA
118 156 stdcall DelMRUString
(long long
) DelMRUString
119 157 stdcall CreateMRUListLazyA
(ptr long long long
) CreateMRUListLazyA
122 164 stub CreateProxyPage
124 167 stdcall AddMRUData
(long ptr long
) AddMRUData
125 169 stdcall FindMRUData
(long ptr long ptr
) FindMRUData
127 233 stdcall Str_GetPtrA
(str str long
) Str_GetPtrA
128 234 stdcall Str_SetPtrA
(str str
) Str_SetPtrA
129 235 stdcall Str_GetPtrW
(wstr wstr long
) Str_GetPtrW
130 236 stdcall Str_SetPtrW
(wstr wstr
) Str_SetPtrW
132 320 stdcall DSA_Create
(long long
) DSA_Create
133 321 stdcall DSA_Destroy
(ptr
) DSA_Destroy
134 322 stdcall DSA_GetItem
(ptr long long
) DSA_GetItem
135 323 stdcall DSA_GetItemPtr
(ptr long
) DSA_GetItemPtr
136 324 stdcall DSA_InsertItem
(ptr long long
) DSA_InsertItem
137 325 stdcall DSA_SetItem
(ptr long long
) DSA_SetItem
138 326 stdcall DSA_DeleteItem
(ptr long
) DSA_DeleteItem
139 327 stdcall DSA_DeleteAllItems
(ptr
) DSA_DeleteAllItems
140 328 stdcall DPA_Create
(long
) DPA_Create
141 329 stdcall DPA_Destroy
(ptr
) DPA_Destroy
142 330 stdcall DPA_Grow
(ptr long
) DPA_Grow
143 331 stdcall DPA_Clone
(ptr ptr
) DPA_Clone
144 332 stdcall DPA_GetPtr
(ptr long
) DPA_GetPtr
145 333 stdcall DPA_GetPtrIndex
(ptr ptr
) DPA_GetPtrIndex
146 334 stdcall DPA_InsertPtr
(ptr long ptr
) DPA_InsertPtr
147 335 stdcall DPA_SetPtr
(ptr long ptr
) DPA_SetPtr
148 336 stdcall DPA_DeletePtr
(ptr long
) DPA_DeletePtr
149 337 stdcall DPA_DeleteAllPtrs
(ptr
) DPA_DeleteAllPtrs
150 338 stdcall DPA_Sort
(ptr ptr long
) DPA_Sort
151 339 stdcall DPA_Search
(ptr ptr long ptr long long
) DPA_Search
152 340 stdcall DPA_CreateEx
(long long
) DPA_CreateEx
153 341 stdcall SendNotify
(long long long ptr
) COMCTL32_SendNotify
154 342 stdcall SendNotifyEx
(long long long ptr long
) COMCTL32_SendNotifyEx
156 350 stdcall StrChrA
(str str
) COMCTL32_StrChrA
157 351 stdcall StrRChrA
(str str long
) COMCTL32_StrRChrA
158 352 stdcall StrCmpNA
(str str long
) COMCTL32_StrCmpNA
159 353 stdcall StrCmpNIA
(str str long
) COMCTL32_StrCmpNIA
160 354 stdcall StrStrA
(str str
) COMCTL32_StrStrA
161 355 stdcall StrStrIA
(str str
) COMCTL32_StrStrIA
162 356 stdcall StrCSpnA
(str str
) COMCTL32_StrCSpnA
163 357 stdcall StrToIntA
(str
) COMCTL32_StrToIntA
164 358 stdcall StrChrW
(wstr long
) COMCTL32_StrChrW
165 359 stdcall StrRChrW
(wstr wstr long
) COMCTL32_StrRChrW
166 360 stdcall StrCmpNW
(wstr wstr long
) COMCTL32_StrCmpNW
167 361 stdcall StrCmpNIW
(wstr wstr long
) COMCTL32_StrCmpNIW
168 362 stdcall StrStrW
(wstr wstr
) COMCTL32_StrStrW
170 364 stdcall StrSpnW
(wstr wstr
) COMCTL32_StrSpnW
171 365 stdcall StrToIntW
(wstr
) COMCTL32_StrToIntW
181 376 stub IntlStrEqWorkerA@
16
182 377 stub IntlStrEqWorkerW@
16
184 382 stdcall SmoothScrollWindow
(ptr
) SmoothScrollWindow
185 383 stub DoReaderMode@
4
186 384 stub SetPathWordBreakProc@
8
187 385 stdcall DPA_EnumCallback
(long long long
) DPA_EnumCallback
188 386 stdcall DPA_DestroyCallback
(ptr ptr long
) DPA_DestroyCallback
189 387 stdcall DSA_EnumCallback
(ptr ptr long
) DSA_EnumCallback
190 388 stdcall DSA_DestroyCallback
(ptr ptr long
) DSA_DestroyCallback
194 400 stub CreateMRUListW@
4
195 401 stub AddMRUStringW@
8
196 402 stub FindMRUStringW@
12
197 403 stub EnumMRUListW@
16
198 404 stub CreateMRUListLazyW@
16
200 410 stdcall @
(long long long long
) COMCTL32_410
201 411 stdcall @
(long long long
) COMCTL32_411
202 412 stdcall @
(long long long
) COMCTL32_412
203 413 stdcall @
(long long long long
) COMCTL32_413
205 415 stdcall @
(long long long long long
) COMCTL32_415