Move the name directive from the .spec file to the Makefile.
[wine/gsoc_dplay.git] / dlls / user / user.exe.spec
blobe85d69c2ba7dd1109dc47a297ce78ddb8a84fd45
1 heap 65520
2 rsrc resources/version16.res
4 1 pascal16 MessageBox(word str str word) MessageBox16
5 2 stub OldExitWindows
6 3 stub EnableOEMLayer
7 4 stub DisableOEMLayer
8 5 pascal16 InitApp(word) InitApp16
9 6 pascal16 PostQuitMessage(word) PostQuitMessage16
10 7 pascal16 ExitWindows(long word) ExitWindows16
11 10 pascal16 SetTimer(word word word segptr) SetTimer16
12 11 pascal16 SetSystemTimer(word word word segptr) SetSystemTimer16 # BEAR11
13 12 pascal16 KillTimer(word word) KillTimer16
14 13 pascal GetTickCount() GetTickCount
15 14 pascal GetTimerResolution() GetTimerResolution16
16 # GetCurrentTime is effectively identical to GetTickCount
17 15 pascal GetCurrentTime() GetTickCount
18 16 pascal16 ClipCursor(ptr) ClipCursor16
19 17 pascal16 GetCursorPos(ptr) GetCursorPos16
20 18 pascal16 SetCapture(word) SetCapture16
21 19 pascal16 ReleaseCapture() ReleaseCapture16
22 20 pascal16 SetDoubleClickTime(word) SetDoubleClickTime16
23 21 pascal16 GetDoubleClickTime() GetDoubleClickTime16
24 22 pascal16 SetFocus(word) SetFocus16
25 23 pascal16 GetFocus() GetFocus16
26 24 pascal16 RemoveProp(word ptr) RemoveProp16
27 25 pascal16 GetProp(word str) GetProp16
28 26 pascal16 SetProp(word str word) SetProp16
29 27 pascal16 EnumProps(word segptr) EnumProps16
30 28 pascal16 ClientToScreen(word ptr) ClientToScreen16
31 29 pascal16 ScreenToClient(word ptr) ScreenToClient16
32 30 pascal16 WindowFromPoint(long) WindowFromPoint16
33 31 pascal16 IsIconic(word) IsIconic16
34 32 pascal16 GetWindowRect(word ptr) GetWindowRect16
35 33 pascal16 GetClientRect(word ptr) GetClientRect16
36 34 pascal16 EnableWindow(word word) EnableWindow16
37 35 pascal16 IsWindowEnabled(word) IsWindowEnabled16
38 36 pascal16 GetWindowText(word segptr word) GetWindowText16
39 37 pascal16 SetWindowText(word segstr) SetWindowText16
40 38 pascal16 GetWindowTextLength(word) GetWindowTextLength16
41 39 pascal16 BeginPaint(word ptr) BeginPaint16
42 40 pascal16 EndPaint(word ptr) EndPaint16
43 41 pascal16 CreateWindow(str str long s_word s_word s_word s_word word word word segptr) CreateWindow16
44 42 pascal16 ShowWindow(word word) ShowWindow16
45 43 pascal16 CloseWindow(word) CloseWindow16
46 44 pascal16 OpenIcon(word) OpenIcon16
47 45 pascal16 BringWindowToTop(word) BringWindowToTop16
48 46 pascal16 GetParent(word) GetParent16
49 47 pascal16 IsWindow(word) IsWindow16
50 48 pascal16 IsChild(word word) IsChild16
51 49 pascal16 IsWindowVisible(word) IsWindowVisible16
52 50 pascal16 FindWindow(str str) FindWindow16
53 51 stub BEAR51 # IsTwoByteCharPrefix
54 52 pascal16 AnyPopup() AnyPopup16
55 53 pascal16 DestroyWindow(word) DestroyWindow16
56 54 pascal16 EnumWindows(segptr long) EnumWindows16
57 55 pascal16 EnumChildWindows(word segptr long) EnumChildWindows16
58 56 pascal16 MoveWindow(word word word word word word) MoveWindow16
59 57 pascal16 RegisterClass(ptr) RegisterClass16
60 58 pascal16 GetClassName(word ptr word) GetClassName16
61 59 pascal16 SetActiveWindow(word) SetActiveWindow16
62 60 pascal16 GetActiveWindow() GetActiveWindow16
63 61 pascal16 ScrollWindow(word s_word s_word ptr ptr) ScrollWindow16
64 62 pascal16 SetScrollPos(word word s_word word) SetScrollPos16
65 63 pascal16 GetScrollPos(word word) GetScrollPos16
66 64 pascal16 SetScrollRange(word word s_word s_word word) SetScrollRange16
67 65 pascal16 GetScrollRange(word word ptr ptr) GetScrollRange16
68 66 pascal16 GetDC(word) GetDC16
69 67 pascal16 GetWindowDC(word) GetWindowDC16
70 68 pascal16 ReleaseDC(word word) ReleaseDC16
71 69 pascal16 SetCursor(word) SetCursor16
72 70 pascal16 SetCursorPos(word word) SetCursorPos16
73 71 pascal16 ShowCursor(word) ShowCursor16
74 72 pascal16 SetRect(ptr s_word s_word s_word s_word) SetRect16
75 73 pascal16 SetRectEmpty(ptr) SetRectEmpty16
76 74 pascal16 CopyRect(ptr ptr) CopyRect16
77 75 pascal16 IsRectEmpty(ptr) IsRectEmpty16
78 76 pascal16 PtInRect(ptr long) PtInRect16
79 77 pascal16 OffsetRect(ptr s_word s_word) OffsetRect16
80 78 pascal16 InflateRect(ptr s_word s_word) InflateRect16
81 79 pascal16 IntersectRect(ptr ptr ptr) IntersectRect16
82 80 pascal16 UnionRect(ptr ptr ptr) UnionRect16
83 81 pascal16 FillRect(word ptr word) FillRect16
84 82 pascal16 InvertRect(word ptr) InvertRect16
85 83 pascal16 FrameRect(word ptr word) FrameRect16
86 84 pascal16 DrawIcon(word s_word s_word word) DrawIcon16
87 85 pascal16 DrawText(word str s_word ptr word) DrawText16
88 86 pascal IconSize() IconSize16 # later versions: BEAR86
89 87 pascal16 DialogBox(word str word segptr) DialogBox16
90 88 pascal16 EndDialog(word s_word) EndDialog16
91 89 pascal16 CreateDialog(word str word segptr) CreateDialog16
92 90 pascal16 IsDialogMessage(word ptr) IsDialogMessage16
93 91 pascal16 GetDlgItem(word word) GetDlgItem16
94 92 pascal16 SetDlgItemText(word word segstr) SetDlgItemText16
95 93 pascal16 GetDlgItemText(word word segptr word) GetDlgItemText16
96 94 pascal16 SetDlgItemInt(word word word word) SetDlgItemInt16
97 95 pascal16 GetDlgItemInt(word s_word ptr word) GetDlgItemInt16
98 96 pascal16 CheckRadioButton(word word word word) CheckRadioButton16
99 97 pascal16 CheckDlgButton(word word word) CheckDlgButton16
100 98 pascal16 IsDlgButtonChecked(word word) IsDlgButtonChecked16
101 99 pascal16 DlgDirSelect(word ptr word) DlgDirSelect16
102 100 pascal16 DlgDirList(word str word word word) DlgDirList16
103 101 pascal SendDlgItemMessage(word word word word long) SendDlgItemMessage16
104 102 pascal16 AdjustWindowRect(ptr long word) AdjustWindowRect16
105 103 pascal16 MapDialogRect(word ptr) MapDialogRect16
106 104 pascal16 MessageBeep(word) MessageBeep16
107 105 pascal16 FlashWindow(word word) FlashWindow16
108 106 pascal16 GetKeyState(word) GetKeyState16
109 107 pascal DefWindowProc(word word word long) DefWindowProc16
110 108 pascal16 GetMessage(ptr word word word) GetMessage16
111 109 pascal16 PeekMessage(ptr word word word word) PeekMessage16
112 110 pascal16 PostMessage(word word word long) PostMessage16
113 111 pascal SendMessage(word word word long) SendMessage16
114 112 pascal16 WaitMessage() WaitMessage
115 113 pascal16 TranslateMessage(ptr) TranslateMessage16
116 114 pascal DispatchMessage(ptr) DispatchMessage16
117 115 pascal16 ReplyMessage(long) ReplyMessage16
118 116 pascal16 PostAppMessage(word word word long) PostAppMessage16
119 117 pascal16 WindowFromDC(word) WindowFromDC16 # not in W1.1, W2.0
120 118 pascal16 RegisterWindowMessage(str) RegisterWindowMessageA
121 119 pascal GetMessagePos() GetMessagePos
122 120 pascal GetMessageTime() GetMessageTime
123 121 pascal SetWindowsHook(s_word segptr) SetWindowsHook16
124 122 pascal CallWindowProc(segptr word word word long) CallWindowProc16
125 123 pascal16 CallMsgFilter(segptr s_word) CallMsgFilter16
126 124 pascal16 UpdateWindow(word) UpdateWindow16
127 125 pascal16 InvalidateRect(word ptr word) InvalidateRect16
128 126 pascal16 InvalidateRgn(word word word) InvalidateRgn16
129 127 pascal16 ValidateRect(word ptr) ValidateRect16
130 128 pascal16 ValidateRgn(word word) ValidateRgn16
131 129 pascal16 GetClassWord(word s_word) GetClassWord16
132 130 pascal16 SetClassWord(word s_word word) SetClassWord16
133 131 pascal GetClassLong(word s_word) GetClassLong16
134 132 pascal SetClassLong(word s_word long) SetClassLong16
135 133 pascal16 GetWindowWord(word s_word) GetWindowWord16
136 134 pascal16 SetWindowWord(word s_word word) SetWindowWord16
137 135 pascal GetWindowLong(word s_word) GetWindowLong16
138 136 pascal SetWindowLong(word s_word long) SetWindowLong16
139 137 pascal16 OpenClipboard(word) OpenClipboard16
140 138 pascal16 CloseClipboard() CloseClipboard16
141 139 pascal16 EmptyClipboard() EmptyClipboard16
142 140 pascal16 GetClipboardOwner() GetClipboardOwner16
143 141 pascal16 SetClipboardData(word word) SetClipboardData16
144 142 pascal16 GetClipboardData(word) GetClipboardData16
145 143 pascal16 CountClipboardFormats() CountClipboardFormats16
146 144 pascal16 EnumClipboardFormats(word) EnumClipboardFormats16
147 145 pascal16 RegisterClipboardFormat(ptr) RegisterClipboardFormat16
148 146 pascal16 GetClipboardFormatName(word ptr s_word) GetClipboardFormatName16
149 147 pascal16 SetClipboardViewer(word) SetClipboardViewer16
150 148 pascal16 GetClipboardViewer() GetClipboardViewer16
151 149 pascal16 ChangeClipboardChain(word word) ChangeClipboardChain16
152 150 pascal16 LoadMenu(word str) LoadMenu16
153 151 pascal16 CreateMenu() CreateMenu16
154 152 pascal16 DestroyMenu(word) DestroyMenu16
155 153 pascal16 ChangeMenu(word word segstr word word) ChangeMenu16
156 154 pascal16 CheckMenuItem(word word word) CheckMenuItem16
157 155 pascal16 EnableMenuItem(word word word) EnableMenuItem16
158 156 pascal16 GetSystemMenu(word word) GetSystemMenu16
159 157 pascal16 GetMenu(word) GetMenu16
160 158 pascal16 SetMenu(word word) SetMenu16
161 159 pascal16 GetSubMenu(word word) GetSubMenu16
162 160 pascal16 DrawMenuBar(word) DrawMenuBar16
163 161 pascal16 GetMenuString(word word ptr s_word word) GetMenuString16
164 162 pascal16 HiliteMenuItem(word word word word) HiliteMenuItem16
165 163 pascal16 CreateCaret(word word word word) CreateCaret16
166 164 pascal16 DestroyCaret() DestroyCaret16
167 165 pascal16 SetCaretPos(word word) SetCaretPos16
168 166 pascal16 HideCaret(word) HideCaret16
169 167 pascal16 ShowCaret(word) ShowCaret16
170 168 pascal16 SetCaretBlinkTime(word) SetCaretBlinkTime16
171 169 pascal16 GetCaretBlinkTime() GetCaretBlinkTime16
172 170 pascal16 ArrangeIconicWindows(word) ArrangeIconicWindows16 # W1.1: CREATECONVERTWINDOW, W2.0: nothing !
173 171 pascal16 WinHelp(word str word long) WinHelp16 # W1.1: SHOWCONVERTWINDOW, W2.0: nothing !
174 172 pascal16 SwitchToThisWindow(word word) SwitchToThisWindow16 # W1.1: SETCONVERTWINDOWHEIGHT, W2.0: nothing !
175 173 pascal16 LoadCursor(word str) LoadCursor16
176 174 pascal16 LoadIcon(word str) LoadIcon16
177 175 pascal16 LoadBitmap(word str) LoadBitmap16
178 176 pascal16 LoadString(word word ptr s_word) LoadString16
179 177 pascal16 LoadAccelerators(word str) LoadAccelerators16
180 178 pascal16 TranslateAccelerator(word word ptr) TranslateAccelerator16
181 179 pascal16 GetSystemMetrics(s_word) GetSystemMetrics16
182 180 pascal GetSysColor(word) GetSysColor16
183 181 pascal16 SetSysColors(word ptr ptr) SetSysColors16
184 182 pascal16 KillSystemTimer(word word) KillSystemTimer16 # BEAR182
185 183 pascal16 GetCaretPos(ptr) GetCaretPos16
186 184 stub QuerySendMessage # W1.1, W2.0: SYSHASKANJI
187 185 pascal16 GrayString(word word segptr segptr s_word s_word s_word s_word s_word) GrayString16
188 186 pascal16 SwapMouseButton(word) SwapMouseButton16
189 187 pascal16 EndMenu() EndMenu
190 188 pascal16 SetSysModalWindow(word) SetSysModalWindow16
191 189 pascal16 GetSysModalWindow() GetSysModalWindow16
192 190 pascal16 GetUpdateRect(word ptr word) GetUpdateRect16
193 191 pascal16 ChildWindowFromPoint(word long) ChildWindowFromPoint16
194 192 pascal16 InSendMessage() InSendMessage16
195 193 pascal16 IsClipboardFormatAvailable(word) IsClipboardFormatAvailable16
196 194 pascal16 DlgDirSelectComboBox(word ptr word) DlgDirSelectComboBox16
197 195 pascal16 DlgDirListComboBox(word ptr word word word) DlgDirListComboBox16
198 196 pascal TabbedTextOut(word s_word s_word ptr s_word s_word ptr s_word) TabbedTextOut16
199 197 pascal GetTabbedTextExtent(word ptr word word ptr) GetTabbedTextExtent16
200 198 pascal16 CascadeChildWindows(word word) CascadeChildWindows16
201 199 pascal16 TileChildWindows(word word) TileChildWindows16
202 200 pascal16 OpenComm(str word word) OpenComm16
203 201 pascal16 SetCommState(ptr) SetCommState16
204 202 pascal16 GetCommState(word ptr) GetCommState16
205 203 pascal16 GetCommError(word ptr) GetCommError16
206 204 pascal16 ReadComm(word ptr word) ReadComm16
207 205 pascal16 WriteComm(word ptr word) WriteComm16
208 206 pascal16 TransmitCommChar(word word) TransmitCommChar16
209 207 pascal16 CloseComm(word) CloseComm16
210 208 pascal SetCommEventMask(word word) SetCommEventMask16
211 209 pascal16 GetCommEventMask(word word) GetCommEventMask16
212 210 pascal16 SetCommBreak(word) SetCommBreak16
213 211 pascal16 ClearCommBreak(word) ClearCommBreak16
214 212 pascal16 UngetCommChar(word word) UngetCommChar16
215 213 pascal16 BuildCommDCB(ptr ptr) BuildCommDCB16
216 214 pascal EscapeCommFunction(word word) EscapeCommFunction16
217 215 pascal16 FlushComm(word word) FlushComm16
218 216 pascal UserSeeUserDo(word word word word) UserSeeUserDo16 # W1.1, W2.0: MYOPENCOMM
219 #217-299 not in W1.1
220 217 pascal16 LookupMenuHandle(word s_word) LookupMenuHandle16
221 218 pascal16 DialogBoxIndirect(word word word segptr) DialogBoxIndirect16
222 219 pascal16 CreateDialogIndirect(word ptr word segptr) CreateDialogIndirect16
223 220 pascal16 LoadMenuIndirect(ptr) LoadMenuIndirect16
224 221 pascal16 ScrollDC(word s_word s_word ptr ptr word ptr) ScrollDC16
225 222 pascal16 GetKeyboardState(ptr) GetKeyboardState
226 223 pascal16 SetKeyboardState(ptr) SetKeyboardState
227 224 pascal16 GetWindowTask(word) GetWindowTask16
228 225 pascal16 EnumTaskWindows(word segptr long) EnumTaskWindows16
229 226 stub LockInput # not in W2.0
230 227 pascal16 GetNextDlgGroupItem(word word word) GetNextDlgGroupItem16
231 228 pascal16 GetNextDlgTabItem(word word word) GetNextDlgTabItem16
232 229 pascal16 GetTopWindow(word) GetTopWindow16
233 230 pascal16 GetNextWindow(word word) GetNextWindow16
234 231 pascal16 GetSystemDebugState() GetSystemDebugState16
235 232 pascal16 SetWindowPos(word word word word word word word) SetWindowPos16
236 233 pascal16 SetParent(word word) SetParent16
237 234 pascal16 UnhookWindowsHook(s_word segptr) UnhookWindowsHook16
238 235 pascal DefHookProc(s_word word long ptr) DefHookProc16
239 236 pascal16 GetCapture() GetCapture16
240 237 pascal16 GetUpdateRgn(word word word) GetUpdateRgn16
241 238 pascal16 ExcludeUpdateRgn(word word) ExcludeUpdateRgn16
242 239 pascal16 DialogBoxParam(word str word segptr long) DialogBoxParam16
243 240 pascal16 DialogBoxIndirectParam(word word word segptr long) DialogBoxIndirectParam16
244 241 pascal16 CreateDialogParam(word str word segptr long) CreateDialogParam16
245 242 pascal16 CreateDialogIndirectParam(word ptr word segptr long) CreateDialogIndirectParam16
246 243 pascal GetDialogBaseUnits() GetDialogBaseUnits
247 244 pascal16 EqualRect(ptr ptr) EqualRect16
248 245 pascal16 EnableCommNotification(s_word word s_word s_word) EnableCommNotification16
249 246 pascal16 ExitWindowsExec(str str) ExitWindowsExec16
250 247 pascal16 GetCursor() GetCursor16
251 248 pascal16 GetOpenClipboardWindow() GetOpenClipboardWindow16
252 249 pascal16 GetAsyncKeyState(word) GetAsyncKeyState16
253 250 pascal16 GetMenuState(word word word) GetMenuState16
254 251 pascal SendDriverMessage(word word long long) SendDriverMessage16
255 252 pascal16 OpenDriver(str str long) OpenDriver16
256 253 pascal CloseDriver(word long long) CloseDriver16
257 254 pascal16 GetDriverModuleHandle(word) GetDriverModuleHandle16
258 255 pascal DefDriverProc(long word word long long) DefDriverProc16
259 256 pascal16 GetDriverInfo(word ptr) GetDriverInfo16
260 257 pascal16 GetNextDriver(word long) GetNextDriver16
261 258 pascal16 MapWindowPoints(word word ptr word) MapWindowPoints16
262 259 pascal16 BeginDeferWindowPos(s_word) BeginDeferWindowPos16
263 260 pascal16 DeferWindowPos(word word word s_word s_word s_word s_word word) DeferWindowPos16
264 261 pascal16 EndDeferWindowPos(word) EndDeferWindowPos16
265 262 pascal16 GetWindow(word word) GetWindow16
266 263 pascal16 GetMenuItemCount(word) GetMenuItemCount16
267 264 pascal16 GetMenuItemID(word word) GetMenuItemID16
268 265 pascal16 ShowOwnedPopups(word word) ShowOwnedPopups16
269 266 pascal16 SetMessageQueue(word) SetMessageQueue16
270 267 pascal16 ShowScrollBar(word word word) ShowScrollBar16
271 268 pascal16 GlobalAddAtom(str) GlobalAddAtom16
272 269 pascal16 GlobalDeleteAtom(word) GlobalDeleteAtom16
273 270 pascal16 GlobalFindAtom(str) GlobalFindAtom16
274 271 pascal16 GlobalGetAtomName(word ptr s_word) GlobalGetAtomName16
275 272 pascal16 IsZoomed(word) IsZoomed16
276 273 pascal16 ControlPanelInfo(word word str) ControlPanelInfo16
277 274 stub GetNextQueueWindow
278 275 stub RepaintScreen
279 276 stub LockMyTask
280 277 pascal16 GetDlgCtrlID(word) GetDlgCtrlID16
281 278 pascal16 GetDesktopHwnd() GetDesktopHwnd16
282 279 pascal16 OldSetDeskPattern() SetDeskPattern
283 280 pascal16 SetSystemMenu(word word) SetSystemMenu16
284 281 pascal16 GetSysColorBrush(word) GetSysColorBrush16
285 282 pascal16 SelectPalette(word word word) SelectPalette16
286 283 pascal16 RealizePalette(word) RealizePalette16
287 284 pascal16 GetFreeSystemResources(word) GetFreeSystemResources16
288 285 pascal16 SetDeskWallPaper(ptr) SetDeskWallPaper16 # BEAR285
289 286 pascal16 GetDesktopWindow() GetDesktopWindow16
290 287 pascal16 GetLastActivePopup(word) GetLastActivePopup16
291 288 pascal GetMessageExtraInfo() GetMessageExtraInfo
292 289 pascal -register keybd_event() keybd_event16
293 290 pascal16 RedrawWindow(word ptr word word) RedrawWindow16
294 291 pascal SetWindowsHookEx(s_word segptr word word) SetWindowsHookEx16
295 292 pascal16 UnhookWindowsHookEx(segptr) UnhookWindowsHookEx16
296 293 pascal CallNextHookEx(segptr s_word word long) CallNextHookEx16
297 294 pascal16 LockWindowUpdate(word) LockWindowUpdate16
298 299 pascal -register mouse_event() mouse_event16
299 300 stub UnloadInstalledDrivers # W1.1: USER_FARFRAME
300 301 stub EDITWNDPROC # BOZOSLIVEHERE :-))
301 302 stub STATICWNDPROC
302 303 stub BUTTONWNDPROC
303 304 stub SBWNDPROC
304 305 stub DESKTOPWNDPROC # W1.1: ICONWNDPROC
305 306 stub MENUWNDPROC # BEAR306
306 307 stub LBOXCTLWNDPROC
307 308 pascal DefDlgProc(word word word long) DefDlgProc16 # W1.1, W2.0: DLGWNDPROC
308 309 pascal16 GetClipCursor(ptr) GetClipCursor16 # W1.1, W2.0: MESSAGEBOXWNDPROC
309 #310 ContScroll
310 #311 CaretBlinkProc # W1.1
311 #312 SendMessage2
312 #313 PostMessage2
313 314 pascal16 SignalProc(word word word word word) USER_SignalProc
314 #315 XCStoDS
315 #316 CompUpdateRect
316 #317 CompUpdateRgn
317 #318 GetWC2
318 319 pascal16 ScrollWindowEx(word s_word s_word ptr ptr word ptr word) ScrollWindowEx16 # W1.1, W2.0: SETWC2
319 320 stub SysErrorBox # W1.1: ICONNAMEWNDPROC, W2.0: nothing !
320 321 pascal SetEventHook(segptr) SetEventHook16 # W1.1, W2.0: DESTROYTASKWINDOWS2
321 322 stub WinOldAppHackOMatic # W1.1, W2.0: POSTSYSERROR
322 323 stub GetMessage2
323 324 pascal16 FillWindow(word word word word) FillWindow16
324 325 pascal16 PaintRect(word word word word ptr) PaintRect16
325 326 pascal16 GetControlBrush(word word word) GetControlBrush16
326 #327 KillTimer2
327 #328 SetTimer2
328 #329 MenuItemState # W1.1
329 #330 SetGetKbdState
330 331 pascal16 EnableHardwareInput(word) EnableHardwareInput16
331 332 pascal16 UserYield() UserYield16
332 333 pascal16 IsUserIdle() IsUserIdle16
333 334 pascal GetQueueStatus(word) GetQueueStatus16
334 335 pascal16 GetInputState() GetInputState16
335 336 pascal16 LoadCursorIconHandler(word word word) LoadCursorIconHandler16
336 337 pascal GetMouseEventProc() GetMouseEventProc16
337 338 stub ECGETDS # W2.0 (only ?)
338 #340 WinFarFrame
339 #341 _FFFE_FARFRAME
340 343 stub GetFilePortName
341 344 stub COMBOBOXCTLWNDPROC
342 345 stub BEAR345
343 #354 TabTheTextOutForWimps
344 #355 BroadcastMessage
345 356 pascal16 LoadDIBCursorHandler(word word word) LoadDIBCursorHandler16
346 357 pascal16 LoadDIBIconHandler(word word word) LoadDIBIconHandler16
347 358 pascal16 IsMenu(word) IsMenu16
348 359 pascal16 GetDCEx(word word long) GetDCEx16
349 362 pascal16 DCHook(word word long long) DCHook16
350 364 pascal16 LookupIconIdFromDirectoryEx(ptr word word word word) LookupIconIdFromDirectoryEx16
351 368 pascal16 CopyIcon(word word) CopyIcon16
352 369 pascal16 CopyCursor(word word) CopyCursor16
353 370 pascal16 GetWindowPlacement(word ptr) GetWindowPlacement16
354 371 pascal16 SetWindowPlacement(word ptr) SetWindowPlacement16
355 372 stub GetInternalIconHeader
356 373 pascal16 SubtractRect(ptr ptr ptr) SubtractRect16
357 #374 DllEntryPoint
358 375 stub DrawTextEx
359 376 stub SetMessageExtraInfo
360 378 stub SetPropEx
361 379 stub GetPropEx
362 380 stub RemovePropEx
363 381 stub UsrMPR_ThunkData16
364 382 stub SetWindowContextHelpID
365 383 stub GetWindowContextHelpID
366 384 pascal16 SetMenuContextHelpId(word word) SetMenuContextHelpId16
367 385 pascal16 GetMenuContextHelpId(word) GetMenuContextHelpId16
368 389 pascal LoadImage(word str word word word word) LoadImage16
369 390 pascal16 CopyImage(word word word word word) CopyImage16
370 391 pascal16 SignalProc32(long long long word) UserSignalProc
371 394 pascal16 DrawIconEx(word word word word word word word word word) DrawIconEx16
372 395 pascal16 GetIconInfo(word ptr) GetIconInfo16
373 397 pascal16 RegisterClassEx(ptr) RegisterClassEx16
374 398 pascal16 GetClassInfoEx(word segstr ptr) GetClassInfoEx16
375 399 pascal16 ChildWindowFromPointEx(word long word) ChildWindowFromPointEx16
376 400 pascal16 FinalUserInit() FinalUserInit16
377 402 pascal16 GetPriorityClipboardFormat(ptr s_word) GetPriorityClipboardFormat16
378 403 pascal16 UnregisterClass(str word) UnregisterClass16
379 404 pascal16 GetClassInfo(word segstr ptr) GetClassInfo16
380 406 pascal16 CreateCursor(word word word word word ptr ptr) CreateCursor16
381 407 pascal16 CreateIcon(word word word word word ptr ptr) CreateIcon16
382 408 pascal16 CreateCursorIconIndirect(word ptr ptr ptr) CreateCursorIconIndirect16
383 409 pascal16 InitThreadInput(word word) InitThreadInput16
384 410 pascal16 InsertMenu(word word word word segptr) InsertMenu16
385 411 pascal16 AppendMenu(word word word segptr) AppendMenu16
386 412 pascal16 RemoveMenu(word word word) RemoveMenu16
387 413 pascal16 DeleteMenu(word word word) DeleteMenu16
388 414 pascal16 ModifyMenu(word word word word segptr) ModifyMenu16
389 415 pascal16 CreatePopupMenu() CreatePopupMenu16
390 416 pascal16 TrackPopupMenu(word word s_word s_word s_word word ptr) TrackPopupMenu16
391 417 pascal GetMenuCheckMarkDimensions() GetMenuCheckMarkDimensions
392 418 pascal16 SetMenuItemBitmaps(word word word word word) SetMenuItemBitmaps16
393 420 pascal16 _wsprintf() wsprintf16
394 421 pascal16 wvsprintf(ptr str ptr) wvsprintf16
395 422 pascal16 DlgDirSelectEx(word ptr word word) DlgDirSelectEx16
396 423 pascal16 DlgDirSelectComboBoxEx(word ptr word word) DlgDirSelectComboBoxEx16
397 427 pascal16 FindWindowEx(word word str str) FindWindowEx16
398 428 stub TileWindows
399 429 stub CascadeWindows
400 430 pascal16 lstrcmp(str str) lstrcmp16
401 431 pascal AnsiUpper(segstr) AnsiUpper16
402 432 pascal AnsiLower(segstr) AnsiLower16
403 433 pascal16 IsCharAlpha(word) IsCharAlphaA
404 434 pascal16 IsCharAlphaNumeric(word) IsCharAlphaNumericA
405 435 pascal16 IsCharUpper(word) IsCharUpperA
406 436 pascal16 IsCharLower(word) IsCharLowerA
407 437 pascal16 AnsiUpperBuff(str word) AnsiUpperBuff16
408 438 pascal16 AnsiLowerBuff(str word) AnsiLowerBuff16
409 441 pascal16 InsertMenuItem(word word word ptr) InsertMenuItem16
410 443 stub GetMenuItemInfo
411 445 pascal DefFrameProc(word word word word long) DefFrameProc16
412 446 stub SetMenuItemInfo
413 447 pascal DefMDIChildProc(word word word long) DefMDIChildProc16
414 448 pascal16 DrawAnimatedRects(word word ptr ptr) DrawAnimatedRects16
415 449 pascal16 DrawState(word word segptr long word s_word s_word s_word s_word word) DrawState16
416 450 pascal16 CreateIconFromResourceEx(ptr long word long word word word) CreateIconFromResourceEx16
417 451 pascal16 TranslateMDISysAccel(word ptr) TranslateMDISysAccel16
418 452 pascal16 CreateWindowEx(long str str long s_word s_word s_word s_word word word word segptr) CreateWindowEx16
419 454 pascal16 AdjustWindowRectEx(ptr long word long) AdjustWindowRectEx16
420 455 pascal16 GetIconID(word long) GetIconID16
421 456 pascal16 LoadIconHandler(word word) LoadIconHandler16
422 457 pascal16 DestroyIcon(word) DestroyIcon16
423 458 pascal16 DestroyCursor(word) DestroyCursor16
424 459 pascal DumpIcon(segptr ptr ptr ptr) DumpIcon16
425 460 pascal16 GetInternalWindowPos(word ptr ptr) GetInternalWindowPos16
426 461 pascal16 SetInternalWindowPos(word word ptr ptr) SetInternalWindowPos16
427 462 pascal16 CalcChildScroll(word word) CalcChildScroll16
428 463 pascal16 ScrollChildren(word word word long) ScrollChildren16
429 464 pascal DragObject(word word word word word word) DragObject16
430 465 pascal16 DragDetect(word long) DragDetect16
431 466 pascal16 DrawFocusRect(word ptr) DrawFocusRect16
432 470 stub StringFunc
433 471 pascal16 lstrcmpi(str str) lstrcmpiA
434 472 pascal AnsiNext(segptr) AnsiNext16
435 473 pascal AnsiPrev(str segptr) AnsiPrev16
436 475 pascal16 SetScrollInfo(word s_word ptr word) SetScrollInfo16
437 476 pascal16 GetScrollInfo(word s_word ptr) GetScrollInfo16
438 477 pascal16 GetKeyboardLayoutName(ptr) GetKeyboardLayoutName16
439 478 stub LoadKeyboardLayout
440 479 stub MenuItemFromPoint
441 480 stub GetUserLocalObjType
442 #481 HARDWARE_EVENT
443 482 pascal16 EnableScrollBar(word word word) EnableScrollBar16
444 483 pascal16 SystemParametersInfo(word word ptr word) SystemParametersInfo16
445 #484 __GP
446 # Stubs for Hebrew version
447 489 pascal16 USER_489() stub_USER_489
448 490 pascal16 USER_490() stub_USER_490
449 492 pascal16 USER_492() stub_USER_492
450 496 pascal16 USER_496() stub_USER_496
451 498 stub BEAR498
452 499 pascal16 WNetErrorText(word ptr word) WNetErrorText16
453 500 stub FARCALLNETDRIVER # Undocumented Windows
454 501 pascal16 WNetOpenJob(ptr ptr word ptr) WNetOpenJob16
455 502 pascal16 WNetCloseJob(word ptr ptr) WNetCloseJob16
456 503 pascal16 WNetAbortJob(ptr word) WNetAbortJob16
457 504 pascal16 WNetHoldJob(ptr word) WNetHoldJob16
458 505 pascal16 WNetReleaseJob(ptr word) WNetReleaseJob16
459 506 pascal16 WNetCancelJob(ptr word) WNetCancelJob16
460 507 pascal16 WNetSetJobCopies(ptr word word) WNetSetJobCopies16
461 508 pascal16 WNetWatchQueue(word ptr ptr word) WNetWatchQueue16
462 509 pascal16 WNetUnwatchQueue(str) WNetUnwatchQueue16
463 510 pascal16 WNetLockQueueData(ptr ptr ptr) WNetLockQueueData16
464 511 pascal16 WNetUnlockQueueData(ptr) WNetUnlockQueueData16
465 512 pascal16 WNetGetConnection(ptr ptr ptr) WNetGetConnection16
466 513 pascal16 WNetGetCaps(word) WNetGetCaps16
467 514 pascal16 WNetDeviceMode(word) WNetDeviceMode16
468 515 pascal16 WNetBrowseDialog(word word ptr) WNetBrowseDialog16
469 516 pascal16 WNetGetUser(ptr ptr ptr) WNetGetUser16
470 517 pascal16 WNetAddConnection(str str str) WNetAddConnection16
471 518 pascal16 WNetCancelConnection(str word) WNetCancelConnection16
472 519 pascal16 WNetGetError(ptr) WNetGetError16
473 520 pascal16 WNetGetErrorText(word ptr ptr) WNetGetErrorText16
474 521 stub WNetEnable
475 522 stub WNetDisable
476 523 pascal16 WNetRestoreConnection(word ptr) WNetRestoreConnection16
477 524 pascal16 WNetWriteJob(word ptr ptr) WNetWriteJob16
478 525 pascal16 WNetConnectDialog(word word) WNetConnectDialog
479 526 pascal16 WNetDisconnectDialog(word word) WNetDisconnectDialog16
480 527 pascal16 WNetConnectionDialog(word word) WNetConnectionDialog16
481 528 pascal16 WNetViewQueueDialog(word ptr) WNetViewQueueDialog16
482 529 pascal16 WNetPropertyDialog(word word word str word) WNetPropertyDialog16
483 530 pascal16 WNetGetDirectoryType(ptr ptr) WNetGetDirectoryType16
484 531 pascal16 WNetDirectoryNotify(word ptr word) WNetDirectoryNotify16
485 532 pascal16 WNetGetPropertyText(word word str str word word) WNetGetPropertyText16
486 533 stub WNetInitialize
487 #533 stub NOTIFYWOW # ordinal conflict with WNetInitialize !!
488 534 stub WNetLogon
489 #534 stub DEFDLGPROCTHUNK # ordinal conflict with WNetLogon !!
490 535 stub WOWWORDBREAKPROC
491 537 stub MOUSEEVENT
492 538 stub KEYBDEVENT
493 595 stub OLDEXITWINDOWS
494 600 pascal16 GetShellWindow() GetShellWindow16
495 601 stub DoHotkeyStuff
496 602 stub SetCheckCursorTimer
497 604 stub BroadcastSystemMessage
498 605 stub HackTaskMonitor
499 606 pascal16 FormatMessage(long segptr word word ptr word ptr) FormatMessage16
500 608 pascal16 GetForegroundWindow() GetForegroundWindow16
501 609 pascal16 SetForegroundWindow(word) SetForegroundWindow16
502 610 pascal16 DestroyIcon32(word word) DestroyIcon32
503 620 pascal ChangeDisplaySettings(ptr long) ChangeDisplaySettings16
504 621 pascal16 EnumDisplaySettings(str long ptr) EnumDisplaySettings16
505 640 pascal MsgWaitForMultipleObjects(long ptr long long long) MsgWaitForMultipleObjects16
506 650 stub ActivateKeyboardLayout
507 651 stub GetKeyboardLayout
508 652 stub GetKeyboardLayoutList
509 654 stub UnloadKeyboardLayout
510 655 stub PostPostedMessages
511 656 pascal16 DrawFrameControl(word ptr word word) DrawFrameControl16
512 657 pascal16 DrawCaptionTemp(word word ptr word word ptr word) DrawCaptionTemp16
513 658 stub DispatchInput
514 659 pascal16 DrawEdge(word ptr word word) DrawEdge16
515 660 pascal16 DrawCaption(word word ptr word) DrawCaption16
516 661 stub SetSysColorsTemp
517 662 stub DrawMenubarTemp
518 663 stub GetMenuDefaultItem
519 664 stub SetMenuDefaultItem
520 665 pascal16 GetMenuItemRect(word word word ptr) GetMenuItemRect16
521 666 pascal16 CheckMenuRadioItem(word word word word word) CheckMenuRadioItem16
522 667 stub TrackPopupMenuEx
523 668 pascal16 SetWindowRgn(word word word) SetWindowRgn16
524 669 stub GetWindowRgn
525 800 stub CHOOSEFONT_CALLBACK16
526 801 stub FINDREPLACE_CALLBACK16
527 802 stub OPENFILENAME_CALLBACK16
528 803 stub PRINTDLG_CALLBACK16
529 804 stub CHOOSECOLOR_CALLBACK16
530 819 pascal16 PeekMessage32(ptr word word word word word) PeekMessage32_16
531 820 pascal GetMessage32(ptr word word word word) GetMessage32_16
532 821 pascal16 TranslateMessage32(ptr word) TranslateMessage32_16
533 #821 stub IsDialogMessage32 # FIXME: two ordinal 821???
534 822 pascal DispatchMessage32(ptr word) DispatchMessage32_16
535 823 pascal16 CallMsgFilter32(segptr word word) CallMsgFilter32_16
536 825 stub PostMessage32
537 826 stub PostThreadMessage32
538 827 pascal16 MessageBoxIndirect(ptr) MessageBoxIndirect16
539 851 stub MsgThkConnectionDataLS
540 853 stub FT_USRFTHKTHKCONNECTIONDATA
541 854 stub FT__USRF2THKTHKCONNECTIONDATA
542 855 stub Usr32ThkConnectionDataSL
543 890 stub InstallIMT
544 891 stub UninstallIMT
545 # API for Hebrew version
546 902 pascal16 LoadSystemLanguageString(word word ptr word word) LoadSystemLanguageString16
547 905 pascal16 ChangeDialogTemplate() ChangeDialogTemplate16
548 906 pascal16 GetNumLanguages() GetNumLanguages16
549 907 pascal16 GetLanguageName(word word ptr word) GetLanguageName16
550 909 pascal16 SetWindowTextEx(word str word) SetWindowTextEx16
551 910 pascal16 BiDiMessageBoxEx() BiDiMessageBoxEx16
552 911 pascal16 SetDlgItemTextEx(word word str word) SetDlgItemTextEx16
553 912 pascal ChangeKeyboardLanguage(word word) ChangeKeyboardLanguage16
554 913 pascal16 GetCodePageSystemFont(word word) GetCodePageSystemFont16
555 914 pascal16 QueryCodePage(word word word long) QueryCodePage16
556 915 pascal GetAppCodePage(word) GetAppCodePage16
557 916 pascal16 CreateDialogIndirectParamML(word ptr word ptr long word word str word) CreateDialogIndirectParamML16
558 918 pascal16 DialogBoxIndirectParamML(word word word ptr long word word str word) DialogBoxIndirectParamML16
559 919 pascal16 LoadLanguageString(word word word ptr word) LoadLanguageString16
560 920 pascal SetAppCodePage(word word word word) SetAppCodePage16
561 922 pascal GetBaseCodePage() GetBaseCodePage16
562 923 pascal16 FindLanguageResource(word str str word) FindLanguageResource16
563 924 pascal ChangeKeyboardCodePage(word word) ChangeKeyboardCodePage16
564 930 pascal16 MessageBoxEx(word str str word word) MessageBoxEx16
565 1000 pascal16 SetProcessDefaultLayout(long) SetProcessDefaultLayout16
566 1001 pascal16 GetProcessDefaultLayout(ptr) GetProcessDefaultLayout16
568 # Wine internal functions
569 1010 pascal __wine_call_wndproc_32A(word word word long long) __wine_call_wndproc_32A
570 1011 pascal __wine_call_wndproc_32W(word word word long long) __wine_call_wndproc_32W