Release 940524
[wine/testsucceed.git] / if1632 / gdi.spec
blob82247c51ac5ddd362d59249ed91bf01176efc023
1 # $Id: gdi.spec,v 1.3 1993/07/04 04:04:21 root Exp root $
3 name gdi
4 id 3
5 length 490
7 1 pascal SetBkColor(word long) SetBkColor(1 2)
8 2 pascal SetBkMode(word word) SetBkMode(1 2)
9 3 pascal SetMapMode(word word) SetMapMode(1 2)
10 4 pascal SetROP2(word word) SetROP2(1 2)
11 5 pascal SetRelAbs(word word) SetRelAbs(1 2)
12 6 pascal SetPolyFillMode(word word) SetPolyFillMode(1 2)
13 7 pascal SetStretchBltMode(word word) SetStretchBltMode(1 2)
14 8 pascal SetTextCharacterExtra(word s_word) SetTextCharacterExtra(1 2)
15 9 pascal SetTextColor(word long) SetTextColor(1 2)
16 10 pascal SetTextJustification(word s_word s_word) SetTextJustification(1 2 3)
17 11 pascal SetWindowOrg(word s_word s_word) SetWindowOrg(1 2 3)
18 12 pascal SetWindowExt(word s_word s_word) SetWindowExt(1 2 3)
19 13 pascal SetViewportOrg(word s_word s_word) SetViewportOrg(1 2 3)
20 14 pascal SetViewportExt(word s_word s_word) SetViewportExt(1 2 3)
21 15 pascal OffsetWindowOrg(word s_word s_word) OffsetWindowOrg(1 2 3)
22 16 pascal ScaleWindowExt(word s_word s_word s_word s_word)
23 ScaleWindowExt(1 2 3 4 5)
24 17 pascal OffsetViewportOrg(word s_word s_word) OffsetViewportOrg(1 2 3)
25 18 pascal ScaleViewportExt(word s_word s_word s_word s_word)
26 ScaleViewportExt(1 2 3 4 5)
27 19 pascal LineTo(word s_word s_word) LineTo(1 2 3)
28 20 pascal MoveTo(word s_word s_word) MoveTo(1 2 3)
29 21 pascal ExcludeClipRect(word s_word s_word s_word s_word)
30 ExcludeClipRect(1 2 3 4 5)
31 22 pascal IntersectClipRect(word s_word s_word s_word s_word)
32 IntersectClipRect(1 2 3 4 5)
33 23 pascal Arc(word s_word s_word s_word s_word s_word s_word s_word s_word)
34 Arc(1 2 3 4 5 6 7 8 9)
35 24 pascal Ellipse(word s_word s_word s_word s_word) Ellipse(1 2 3 4 5)
36 25 pascal FloodFill(word word word long) FloodFill(1 2 3 4)
37 26 pascal Pie(word s_word s_word s_word s_word s_word s_word s_word s_word)
38 Pie(1 2 3 4 5 6 7 8 9)
39 27 pascal Rectangle(word s_word s_word s_word s_word) Rectangle(1 2 3 4 5)
40 28 pascal RoundRect(word s_word s_word s_word s_word s_word s_word)
41 RoundRect(1 2 3 4 5 6 7)
42 29 pascal PatBlt(word s_word s_word s_word s_word long) PatBlt(1 2 3 4 5 6)
43 30 pascal SaveDC(word) SaveDC(1)
44 31 pascal SetPixel(word s_word s_word long) SetPixel(1 2 3 4)
45 32 pascal OffsetClipRgn(word s_word s_word) OffsetClipRgn(1 2 3)
46 33 pascal TextOut(word s_word s_word ptr word) TextOut(1 2 3 4 5)
47 34 pascal BitBlt( word s_word s_word s_word s_word word s_word s_word long)
48 BitBlt(1 2 3 4 5 6 7 8 9)
49 35 pascal StretchBlt( word s_word s_word s_word s_word word s_word s_word s_word s_word long)
50 StretchBlt(1 2 3 4 5 6 7 8 9 10 11)
51 36 pascal Polygon (word ptr word) Polygon (1 2 3)
52 37 pascal Polyline (word ptr word) Polyline (1 2 3)
53 #38 pascal Escape
54 39 pascal RestoreDC(word s_word) RestoreDC(1 2)
55 40 pascal FillRgn(word word word) FillRgn(1 2 3)
56 #41 pascal FrameRgn
57 #42 pascal InvertRgn
58 43 pascal PaintRgn(word word) PaintRgn(1 2)
59 44 pascal SelectClipRgn(word word) SelectClipRgn(1 2)
60 45 pascal SelectObject(word word) SelectObject(1 2)
61 #46 pascal __GP?
62 47 pascal CombineRgn(word word word word) CombineRgn(1 2 3 4)
63 48 pascal CreateBitmap(word word word word ptr) CreateBitmap(1 2 3 4 5)
64 49 pascal CreateBitmapIndirect(ptr) CreateBitmapIndirect(1)
65 50 pascal CreateBrushIndirect(ptr) CreateBrushIndirect(1)
66 51 pascal CreateCompatibleBitmap(word word word) CreateCompatibleBitmap(1 2 3)
67 52 pascal CreateCompatibleDC(word) CreateCompatibleDC(1)
68 53 pascal CreateDC(ptr ptr ptr ptr) CreateDC(1 2 3 4)
69 54 pascal CreateEllipticRgn(s_word s_word s_word s_word)
70 CreateEllipticRgn(1 2 3 4)
71 55 pascal CreateEllipticRgnIndirect(ptr) CreateEllipticRgnIndirect(1)
72 56 pascal CreateFont(s_word s_word s_word s_word s_word word word word
73 word word word word word ptr)
74 CreateFont(1 2 3 4 5 6 7 8 9 10 11 12 13 14)
75 57 pascal CreateFontIndirect(ptr) CreateFontIndirect(1)
76 58 pascal CreateHatchBrush(word long) CreateHatchBrush(1 2)
77 60 pascal CreatePatternBrush(word) CreatePatternBrush(1)
78 61 pascal CreatePen(s_word s_word long) CreatePen(1 2 3)
79 62 pascal CreatePenIndirect(ptr) CreatePenIndirect(1)
80 63 pascal CreatePolygonRgn(ptr word word) CreatePolygonRgn(1 2 3)
81 64 pascal CreateRectRgn(s_word s_word s_word s_word) CreateRectRgn(1 2 3 4)
82 65 pascal CreateRectRgnIndirect(ptr) CreateRectRgnIndirect(1)
83 66 pascal CreateSolidBrush(long) CreateSolidBrush(1)
84 67 pascal DPtoLP(word ptr s_word) DPtoLP(1 2 3)
85 68 pascal DeleteDC(word) DeleteDC(1)
86 69 pascal DeleteObject(word) DeleteObject(1)
87 70 pascal EnumFonts(word ptr ptr ptr) EnumFonts(1 2 3 4)
88 71 pascal EnumObjects(word word ptr ptr) EnumObjects(1 2 3 4)
89 72 pascal EqualRgn(word word) EqualRgn(1 2)
90 73 pascal ExcludeVisRect(word s_word s_word s_word s_word)
91 ExcludeVisRect(1 2 3 4 5)
92 74 pascal GetBitmapBits(word long ptr) GetBitmapBits(1 2 3)
93 75 pascal GetBkColor(word) GetBkColor(1)
94 76 pascal GetBkMode(word) GetBkMode(1)
95 77 pascal GetClipBox(word ptr) GetClipBox(1 2)
96 78 pascal GetCurrentPosition(word) GetCurrentPosition(1)
97 79 pascal GetDCOrg(word) GetDCOrg(1)
98 80 pascal GetDeviceCaps(word s_word) GetDeviceCaps(1 2)
99 81 pascal GetMapMode(word) GetMapMode(1)
100 82 pascal GetObject(word word ptr) GetObject(1 2 3)
101 83 pascal GetPixel(word s_word s_word) GetPixel(1 2 3)
102 84 pascal GetPolyFillMode(word) GetPolyFillMode(1)
103 85 pascal GetROP2(word) GetROP2(1)
104 86 pascal GetRelAbs(word) GetRelAbs(1)
105 87 pascal GetStockObject(word) GetStockObject(1)
106 88 pascal GetStretchBltMode(word) GetStretchBltMode(1)
107 89 pascal GetTextCharacterExtra(word) GetTextCharacterExtra(1)
108 90 pascal GetTextColor(word) GetTextColor(1)
109 91 pascal GetTextExtent(word ptr s_word) GetTextExtent(1 2 3)
110 #92 pascal GetTextFace
111 93 pascal GetTextMetrics(word ptr) GetTextMetrics(1 2)
112 94 pascal GetViewportExt(word) GetViewportExt(1)
113 95 pascal GetViewportOrg(word) GetViewportOrg(1)
114 96 pascal GetWindowExt(word) GetWindowExt(1)
115 97 pascal GetWindowOrg(word) GetWindowOrg(1)
116 98 pascal IntersectVisRect(word s_word s_word s_word s_word)
117 IntersectVisRect(1 2 3 4 5)
118 99 pascal LPtoDP(word ptr s_word) LPtoDP(1 2 3)
119 100 pascal LineDDA(s_word s_word s_word s_word ptr long)
120 LineDDA(1 2 3 4 5 6)
121 101 pascal OffsetRgn(word s_word s_word) OffsetRgn(1 2 3)
122 102 pascal OffsetVisRgn(word s_word s_word) OffsetVisRgn(1 2 3)
123 103 pascal PtVisible(word s_word s_word) PtVisible(1 2 3)
124 104 pascal RectVisibleOld(word ptr) RectVisible(1 2)
125 105 pascal SelectVisRgn(word word) SelectVisRgn(1 2)
126 106 pascal SetBitmapBits(word long ptr) SetBitmapBits(1 2 3)
127 117 pascal SetDCOrg(word s_word s_word) SetDCOrg(1 2 3)
128 #121 pascal Death
129 #122 pascal ReSurRection
130 #123 pascal PlayMetaFile
131 #124 pascal GetMetaFile
132 125 pascal CreateMetaFile(ptr) CreateMetaFile(1)
133 126 pascal CloseMetaFile(word) CloseMetaFile(1)
134 127 pascal DeleteMetaFile(word) DeleteMetaFile(1)
135 128 pascal MulDiv(s_word s_word s_word) MulDiv(1 2 3)
136 129 pascal SaveVisRgn(word) SaveVisRgn(1)
137 130 pascal RestoreVisRgn(word) RestoreVisRgn(1)
138 131 pascal InquireVisRgn(word) InquireVisRgn(1)
139 132 pascal SetEnvironment(ptr ptr word) SetEnvironment(1 2 3)
140 133 pascal GetEnvironment(ptr ptr word) GetEnvironment(1 2 3)
141 134 pascal GetRgnBox(word ptr) GetRgnBox(1 2)
142 #135 pascal ScanLr
143 #136 pascal RemoveFontResource
144 148 pascal SetBrushOrg(word s_word s_word) SetBrushOrg(1 2 3)
145 149 pascal GetBrushOrg(word) GetBrushOrg(1)
146 150 pascal UnrealizeObject(word) UnrealizeObject(1)
147 #151 pascal CopyMetaFile
148 153 pascal CreateIC(ptr ptr ptr ptr) CreateIC(1 2 3 4)
149 154 pascal GetNearestColor(word long) GetNearestColor(1 2)
150 #155 pascal QueryAbort
151 #156 pascal CreateDiscardableBitmap
152 #159 pascal GetMetaFileBits
153 #160 pascal SetMetaFileBits
154 161 pascal PtInRegion(word s_word s_word) PtInRegion(1 2 3)
155 162 pascal GetBitmapDimension(word) GetBitmapDimension(1)
156 163 pascal SetBitmapDimension(word s_word s_word) SetBitmapDimension(1 2 3)
157 #169 pascal IsDCDirty
158 #170 pascal SetDCStatus
159 172 pascal SetRectRgn(word s_word s_word s_word s_word) SetRectRgn(1 2 3 4 5)
160 173 pascal GetClipRgn(word) GetClipRgn(1)
161 #175 pascal EnumMetaFile
162 179 pascal GetDCState(word) GetDCState(1)
163 180 pascal SetDCState(word word) SetDCState(1 2)
164 181 pascal RectInRegionOld(word ptr) RectInRegion(1 2)
165 #190 pascal SetDCHook
166 #191 pascal GetDCHook
167 #192 pascal SetHookFlags
168 #193 pascal SetBoundsRect
169 #194 pascal GetBoundsRect
170 #195 pascal SelectBitmap
171 #196 pascal SetMetaFileBitsBetter
172 #201 pascal DMBITBLT
173 #202 pascal DMCOLORINFO
174 #206 pascal DMENUMDFONTS
175 #207 pascal DMENUMOBJ
176 #208 pascal DMOUTPUT
177 #209 pascal DMPIXEL
178 #210 pascal DMREALIZEOBJECT
179 #211 pascal DMSTRBLT
180 #212 pascal DMSCANLR
181 #213 pascal BRUTE
182 #214 pascal DMEXTTEXTOUT
183 #215 pascal DMGETCHARWIDTH
184 #216 pascal DMSTRETCHBLT
185 #217 pascal DMDIBBITS
186 #218 pascal DMSTRETCHDIBITS
187 #219 pascal DMSETDIBTODEV
188 #220 pascal DMTRANSPOSE
189 #230 pascal CREATEPQ
190 #231 pascal MINPQ
191 #232 pascal EXTRACTPQ
192 #233 pascal INSERTPQ
193 #234 pascal SIZEPQ
194 #235 pascal DELETEPQ
195 #240 pascal OPENJOB
196 #241 pascal WRITESPOOL
197 #242 pascal WRITEDIALOG
198 #243 pascal CLOSEJOB
199 #244 pascal DELETEJOB
200 #245 pascal GETSPOOLJOB
201 #246 pascal STARTSPOOLPAGE
202 #247 pascal ENDSPOOLPAGE
203 #248 pascal QUERYJOB
204 250 pascal Copy(ptr ptr word) Copy(1 2 3)
205 #253 pascal DeleteSpoolPage
206 #254 pascal SpoolFile
207 #300 pascal ENGINEENUMERATEFONT
208 #301 pascal ENGINEDELETEFONT
209 #302 pascal ENGINEREALIZEFONT
210 #303 pascal ENGINEGETCHARWIDTH
211 #304 pascal ENGINESETFONTCONTEXT
212 #305 pascal ENGINEGETGLYPHBMP
213 #306 pascal ENGINEMAKEFONTDIR
214 #307 pascal GETCHARABCWIDTHS
215 #308 pascal GETOUTLINETEXTMETRICS
216 #309 pascal GETGLYPHOUTLINE
217 #310 pascal CREATESCALABLEFONTRESOURCE
218 #311 pascal GETFONTDATA
219 #312 pascal CONVERTOUTLINEFONTFILE
220 #313 pascal GETRASTERIZERCAPS
221 #314 pascal ENGINEEXTTEXTOUT
222 330 pascal EnumFontFamilies(word ptr ptr ptr) EnumFontFamilies(1 2 3 4)
223 #332 pascal GETKERNINGPAIRS
224 345 pascal GetTextAlign(word) GetTextAlign(1)
225 346 pascal SetTextAlign(word word) SetTextAlign(1 2)
226 348 pascal Chord(word s_word s_word s_word s_word s_word s_word s_word s_word)
227 Chord(1 2 3 4 5 6 7 8 9)
228 349 pascal SetMapperFlags(word word) SetMapperFlags(1 2)
229 350 pascal GetCharWidth(word word word ptr) GetCharWidth(1 2 3 4)
230 351 pascal ExtTextOut(word s_word s_word word ptr ptr s_word ptr)
231 ExtTextOut(1 2 3 4 5 6 7 8)
232 #352 pascal GETPHYSICALFONTHANDLE
233 #353 pascal GETASPECTRATIOFILTER
234 #354 pascal SHRINKGDIHEAP
235 360 pascal CreatePalette(ptr) CreatePalette(1)
236 361 pascal GDISelectPalette(word word) GDISelectPalette(1 2)
237 362 pascal GDIRealizePalette(word) GDIRealizePalette(1)
238 363 pascal GetPaletteEntries(word word word ptr) GetPaletteEntries(1 2 3 4)
239 364 pascal SetPaletteEntries(word word word ptr) SetPaletteEntries(1 2 3 4)
240 365 pascal RealizeDefaultPalette(word) RealizeDefaultPalette(1)
241 #366 pascal UPDATECOLORS
242 #367 pascal ANIMATEPALETTE
243 #368 pascal RESIZEPALETTE
244 370 pascal GetNearestPaletteIndex(word long) GetNearestPaletteIndex(1 2)
245 375 pascal GetSystemPaletteEntries(word word word ptr)
246 GetSystemPaletteEntries(1 2 3 4)
247 #376 pascal RESETDC
248 #377 pascal STARTDOC
249 #378 pascal ENDDOC
250 #379 pascal STARTPAGE
251 #380 pascal ENDPAGE
252 #381 pascal SETABORTPROC
253 #382 pascal ABORTDOC
254 #400 pascal FASTWINDOWFRAME
255 #401 pascal GDIMOVEBITMAP
256 #403 pascal GDIINIT2
257 #405 pascal FINALGDIINIT
258 #407 pascal CREATEUSERBITMAP
259 #409 pascal CREATEUSERDISCARDABLEBITMAP
260 #410 pascal ISVALIDMETAFILE
261 411 pascal GetCurLogFont(word) GetCurLogFont(1)
262 #412 pascal ISDCCURRENTPALETTE
263 #439 pascal STRETCHDIBITS
264 440 pascal SetDIBits(word word word word ptr ptr word) SetDIBits(1 2 3 4 5 6 7)
265 441 pascal GetDIBits(word word word word ptr ptr word) GetDIBits(1 2 3 4 5 6 7)
266 442 pascal CreateDIBitmap(word ptr long ptr ptr word)
267 CreateDIBitmap(1 2 3 4 5 6)
268 443 pascal SetDIBitsToDevice(word s_word s_word word word word word word word ptr ptr word)
269 SetDIBitsToDevice(1 2 3 4 5 6 7 8 9 10 11 12)
270 444 pascal CreateRoundRectRgn(s_word s_word s_word s_word s_word s_word)
271 CreateRoundRectRgn(1 2 3 4 5 6)
272 445 pascal CreateDIBPatternBrush(word word) CreateDIBPatternBrush(1 2)
273 #449 pascal DEVICECOLORMATCH
274 #450 pascal POLYPOLYGON
275 451 pascal CreatePolyPolygonRgn(ptr ptr word word)
276 CreatePolyPolygonRgn(1 2 3 4)
277 #452 pascal GDISEEGDIDO
278 #460 pascal GDITASKTERMINATION
279 461 pascal SetObjectOwner(word) SetObjectOwner(1)
280 #462 pascal ISGDIOBJECT
281 #463 pascal MAKEOBJECTPRIVATE
282 #464 pascal FIXUPBOGUSPUBLISHERMETAFILE
283 465 pascal RectVisible(word ptr) RectVisible(1 2)
284 466 pascal RectInRegion(word ptr) RectInRegion(1 2)
285 #467 pascal UNICODETOANSI
286 468 pascal GetBitmapDimensionEx(word ptr) GetBitmapDimensionEx(1 2)
287 469 pascal GetBrushOrgEx(word ptr) GetBrushOrgEx(1 2)
288 470 pascal GetCurrentPositionEx(word ptr) GetCurrentPositionEx(1 2)
289 471 pascal GetTextExtentPoint(word ptr s_word ptr) GetTextExtentPoint(1 2 3 4)
290 472 pascal GetViewportExtEx(word ptr) GetViewportExtEx(1 2)
291 473 pascal GetViewportOrgEx(word ptr) GetViewportOrgEx(1 2)
292 474 pascal GetWindowExtEx(word ptr) GetWindowExtEx(1 2)
293 475 pascal GetWindowOrgEx(word ptr) GetWindowOrgEx(1 2)
294 476 pascal OffsetViewportOrgEx(word s_word s_word ptr)
295 OffsetViewportOrgEx(1 2 3 4)
296 477 pascal OffsetWindowOrgEx(word s_word s_word ptr) OffsetWindowOrgEx(1 2 3 4)
297 478 pascal SetBitmapDimensionEx(word s_word s_word ptr)
298 SetBitmapDimensionEx(1 2 3 4)
299 479 pascal SetViewportExtEx(word s_word s_word ptr) SetViewportExtEx(1 2 3 4)
300 480 pascal SetViewportOrgEx(word s_word s_word ptr) SetViewportOrgEx(1 2 3 4)
301 481 pascal SetWindowExtEx(word s_word s_word ptr) SetWindowExtEx(1 2 3 4)
302 482 pascal SetWindowOrgEx(word s_word s_word ptr) SetWindowOrgEx(1 2 3 4)
303 483 pascal MoveToEx(word s_word s_word ptr) MoveToEx(1 2 3 4)
304 484 pascal ScaleViewportExtEx(word s_word s_word s_word s_word ptr)
305 ScaleViewportExtEx(1 2 3 4 5 6)
306 485 pascal ScaleWindowExtEx(word s_word s_word s_word s_word ptr)
307 ScaleWindowExtEx(1 2 3 4 5 6)
308 #486 pascal GETASPECTRATIOFILEREX