Changed DllOverrides so we use builtin rpcrt4, ole32, oleaut32.
[wine/testsucceed.git] / dlls / wsock32 / wsock32.spec
blob7d33f9c0e900b697434afb2d3df7dfb4628c4400
1 name wsock32
3 1 forward accept ws2_32.accept
4 2 forward bind ws2_32.bind
5 3 forward closesocket ws2_32.closesocket
6 4 forward connect ws2_32.connect
7 5 forward getpeername ws2_32.getpeername
8 6 forward getsockname ws2_32.getsockname
9 7 forward getsockopt ws2_32.getsockopt
10 8 forward htonl ws2_32.htonl
11 9 forward htons ws2_32.htons
12 10 forward inet_addr ws2_32.inet_addr
13 11 forward inet_ntoa ws2_32.inet_ntoa
14 12 forward ioctlsocket ws2_32.ioctlsocket
15 13 forward listen ws2_32.listen
16 14 forward ntohl ws2_32.ntohl
17 15 forward ntohs ws2_32.ntohs
18 16 forward recv ws2_32.recv
19 17 forward recvfrom ws2_32.recvfrom
20 18 forward select ws2_32.select
21 19 forward send ws2_32.send
22 20 forward sendto ws2_32.sendto
23 21 forward setsockopt ws2_32.setsockopt
24 22 forward shutdown ws2_32.shutdown
25 23 forward socket ws2_32.socket
26 51 forward gethostbyaddr ws2_32.gethostbyaddr
27 52 forward gethostbyname ws2_32.gethostbyname
28 53 forward getprotobyname ws2_32.getprotobyname
29 54 forward getprotobynumber ws2_32.getprotobynumber
30 55 forward getservbyname ws2_32.getservbyname
31 56 forward getservbyport ws2_32.getservbyport
32 57 forward -noimport gethostname ws2_32.gethostname
33 101 forward WSAAsyncSelect ws2_32.WSAAsyncSelect
34 102 forward WSAAsyncGetHostByAddr ws2_32.WSAAsyncGetHostByAddr
35 103 forward WSAAsyncGetHostByName ws2_32.WSAAsyncGetHostByName
36 104 forward WSAAsyncGetProtoByNumber ws2_32.WSAAsyncGetProtoByNumber
37 105 forward WSAAsyncGetProtoByName ws2_32.WSAAsyncGetProtoByName
38 106 forward WSAAsyncGetServByPort ws2_32.WSAAsyncGetServByPort
39 107 forward WSAAsyncGetServByName ws2_32.WSAAsyncGetServByName
40 108 forward WSACancelAsyncRequest ws2_32.WSACancelAsyncRequest
41 109 forward WSASetBlockingHook ws2_32.WSASetBlockingHook
42 110 forward WSAUnhookBlockingHook ws2_32.WSAUnhookBlockingHook
43 111 forward WSAGetLastError ws2_32.WSAGetLastError
44 112 forward WSASetLastError ws2_32.WSASetLastError
45 113 forward WSACancelBlockingCall ws2_32.WSACancelBlockingCall
46 114 forward WSAIsBlocking ws2_32.WSAIsBlocking
47 115 forward WSAStartup ws2_32.WSAStartup
48 116 forward WSACleanup ws2_32.WSACleanup
49 151 forward __WSAFDIsSet ws2_32.__WSAFDIsSet
50 500 forward WEP ws2_32.WEP
52 # applications *should* 'degrade gracefully if these are not present
53 # ... as it is, they don't
54 #1000 stub WSApSetPostRoutine
55 1001 stdcall WsControl(long long ptr ptr ptr ptr) WsControl
56 1100 stdcall inet_network(str) WSOCK32_inet_network
57 1101 stdcall getnetbyname(str) WSOCK32_getnetbyname
58 #1102 stub rcmd
59 #1103 stub rexec
60 #1104 stub rresvport
61 #1105 stub sethostname
62 #1106 stub dn_expand
63 1107 stdcall WSARecvEx(long ptr long ptr) WSARecvEx
64 1108 stdcall s_perror(str) s_perror
65 1109 stub GetAddressByNameA
66 1110 stub GetAddressByNameW
67 1111 stdcall EnumProtocolsA(ptr ptr ptr) EnumProtocolsA
68 1112 stdcall EnumProtocolsW(ptr ptr ptr) EnumProtocolsW
69 #1113 stub GetTypeByNameA
70 #1114 stub GetTypeByNameW
71 #1115 stub GetNameByTypeA
72 #1116 stub GetNameByTypeW
73 #1117 stub SetServiceA
74 #1118 stub SetServiceW
75 #1119 stub GetServiceA
76 #1120 stub GetServiceW
77 #1130 stub NPLoadNameSpaces
78 #1140 stub TransmitFile
79 #1141 stub AcceptEx
80 #1142 stub GetAcceptExSockaddrs