Finished separation of comclt32 and comdlg32.
[wine/testsucceed.git] / dlls / comctl32 / comctl32.spec
blob6b3e16b93cc55345530bb91921ef065123cfe999
1 name comctl32
2 type win32
3 init COMCTL32_LibMain
4 rsrc rsrc.res
6 import user32.dll
7 import gdi32.dll
8 import advapi32.dll
9 import kernel32.dll
10 import ntdll.dll
12 debug_channels (animate comboex commctrl datetime header hotkey imagelist ipaddress
13 listview message monthcal nativefont pager progress propsheet
14 rebar statusbar tab toolbar tooltips trackbar treeview updown)
16 # Functions exported by the Win95 comctl32.dll
17 # (these need to have these exact ordinals, because some win95 dlls
18 # import comctl32.dll by ordinal)
19 # This list was created from a comctl32.dll v5.81 (IE5.01).
21 2 stdcall MenuHelp(long long long long long long ptr) MenuHelp
22 3 stdcall ShowHideMenuCtl(long long ptr) ShowHideMenuCtl
23 4 stdcall GetEffectiveClientRect(long long long) GetEffectiveClientRect
24 5 stdcall DrawStatusTextA(long ptr str long) DrawStatusTextA
25 6 stdcall CreateStatusWindowA(long str long long) CreateStatusWindowA
26 7 stdcall CreateToolbar(long long long long long long ptr long) CreateToolbar
27 8 stdcall CreateMappedBitmap(long long long ptr long) CreateMappedBitmap
28 9 stdcall DPA_LoadStream(ptr ptr ptr long) DPA_LoadStream
29 10 stdcall DPA_SaveStream(ptr ptr ptr long) DPA_SaveStream
30 11 stdcall DPA_Merge(ptr ptr long ptr ptr long) DPA_Merge
31 #12 stub Cctl1632_ThunkData32
32 13 stdcall MakeDragList(long) MakeDragList
33 14 stdcall LBItemFromPt(long long long long) LBItemFromPt
34 15 stdcall DrawInsert(long long long) DrawInsert
35 16 stdcall CreateUpDownControl(long long long long long long long long long long long long) CreateUpDownControl
36 17 stdcall InitCommonControls() InitCommonControls
37 18 stdcall CreatePropertySheetPage(ptr) CreatePropertySheetPageA
38 19 stdcall CreatePropertySheetPageA(ptr) CreatePropertySheetPageA
39 20 stdcall CreatePropertySheetPageW(ptr) CreatePropertySheetPageW
40 21 stdcall CreateStatusWindow(long str long long) CreateStatusWindowA
41 22 stdcall CreateStatusWindowW(long wstr long long) CreateStatusWindowW
42 23 stdcall CreateToolbarEx(long long long long long long ptr long long long long long long) CreateToolbarEx
43 24 stdcall DestroyPropertySheetPage(long) DestroyPropertySheetPage
44 25 stdcall DllGetVersion(ptr) COMCTL32_DllGetVersion
45 26 stdcall DllInstall(long ptr) COMCTL32_DllInstall
46 27 stdcall DrawStatusText(long ptr ptr long) DrawStatusTextA
47 28 stdcall DrawStatusTextW(long ptr wstr long) DrawStatusTextW
48 29 stdcall FlatSB_EnableScrollBar (long long long) FlatSB_EnableScrollBar
49 30 stdcall FlatSB_GetScrollInfo (long long ptr) FlatSB_GetScrollInfo
50 31 stdcall FlatSB_GetScrollPos (long long) FlatSB_GetScrollPos
51 32 stdcall FlatSB_GetScrollProp (long long ptr) FlatSB_GetScrollProp
52 33 stdcall FlatSB_GetScrollRange (long long ptr ptr) FlatSB_GetScrollRange
53 34 stdcall FlatSB_SetScrollInfo (long long ptr long) FlatSB_SetScrollInfo
54 35 stdcall FlatSB_SetScrollPos (long long long long) FlatSB_SetScrollPos
55 36 stdcall FlatSB_SetScrollProp (long long long long) FlatSB_SetScrollProp
56 37 stdcall FlatSB_SetScrollRange (long long long long long) FlatSB_SetScrollRange
57 38 stdcall FlatSB_ShowScrollBar (long long long) FlatSB_ShowScrollBar
58 39 stdcall GetMUILanguage() GetMUILanguage
59 40 stdcall ImageList_Add(ptr long long) ImageList_Add
60 41 stdcall ImageList_AddIcon(ptr long) ImageList_AddIcon
61 42 stdcall ImageList_AddMasked(ptr long long) ImageList_AddMasked
62 43 stdcall ImageList_BeginDrag(ptr long long long) ImageList_BeginDrag
63 44 stdcall ImageList_Copy(ptr long ptr long long) ImageList_Copy
64 45 stdcall ImageList_Create(long long long long long) ImageList_Create
65 46 stdcall ImageList_Destroy(ptr) ImageList_Destroy
66 47 stdcall ImageList_DragEnter(long long long) ImageList_DragEnter
67 48 stdcall ImageList_DragLeave(long) ImageList_DragLeave
68 49 stdcall ImageList_DragMove(long long) ImageList_DragMove
69 50 stdcall ImageList_DragShowNolock(long) ImageList_DragShowNolock
70 51 stdcall ImageList_Draw(ptr long long long long long) ImageList_Draw
71 52 stdcall ImageList_DrawEx(ptr long long long long long long long long long) ImageList_DrawEx
72 53 stdcall ImageList_DrawIndirect(ptr) ImageList_DrawIndirect
73 54 stdcall ImageList_Duplicate(ptr) ImageList_Duplicate
74 55 stdcall ImageList_EndDrag() ImageList_EndDrag
75 56 stdcall ImageList_GetBkColor(ptr) ImageList_GetBkColor
76 57 stdcall ImageList_GetDragImage(ptr ptr) ImageList_GetDragImage
77 58 stub ImageList_GetFlags
78 59 stdcall ImageList_GetIcon(ptr long long) ImageList_GetIcon
79 60 stdcall ImageList_GetIconSize(ptr ptr ptr) ImageList_GetIconSize
80 61 stdcall ImageList_GetImageCount(ptr) ImageList_GetImageCount
81 62 stdcall ImageList_GetImageInfo(ptr long ptr) ImageList_GetImageInfo
82 63 stdcall ImageList_GetImageRect(ptr long ptr) ImageList_GetImageRect
83 64 stdcall ImageList_LoadImage(long str long long long long long) ImageList_LoadImageA
84 65 stdcall ImageList_LoadImageA(long str long long long long long) ImageList_LoadImageA
85 66 stdcall ImageList_LoadImageW(long wstr long long long long long) ImageList_LoadImageW
86 67 stdcall ImageList_Merge(ptr long ptr long long long) ImageList_Merge
87 68 stdcall ImageList_Read(ptr) ImageList_Read
88 69 stdcall ImageList_Remove(ptr long) ImageList_Remove
89 70 stdcall ImageList_Replace(ptr long long long) ImageList_Replace
90 71 stdcall Alloc(long) COMCTL32_Alloc
91 72 stdcall ReAlloc(ptr long) COMCTL32_ReAlloc
92 73 stdcall Free(ptr) COMCTL32_Free
93 74 stdcall GetSize(ptr) COMCTL32_GetSize
94 75 stdcall ImageList_ReplaceIcon(ptr long long) ImageList_ReplaceIcon
95 76 stdcall ImageList_SetBkColor(ptr long) ImageList_SetBkColor
96 77 stdcall ImageList_SetDragCursorImage(ptr long long long) ImageList_SetDragCursorImage
97 78 stdcall ImageList_SetFilter(ptr long long) ImageList_SetFilter
98 79 stub ImageList_SetFlags
99 80 stdcall ImageList_SetIconSize(ptr long long) ImageList_SetIconSize
100 81 stdcall ImageList_SetImageCount(ptr long) ImageList_SetImageCount
101 82 stdcall ImageList_SetOverlayImage(ptr long long) ImageList_SetOverlayImage
102 83 stdcall ImageList_Write(ptr ptr) ImageList_Write
103 84 stdcall InitCommonControlsEx(ptr) InitCommonControlsEx
104 85 stdcall InitMUILanguage(long) InitMUILanguage
105 86 stdcall InitializeFlatSB(long) InitializeFlatSB
106 87 stdcall PropertySheet(ptr) PropertySheetA
107 88 stdcall PropertySheetA(ptr) PropertySheetA
108 89 stdcall PropertySheetW(ptr) PropertySheetW
109 90 stdcall UninitializeFlatSB(long) UninitializeFlatSB
110 91 stdcall _TrackMouseEvent(ptr) _TrackMouseEvent
112 151 stdcall CreateMRUListA(ptr) CreateMRUListA
113 152 stdcall FreeMRUList(ptr) FreeMRUListA
114 153 stdcall AddMRUStringA(long str) AddMRUStringA
115 154 stdcall EnumMRUListA(long long ptr long) EnumMRUListA
116 155 stdcall FindMRUStringA(long str ptr) FindMRUStringA
117 156 stdcall DelMRUString(long long) DelMRUString
118 157 stdcall CreateMRUListLazyA(ptr long long long) CreateMRUListLazyA
120 163 stub CreatePage
121 164 stub CreateProxyPage
123 167 stdcall AddMRUData(long ptr long) AddMRUData
124 169 stdcall FindMRUData(long ptr long ptr) FindMRUData
126 233 stdcall Str_GetPtrA(str str long) Str_GetPtrA
127 234 stdcall Str_SetPtrA(str str) Str_SetPtrA
128 235 stdcall Str_GetPtrW(wstr wstr long) Str_GetPtrW
129 236 stdcall Str_SetPtrW(wstr wstr) Str_SetPtrW
131 320 stdcall DSA_Create(long long) DSA_Create
132 321 stdcall DSA_Destroy(ptr) DSA_Destroy
133 322 stdcall DSA_GetItem(ptr long long) DSA_GetItem
134 323 stdcall DSA_GetItemPtr(ptr long) DSA_GetItemPtr
135 324 stdcall DSA_InsertItem(ptr long long) DSA_InsertItem
136 325 stdcall DSA_SetItem (ptr long long) DSA_SetItem
137 326 stdcall DSA_DeleteItem(ptr long) DSA_DeleteItem
138 327 stdcall DSA_DeleteAllItems(ptr) DSA_DeleteAllItems
139 328 stdcall DPA_Create(long) DPA_Create
140 329 stdcall DPA_Destroy(ptr) DPA_Destroy
141 330 stdcall DPA_Grow(ptr long) DPA_Grow
142 331 stdcall DPA_Clone(ptr ptr) DPA_Clone
143 332 stdcall DPA_GetPtr(ptr long) DPA_GetPtr
144 333 stdcall DPA_GetPtrIndex(ptr ptr) DPA_GetPtrIndex
145 334 stdcall DPA_InsertPtr(ptr long ptr) DPA_InsertPtr
146 335 stdcall DPA_SetPtr(ptr long ptr) DPA_SetPtr
147 336 stdcall DPA_DeletePtr(ptr long) DPA_DeletePtr
148 337 stdcall DPA_DeleteAllPtrs(ptr) DPA_DeleteAllPtrs
149 338 stdcall DPA_Sort(ptr ptr long) DPA_Sort
150 339 stdcall DPA_Search(ptr ptr long ptr long long) DPA_Search
151 340 stdcall DPA_CreateEx(long long) DPA_CreateEx
152 341 stdcall SendNotify(long long long ptr) COMCTL32_SendNotify
153 342 stdcall SendNotifyEx(long long long ptr long) COMCTL32_SendNotifyEx
155 350 stdcall StrChrA(str str) COMCTL32_StrChrA
156 351 stdcall StrRChrA(str str long) COMCTL32_StrRChrA
157 352 stdcall StrCmpNA(str str long) COMCTL32_StrCmpNA
158 353 stdcall StrCmpNIA(str str long) COMCTL32_StrCmpNIA
159 354 stdcall StrStrA(str str) COMCTL32_StrStrA
160 355 stdcall StrStrIA(str str) COMCTL32_StrStrIA
161 356 stdcall StrCSpnA(str str) COMCTL32_StrCSpnA
162 357 stdcall StrToIntA(str) COMCTL32_StrToIntA
163 358 stdcall StrChrW(wstr long) COMCTL32_StrChrW
164 359 stdcall StrRChrW(wstr wstr long) COMCTL32_StrRChrW
165 360 stdcall StrCmpNW(wstr wstr long) COMCTL32_StrCmpNW
166 361 stdcall StrCmpNIW(wstr wstr long) COMCTL32_StrCmpNIW
167 362 stdcall StrStrW(wstr wstr) COMCTL32_StrStrW
168 363 stub StrStrIW
169 364 stdcall StrSpnW(wstr wstr) COMCTL32_StrSpnW
170 365 stub StrToIntW
171 366 stub StrChrIA
172 367 stub StrChrIW
173 368 stub StrRChrIA
174 369 stub StrRChrIW
176 372 stub StrRStrIA
177 373 stub StrRStrIW
178 374 stub StrCSpnIA
179 375 stub StrCSpnIW
180 376 stub IntlStrEqWorkerA@16
181 377 stub IntlStrEqWorkerW@16
183 382 stdcall SmoothScrollWindow(ptr) SmoothScrollWindow
184 383 stub DoReaderMode@4
185 384 stub SetPathWordBreakProc@8
186 385 stdcall DPA_EnumCallback(long long long) DPA_EnumCallback
187 386 stdcall DPA_DestroyCallback(ptr ptr long) DPA_DestroyCallback
188 387 stdcall DSA_EnumCallback(ptr ptr long) DSA_EnumCallback
189 388 stdcall DSA_DestroyCallback(ptr ptr long) DSA_DestroyCallback
190 389 stub COMCTL32_389
191 390 stub COMCTL32_390
193 400 stub CreateMRUListW@4
194 401 stub AddMRUStringW@8
195 402 stub FindMRUStringW@12
196 403 stub EnumMRUListW@16
197 404 stub CreateMRUListLazyW@16
199 410 stdcall COMCTL32_410(long long long long) COMCTL32_410
200 411 stdcall COMCTL32_411(long long long) COMCTL32_411
201 412 stdcall COMCTL32_412(long long long) COMCTL32_412
202 413 stdcall COMCTL32_413(long long long long) COMCTL32_413
203 414 stub COMCTL32_414
204 415 stdcall COMCTL32_415(long long long long long) COMCTL32_415
205 416 stub COMCTL32_416
206 417 stub COMCTL32_417
207 418 stub COMCTL32_418
208 419 stub COMCTL32_419
209 420 stub COMCTL32_420
210 421 stub COMCTL32_421