5 .
/usr
/share
/debconf
/confmodule
6 PROGRAM
=$
(dpkg-divert
--truename /usr
/bin
/dumpcap
)
9 if ! dpkg-statoverride
--list $PROGRAM > /dev
/null
; then
10 db_get wireshark-common
/install-setuid
11 if [ -e "$PROGRAM" ]; then
12 if [ "$RET" = "false" ] ; then
13 chown root
:root
$PROGRAM
14 chmod u
=rwx
,go
=rx
$PROGRAM
16 if ! addgroup
--quiet --system $GROUP; then
17 if ! getent group wireshark
> /dev
/null
; then
18 db_input high wireshark-common
/addgroup-failed || true
22 db_input high wireshark-common
/group-is-user-group || true
26 chown root
:$GROUP $PROGRAM
27 if which setcap
> /dev
/null
; then
28 chmod u
=rwx
,g
=rx
,o
=r
$PROGRAM
29 if ! setcap cap_net_raw
,cap_net_admin
=eip
$PROGRAM; then
30 db_input high wireshark-common
/setcap-failed || true
32 chmod u
=rwxs
,g
=rx
,o
=r
$PROGRAM
35 chmod u
=rwxs
,g
=rx
,o
=r
$PROGRAM
40 dpkg-statoverride
--list $PROGRAM