Disable GTK+ XInput bugfix by default (tracker #3429416)
[xournal.git] / debian / rules
blobe56132e94287c0ee9df870866158a6a8a7b83696
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # GNU copyright 1997 to 1999 by Joey Hess.
6 # Uncomment this to turn on verbose mode.
7 #export DH_VERBOSE=1
10 # These are used for cross-compiling and for saving the configure script
11 # from having to guess our platform (since we know it already)
12 DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
13 DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
16 CFLAGS = -Wall -g
18 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
19 CFLAGS += -O0
20 else
21 CFLAGS += -O2
22 endif
23 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
24 INSTALL_PROGRAM += -s
25 endif
27 config.status: configure
28 dh_testdir
29 # Add here commands to configure the package.
30 CFLAGS="$(CFLAGS)" ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
33 build: build-stamp
35 build-stamp: config.status
36 dh_testdir
38 # Add here commands to compile the package.
39 $(MAKE)
40 #/usr/bin/docbook-to-man debian/xournal.sgml > xournal.1
42 touch build-stamp
44 clean:
45 dh_testdir
46 dh_testroot
47 rm -f build-stamp
49 # Add here commands to clean up after the build process.
50 -$(MAKE) distclean
51 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
52 cp -f /usr/share/misc/config.sub config.sub
53 endif
54 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
55 cp -f /usr/share/misc/config.guess config.guess
56 endif
59 dh_clean
61 install: build
62 dh_testdir
63 dh_testroot
64 dh_clean -k
65 dh_installdirs
67 # Add here commands to install the package into debian/xournal.
68 $(MAKE) install DESTDIR=$(CURDIR)/debian/xournal
71 # Build architecture-independent files here.
72 binary-indep: build install
73 # We have nothing to do by default.
75 # Build architecture-dependent files here.
76 binary-arch: build install
77 dh_testdir
78 dh_testroot
79 dh_installchangelogs ChangeLog
80 dh_installdocs
81 dh_installexamples
82 # dh_install
83 # dh_installmenu
84 # dh_installdebconf
85 # dh_installlogrotate
86 # dh_installemacsen
87 # dh_installpam
88 # dh_installmime
89 # dh_installinit
90 # dh_installcron
91 # dh_installinfo
92 dh_installman
93 dh_link
94 dh_strip
95 dh_compress
96 dh_fixperms
97 # dh_perl
98 # dh_python
99 # dh_makeshlibs
100 dh_installdeb
101 dh_shlibdeps
102 dh_gencontrol
103 dh_md5sums
104 dh_builddeb
106 binary: binary-indep binary-arch
107 .PHONY: build clean binary-indep binary-arch binary install