Fix invalid pointer access in trace_dbuf.h
[zfs.git] / contrib / debian / control
blobb9bb23b09ba0db4cbbcc4a6197471e0858b4e373
1 Source: openzfs-linux
2 Section: contrib/kernel
3 Priority: optional
4 Maintainer: ZFS on Linux specific mailing list <zfs-discuss@list.zfsonlinux.org>
5 Build-Depends: debhelper-compat (= 12),
6                dh-python,
7                dkms (>> 2.1.1.2-5),
8                libaio-dev,
9                libblkid-dev,
10                libcurl4-openssl-dev,
11                libelf-dev,
12                libpam0g-dev,
13                libssl-dev | libssl1.0-dev,
14                libtool,
15                libudev-dev,
16                lsb-release,
17                po-debconf,
18                python3-all-dev,
19                python3-cffi,
20                python3-setuptools,
21                python3-sphinx,
22                uuid-dev,
23                zlib1g-dev
24 Standards-Version: 4.5.1
25 Homepage: https://openzfs.org/
26 Vcs-Git: https://github.com/openzfs/zfs.git
27 Vcs-Browser: https://github.com/openzfs/zfs
28 Rules-Requires-Root: no
29 XS-Autobuild: yes
31 Package: openzfs-libnvpair3
32 Section: contrib/libs
33 Architecture: linux-any
34 Depends: ${misc:Depends}, ${shlibs:Depends}
35 Breaks: libnvpair1, libnvpair3
36 Replaces: libnvpair1, libnvpair3, libnvpair3linux
37 Conflicts: libnvpair3linux
38 Description: Solaris name-value library for Linux
39  This library provides routines for packing and unpacking nv pairs for
40  transporting data across process boundaries, transporting between
41  kernel and userland, and possibly saving onto disk files.
43 Package: openzfs-libpam-zfs
44 Section: contrib/admin
45 Architecture: linux-any
46 Depends: libpam-runtime, ${misc:Depends}, ${shlibs:Depends}
47 Replaces: libpam-zfs
48 Conflicts: libpam-zfs
49 Description: PAM module for managing encryption keys for ZFS
50  OpenZFS is a storage platform that encompasses the functionality of
51  traditional filesystems and volume managers. It supports data checksums,
52  compression, encryption, snapshots, and more.
53  .
54  This provides a Pluggable Authentication Module (PAM) that automatically
55  unlocks encrypted ZFS datasets upon login.
57 Package: openzfs-libuutil3
58 Section: contrib/libs
59 Architecture: linux-any
60 Depends: ${misc:Depends}, ${shlibs:Depends}
61 Breaks: libuutil1, libuutil3
62 Replaces: libuutil1, libuutil3, libuutil3linux
63 Conflicts: libuutil3linux
64 Description: Solaris userland utility library for Linux
65  This library provides a variety of glue functions for ZFS on Linux:
66   * libspl: The Solaris Porting Layer userland library, which provides APIs
67     that make it possible to run Solaris user code in a Linux environment
68     with relatively minimal modification.
69   * libavl: The Adelson-Velskii Landis balanced binary tree manipulation
70     library.
71   * libefi: The Extensible Firmware Interface library for GUID disk
72     partitioning.
73   * libshare: NFS, SMB, and iSCSI service integration for ZFS.
75 Package: openzfs-libzfs-dev
76 Section: contrib/libdevel
77 Architecture: linux-any
78 Depends: libssl-dev | libssl1.0-dev,
79          openzfs-libnvpair3 (= ${binary:Version}),
80          openzfs-libuutil3 (= ${binary:Version}),
81          openzfs-libzfs4 (= ${binary:Version}),
82          openzfs-libzfsbootenv1 (= ${binary:Version}),
83          openzfs-libzpool5 (= ${binary:Version}),
84          ${misc:Depends}
85 Replaces: libzfslinux-dev
86 Conflicts: libzfslinux-dev
87 Provides: libnvpair-dev, libuutil-dev
88 Description: OpenZFS filesystem development files for Linux
89  Header files and static libraries for compiling software against
90  libraries of OpenZFS filesystem.
91  .
92  This package includes the development files of libnvpair3, libuutil3,
93  libzpool5 and libzfs4.
95 Package: openzfs-libzfs4
96 Section: contrib/libs
97 Architecture: linux-any
98 Depends: ${misc:Depends}, ${shlibs:Depends}
99 # The libcurl4 is loaded through dlopen("libcurl.so.4").
100 # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=988521
101 Recommends: libcurl4
102 Breaks: libzfs2, libzfs4
103 Replaces: libzfs2, libzfs4, libzfs4linux
104 Conflicts: libzfs4linux
105 Description: OpenZFS filesystem library for Linux - general support
106  OpenZFS is a storage platform that encompasses the functionality of
107  traditional filesystems and volume managers. It supports data checksums,
108  compression, encryption, snapshots, and more.
110  The OpenZFS library provides support for managing OpenZFS filesystems.
112 Package: openzfs-libzfsbootenv1
113 Section: contrib/libs
114 Architecture: linux-any
115 Depends: ${misc:Depends}, ${shlibs:Depends}
116 Breaks: libzfs2, libzfs4
117 Replaces: libzfs2, libzfs4, libzfsbootenv1linux
118 Conflicts: libzfsbootenv1linux
119 Description: OpenZFS filesystem library for Linux - label info support
120  OpenZFS is a storage platform that encompasses the functionality of
121  traditional filesystems and volume managers. It supports data checksums,
122  compression, encryption, snapshots, and more.
124  The zfsbootenv library provides support for modifying ZFS label information.
126 Package: openzfs-libzpool5
127 Section: contrib/libs
128 Architecture: linux-any
129 Depends: ${misc:Depends}, ${shlibs:Depends}
130 Breaks: libzpool2, libzpool5
131 Replaces: libzpool2, libzpool5, libzpool5linux
132 Conflicts: libzpool5linux
133 Description: OpenZFS pool library for Linux
134  OpenZFS is a storage platform that encompasses the functionality of
135  traditional filesystems and volume managers. It supports data checksums,
136  compression, encryption, snapshots, and more.
138  This zpool library provides support for managing zpools.
140 Package: openzfs-python3-pyzfs
141 Section: contrib/python
142 Architecture: linux-any
143 Depends: python3-cffi,
144          openzfs-zfsutils (= ${binary:Version}),
145          ${misc:Depends},
146          ${python3:Depends}
147 Replaces: python3-pyzfs
148 Conflicts: python3-pyzfs
149 Description: wrapper for libzfs_core C library
150  libzfs_core is intended to be a stable interface for programmatic
151  administration of ZFS. This wrapper provides one-to-one wrappers for
152  libzfs_core API functions, but the signatures and types are more natural to
153  Python.
155  nvlists are wrapped as dictionaries or lists depending on their usage.
156  Some parameters have default values depending on typical use for
157  increased convenience. Enumerations and bit flags become strings and lists
158  of strings in Python. Errors are reported as exceptions rather than integer
159  errno-style error codes.  The wrapper takes care to provide one-to-many
160  mapping of the error codes to the exceptions by interpreting a context
161  in which the error code is produced.
163 Package: openzfs-pyzfs-doc
164 Section: contrib/doc
165 Architecture: all
166 Depends: ${misc:Depends}, ${sphinxdoc:Depends}
167 Recommends: openzfs-python3-pyzfs
168 Replaces: pyzfs-doc
169 Conflicts: pyzfs-doc
170 Description: wrapper for libzfs_core C library (documentation)
171  libzfs_core is intended to be a stable interface for programmatic
172  administration of ZFS. This wrapper provides one-to-one wrappers for
173  libzfs_core API functions, but the signatures and types are more natural to
174  Python.
176  nvlists are wrapped as dictionaries or lists depending on their usage.
177  Some parameters have default values depending on typical use for
178  increased convenience. Enumerations and bit flags become strings and lists
179  of strings in Python. Errors are reported as exceptions rather than integer
180  errno-style error codes.  The wrapper takes care to provide one-to-many
181  mapping of the error codes to the exceptions by interpreting a context
182  in which the error code is produced.
184  This package contains the documentation.
186 Package: openzfs-zfs-dkms
187 Architecture: all
188 Depends: dkms (>> 2.1.1.2-5),
189          file,
190          libc6-dev | libc-dev,
191          lsb-release,
192          python3-distutils | libpython3-stdlib (<< 3.6.4),
193          ${misc:Depends},
194          ${perl:Depends}
195 Recommends: openzfs-zfs-zed, openzfs-zfsutils (>= ${source:Version}), ${linux:Recommends}
196 # suggests debhelper because e.g. `dkms mkdeb -m zfs -v 0.8.2` needs dh_testdir (#909183)
197 Suggests: debhelper
198 Breaks: spl-dkms (<< 0.8.0~rc1)
199 Replaces: spl-dkms, zfs-dkms
200 Conflicts: zfs-dkms
201 Provides: openzfs-zfs-modules
202 Description: OpenZFS filesystem kernel modules for Linux
203  OpenZFS is a storage platform that encompasses the functionality of
204  traditional filesystems and volume managers. It supports data checksums,
205  compression, encryption, snapshots, and more.
207  This DKMS package includes the SPA, DMU, ZVOL, and ZPL components of
208  OpenZFS.
210 Package: openzfs-zfs-initramfs
211 Architecture: all
212 Depends: busybox-initramfs | busybox-static | busybox,
213          initramfs-tools,
214          openzfs-zfs-modules | openzfs-zfs-dkms,
215          openzfs-zfsutils (>= ${source:Version}),
216          ${misc:Depends}
217 Breaks: zfsutils-linux (<= 0.7.11-2)
218 Replaces: zfsutils-linux (<= 0.7.11-2), zfs-initramfs
219 Conflicts: zfs-initramfs
220 Description: OpenZFS root filesystem capabilities for Linux - initramfs
221  OpenZFS is a storage platform that encompasses the functionality of
222  traditional filesystems and volume managers. It supports data checksums,
223  compression, encryption, snapshots, and more.
225  This package adds OpenZFS to the system initramfs with a hook
226  for the initramfs-tools infrastructure.
228 Package: openzfs-zfs-dracut
229 Architecture: all
230 Depends: dracut,
231          openzfs-zfs-modules | openzfs-zfs-dkms,
232          openzfs-zfsutils (>= ${source:Version}),
233          ${misc:Depends}
234 Conflicts: zfs-dracut
235 Replaces: zfs-dracut
236 Description: OpenZFS root filesystem capabilities for Linux - dracut
237  OpenZFS is a storage platform that encompasses the functionality of
238  traditional filesystems and volume managers. It supports data checksums,
239  compression, encryption, snapshots, and more.
241  This package adds OpenZFS to the system initramfs with a hook
242  for the dracut infrastructure.
244 Package: openzfs-zfsutils
245 Section: contrib/admin
246 Architecture: linux-any
247 Pre-Depends: ${misc:Pre-Depends}
248 Depends: openzfs-libnvpair3 (= ${binary:Version}),
249          openzfs-libuutil3 (= ${binary:Version}),
250          openzfs-libzfs4 (= ${binary:Version}),
251          openzfs-libzpool5 (= ${binary:Version}),
252          python3,
253          ${misc:Depends},
254          ${shlibs:Depends}
255 Recommends: lsb-base, openzfs-zfs-modules | openzfs-zfs-dkms, openzfs-zfs-zed
256 Breaks: openrc,
257         spl (<< 0.7.9-2),
258         spl-dkms (<< 0.8.0~rc1),
259         openzfs-zfs-dkms (<< ${source:Version}),
260         openzfs-zfs-dkms (>> ${source:Version}...)
261 Replaces: spl (<< 0.7.9-2), spl-dkms, zfsutils-linux
262 Conflicts: zfs, zfs-fuse, zfsutils-linux
263 Suggests: nfs-kernel-server,
264           samba-common-bin (>= 3.0.23),
265           openzfs-zfs-initramfs | openzfs-zfs-dracut
266 Provides: openzfsutils
267 Description: command-line tools to manage OpenZFS filesystems
268  OpenZFS is a storage platform that encompasses the functionality of
269  traditional filesystems and volume managers. It supports data checksums,
270  compression, encryption, snapshots, and more.
272  This package provides the zfs and zpool commands to create and administer
273  OpenZFS filesystems.
275 Package: openzfs-zfs-zed
276 Section: contrib/admin
277 Architecture: linux-any
278 Pre-Depends: ${misc:Pre-Depends}
279 Depends: openzfs-zfs-modules | openzfs-zfs-dkms,
280          openzfs-zfsutils (>= ${binary:Version}),
281          ${misc:Depends},
282          ${shlibs:Depends}
283 Conflicts: zfs, zfs-zed
284 Replaces: zfs-zed
285 Description: OpenZFS Event Daemon
286  OpenZFS is a storage platform that encompasses the functionality of
287  traditional filesystems and volume managers. It supports data checksums,
288  compression, encryption, snapshots, and more.
290  ZED (ZFS Event Daemon) monitors events generated by the ZFS kernel
291  module. When a zevent (ZFS Event) is posted, ZED will run any ZEDLETs
292  (ZFS Event Daemon Linkage for Executable Tasks) that have been enabled
293  for the corresponding zevent class.
295  This package provides the OpenZFS Event Daemon (zed).
297 Package: openzfs-zfs-test
298 Section: contrib/admin
299 Architecture: linux-any
300 Depends: acl,
301          attr,
302          bc,
303          fio,
304          ksh,
305          lsscsi,
306          mdadm,
307          parted,
308          python3,
309          openzfs-python3-pyzfs,
310          sudo,
311          sysstat,
312          openzfs-zfs-modules | openzfs-zfs-dkms,
313          openzfs-zfsutils (>=${binary:Version}),
314          ${misc:Depends},
315          ${shlibs:Depends}
316 Recommends: nfs-kernel-server
317 Breaks: zfsutils-linux (<= 0.7.9-2)
318 Replaces: zfsutils-linux (<= 0.7.9-2), zfs-test
319 Conflicts: zutils, zfs-test
320 Description: OpenZFS test infrastructure and support scripts
321  OpenZFS is a storage platform that encompasses the functionality of
322  traditional filesystems and volume managers. It supports data checksums,
323  compression, encryption, snapshots, and more.
325  This package provides the OpenZFS test infrastructure for destructively
326  testing and validating a system using OpenZFS. It is entirely optional
327  and should only be installed and used in test environments.