fixed bash/dash/sh issue (Ubuntu)
[zpugcc/jano.git] / toolchain / dejagnu / packaging / rpm / dejagnu.spec
blob300d93cb4cd39971e8042d636e9d908055073bee
1 %define version 1.4.4
3 Summary: A front end for testing other programs.
4 Name: dejagnu
5 Version: %{version}
6 Release: 0
7 Copyright: GPL
8 Source: ftp://ftp.gnu.org/gnu/dejagnu/snapshots/dejagnu-%{version}.tar.gz
10 #Patch0: dejagnu-1.4.3-rth.patch
11 Group: Development/Tools
12 # Since we're building this on a debian system, we can't require these.
13 Requires: tcl >= 8.0, expect >= 5.21
14 BuildRoot: /tmp/%{name}-root
16 %description
17 DejaGnu is an Expect/Tcl based framework for testing other programs.
18 DejaGnu has several purposes: to make it easy to write tests for any
19 program; to allow you to write tests which will be portable to any
20 host or target where a program must be tested; and to standardize the
21 output format of all tests (making it easier to integrate the testing
22 into software development).
24 %prep
25 %setup -q -n dejagnu-%{version}
27 %build
28 ./configure -v
29 make
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 mkdir -p $RPM_BUILD_ROOT/usr
34 mkdir -p $RPM_BUILD_ROOT/usr/include
35 mkdir -p $RPM_BUILD_ROOT/usr/share/dejagnu
36 mkdir -p $RPM_BUILD_ROOT/usr/doc/dejagnu-%{version}
37 make prefix=$RPM_BUILD_ROOT/usr install
38 make prefix=$RPM_BUILD_ROOT/usr install-doc
40 %clean
41 rm -rf $RPM_BUILD_ROOT
43 %files
44 %defattr(-,root,root)
45 /usr/bin/runtest
46 /usr/include/dejagnu.h
47 /usr/share/dejagnu/*
49 # %config site.exp
51 %doc COPYING NEWS README AUTHORS INSTALL ChangeLog doc/overview doc/overview.ps doc/overview.pdf
53 %changelog
54 * Thu Aug 29 2002 Rob Savoye <rob@welcomehome.org>
55 - Update version number for 1.4.3 release.
57 * Wed Apr 11 2001 Rob Savoye <rob@welcomehome.org>
58 - Update version number for 1.4.2 release.
60 * Wed Apr 11 2001 Rob Savoye <rob@welcomehome.org>
61 - Added installing dejagnu.h.
62 - Install the ps and pdf formatted docs too
64 * Wed Feb 21 2001 Rob Savoye <rob@welcomehome.org>
65 - Fixed Requires line, and changed the URL to the new ftp site.
67 * Sun Oct 31 1999 Rob Savoye <rob@welcomehome.org>
68 - updated to the latest snapshot
69 - added doc files
70 - added the site.exp config file
72 * Mon Jul 12 1999 Tim Powers <timp@redhat.com>
73 - updated to 19990628
74 - updated patches as needed
75 - added %defattr in files section
77 * Wed Mar 10 1999 Jeff Johnson <jbj@redhat.com>
78 - add alpha expect patch (#989)
79 - use %configure
81 * Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
82 - Update to 19981215.
84 * Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com>
85 - Update to 1998-10-29.
87 * Wed Jul 8 1998 Jeff Johnson <jbj@redhat.com>
88 - Update to 1998-05-28.
90 * Sun Feb 1 1998 Jeff Johnson <jbj@jbj.org>
91 - Create.