1 # Maintainer: Bruno Pagani <archange@archlinux.org>
7 pkgdesc="Parallel computing with task scheduling"
17 python-importlib-metadata
31 # 'python-bokeh: visualizing dask diagnostics'
32 # 'python-cityhash: faster hashing of arrays'
33 'python-distributed: distributed computing'
34 # 'python-fastparquet: storing and reading data from parquet files'
35 # 'python-gcsfs: file-system interface to Google Cloud Storage'
36 # 'python-jinja: diagnostics'
37 # 'python-murmurhash: faster hashing of arrays'
38 'python-numpy: arrays and dataframes support'
39 'python-pandas: dataframes support'
40 'python-psutil: more accurate CPU count'
41 'python-pyarrow: Apache Arrow, for parquet support'
42 # 'python-s3fs: Amazon S3 support'
43 'python-sqlalchemy: writing and reading from SQL databases'
44 'python-xxhash: faster hashing of arrays'
49 python-pytest-rerunfailures
85 #source=(https://files.pythonhosted.org/packages/source/${_pkg::1}/${_pkg}/${_pkg}-${pkgver}.tar.gz)
86 source=(https://github.com/dask/dask/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
87 sha256sums=('f3d4d4ab004f617f7f8f0dddac55a87c6ebae19fccdf2b68a400870bdbfbd4d3')
91 python -m build --wheel --no-isolation
95 local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
96 local pytest_options=(
98 --ignore test_dir/$site_packages/$_pkg/tests/test_distributed.py
102 python -m installer --destdir=test_dir dist/*.whl
103 export PYTHONPATH="$PWD/test_dir/$site_packages:$PYTHONPATH"
104 pytest "${pytest_options[@]}" "$PWD/test_dir/$site_packages/$_pkg/"
109 python -m installer --destdir="$pkgdir" dist/*.whl
110 install -Dm644 LICENSE.txt -t "${pkgdir}"/usr/share/licenses/${pkgname}/