1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=th-lift-instances
4 pkgname=haskell-th-lift-instances
7 pkgdesc="Lift instances for template-haskell for common data types."
8 url="https://github.com/bennofs/th-lift-instances/"
11 depends=('ghc-libs' 'haskell-th-lift' 'haskell-vector')
13 source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
14 sha512sums=('bb43b13df8fb939a79a3fc1099900fcaa8741eb61b8f5574b7d7b68c220acc0cbb9fa7517b22ad34f006da7a1c25c08d1237309f8f98d79ca4d00dad345b28cb')
19 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
21 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
22 runhaskell Setup build $MAKEFLAGS
23 runhaskell Setup register --gen-script
24 runhaskell Setup unregister --gen-script
25 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
26 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
33 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
34 runhaskell Setup copy --destdir="$pkgdir"
35 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
36 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE