1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
6 pkgdesc="An implementation of the Redo build system in Bash"
8 url="http://news.dieweltistgarnichtso.net/bin/redo-sh.html"
12 optdepends=('graphviz: dependency graph support via redo-dot')
14 conflicts=('redo-python' 'redo-jdebp' 'redo-c')
15 _commit='039767509a6b52707f9fc28e8dc16c2da294b92b'
16 source=("$pkgname::git+http://news.dieweltistgarnichtso.net/bin.git#commit=$_commit")
22 git describe --tags | sed 's/^redo-v//'
28 # description of each expression:
29 # 1 - strip executable components in middle of file
30 # 2 & 3 - remove shebang & subsequent 'cat' invocation
31 # 4 - remove html comments
32 # boom, we now have a valid HTML file
34 -e '/^EOF/,/^cat <<EOF/d' \
37 -e '/^<!--/,/^-->/d' \
50 -exec install -vDm755 -t "$pkgdir/usr/bin" "{}" +
57 -exec install -vDm644 -t "$pkgdir/usr/share/man/man1" "{}" +
60 install -vDm644 "redo-sh.do" "$pkgdir/usr/share/doc/$pkgname/index.html"