1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
6 pkgdesc='Package manager for the Reaper DAW'
8 url='https://reapack.com'
9 license=('GPL3' 'LGPL3')
26 install='reapack.install'
27 _commit='daa3346cee146d5eeca806452d26b70e623d5aa7'
29 "$pkgname::git+https://github.com/cfillion/reapack#commit=$_commit"
30 'github.com-justinfrankel-wdl::git+https://github.com/justinfrankel/WDL'
31 'github.com-justinfrankel-reaper-sdk::git+https://github.com/justinfrankel/reaper-sdk'
40 git describe --tags | sed 's/^v//'
46 # prepare git submodule(s)
48 git config submodule.vendor/WDL.url "$srcdir/github.com-justinfrankel-wdl"
49 git config submodule.vendor/reaper-sdk.url "$srcdir/github.com-justinfrankel-reaper-sdk"
50 git -c protocol.file.allow=always submodule update
52 # FTBFS due to catch2 v3 not being in the repos yet
53 # so we have to use an older version
54 git revert --no-commit d551e255fe79ea1e463fe757554a55bf5adf5058
57 git cherry-pick --no-commit f2806c95ba16549e969581429d1fc51616c68796
65 -DCMAKE_BUILD_TYPE=Release
71 make -C "$pkgname/build" test
78 install -vDm755 -t "$pkgdir/usr/lib/$pkgname" "build/reaper_reapack-$CARCH.so"
81 install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.md