ThirdParty packages: Fix typos for some .csh files. Add some comments in the etc...
[OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / mpfr-3.0.0.spec
blob7f1f2e8fe7810f50f11311b70f026abb7d741ca0
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #-------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for mpfr-3.0.0
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath %{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
57 # regenerate the RPM.
59 %define _prefix %{_WM_THIRD_PARTY_DIR}
61 %define name mpfr
62 %define release %{_WM_OPTIONS}
63 %define version 3.0.0
65 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
68 Summary: mpfr
69 License: Unkown
70 Name: %{name}
71 Version: %{version}
72 Release: %{release}
73 URL: http://www.mpfr.org/mpfr-current
74 Source: %url/%{name}-%{version}.tar.gz
75 Prefix: %{_prefix}
76 Group: Development/Tools
78 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
80 %description
81 %{summary}
83 %prep
84 %setup -q
86 %build
87 # export WM settings in a form that GNU configure recognizes
88 [ -n "$WM_CC" ] && export CC="$WM_CC"
89 [ -n "$WM_CXX" ] && export CXX="$WM_CXX"
90 [ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
91 [ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
92 [ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"
94 GMP_VERSION=gmp-5.0.1
95 ./configure \
96 --prefix=%{_installPrefix} \
97 --with-gmp=$WM_THIRD_PARTY_DIR/packages/$GMP_VERSION/platforms/$WM_OPTIONS
99 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
100 make -j $WM_NCOMPPROCS
102 %install
103 make install prefix=$RPM_BUILD_ROOT%{_installPrefix}
105 # Creation of OpenFOAM specific .csh and .sh files"
107 echo ""
108 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
109 echo ""
111 # Generate package specific .sh file for OpenFOAM
113 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
114 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
115 # Load %{name}-%{version} libraries and binaries if available
116 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
118 export MPFR_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
120 [ -d \$MPFR_DIR/lib ] && _foamAddLib \$MPFR_DIR/lib
122 # Enable access to the package applications if present
123 [ -d \$MPFR_DIR/bin ] && _foamAddPath \$MPFR_DIR/bin
124 DOT_SH_EOF
127 # Generate package specific .csh file for OpenFOAM
129 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
130 # Load %{name}-%{version} libraries and binaries if available
131 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
132 setenv MPFR_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
134 if ( -e \$MPFR_DIR/lib ) then
135 _foamAddLib \$MPFR_DIR/lib
136 endif
138 if ( -e \$MPFR_DIR/bin ) then
139 _foamAddPath \$MPFR_DIR/bin
140 endif
141 DOT_CSH_EOF
143 %clean
144 rm -rf %{buildroot}
146 %files
147 %defattr(-,root,root)
148 %{_installPrefix}/etc
149 %{_installPrefix}/include
150 %{_installPrefix}/lib
151 %{_installPrefix}/share