ThirdParty: adjustments to path of generated .tgz files
[OpenFOAM-1.6-ext.git] / ThirdParty / rpmBuild / SPECS / ParMGridGen-1.0.spec
blobc702996822b6a5902ab6f37d3262930831efe216
1 #------------------------------------------------------------------------------
2 # ========= |
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
4 # \\ / O peration |
5 # \\ / A nd | Copyright held by original author
6 # \\/ M anipulation |
7 #------------------------------------------------------------------------------
8 # License
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
19 # for more details.
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
25 # Script
26 # RPM spec file for ParMGridGen-1.0
28 # Description
29 # RPM spec file for creating a relocatable RPM
31 # Author:
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir %{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath %{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
57 # regenerate the RPM.
59 %define _prefix %{_WM_THIRD_PARTY_DIR}
61 %define name ParMGridGen
62 %define release %{_WM_OPTIONS}
63 %define version 1.0
65 %define buildroot %{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
68 Summary: ParMGridGen
69 License: Unkown
70 Name: %{name}
71 Version: %{version}
72 Release: %{release}
73 URL: http://www.mgnet.org/mgnet/Codes/parmgridgen
74 Source: %url/%{name}-%{version}.tar.gz
75 Prefix: %{_prefix}
76 Group: Development/Tools
77 Patch0: ParMGridGen-1.0.patch_darwin
78 Patch1: ParMGridGen-1.0.patch
80 %define _installPrefix %{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
82 %description
83 %{summary}
85 %prep
86 %setup -q
88 %ifos darwin
89 %patch0 -p1
90 %else
91 %patch1 -p1
92 %endif
94 %build
95 [ -z "$WM_NCOMPPROCS" ] && WM_NCOMPPROCS=1
96 make -j $WM_NCOMPPROCS
98 %install
99 # Manual installation
100 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include/Lib
101 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/include/IMlib
102 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/lib
104 cp ./MGridGen/Lib/*.h $RPM_BUILD_ROOT/%{_installPrefix}/include/Lib
105 cp ./MGridGen/IMlib/*.h $RPM_BUILD_ROOT/%{_installPrefix}/include/IMlib
107 cp ./MGridGen/IMlib/libIMlib.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
108 cp ./MGridGen/Lib/libMGridGen.* $RPM_BUILD_ROOT/%{_installPrefix}/lib
110 # Creation of OpenFOAM specific .csh and .sh files"
112 echo ""
113 echo "Generating OpenFOAM specific .csh and .sh files for the package %{name}-%{version}"
114 echo ""
116 # Generate package specific .sh file for OpenFOAM
118 mkdir -p $RPM_BUILD_ROOT/%{_installPrefix}/etc
119 cat << DOT_SH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.sh
120 # Load %{name}-%{version} libraries and binaries if available
121 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
123 export PARMGRIDGEN_DIR=\$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
124 export PARMGRIDGEN_BIN_DIR=\$PARMGRIDGEN_DIR/bin
125 export PARMGRIDGEN_LIB_DIR=\$PARMGRIDGEN_DIR/lib
126 export PARMGRIDGEN_INCLUDE_DIR=\$PARMGRIDGEN_DIR/include
128 # Enable access to the runtime package applications and libraries
129 [ -d \$PARMGRIDGEN_BIN_DIR ] && _foamAddPath \$PARMGRIDGEN_BIN_DIR
130 [ -d \$PARMGRIDGEN_LIB_DIR ] && _foamAddLib \$PARMGRIDGEN_LIB_DIR
131 DOT_SH_EOF
134 # Generate package specific .csh file for OpenFOAM
136 cat << DOT_CSH_EOF > $RPM_BUILD_ROOT/%{_installPrefix}/etc/%{name}-%{version}.csh
137 # Load %{name}-%{version} libraries and binaries if available
138 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
139 setenv PARMGRIDGEN_DIR \$WM_THIRD_PARTY_DIR/packages/%{name}-%{version}/platforms/\$WM_OPTIONS
140 setenv PARMGRIDGEN_BIN_DIR \$PARMGRIDGEN_DIR/bin
141 setenv PARMGRIDGEN_LIB_DIR \$PARMGRIDGEN_DIR/lib
142 setenv PARMGRIDGEN_INCLUDE_DIR \$PARMGRIDGEN_DIR/include
144 if ( -e \$PARMGRIDGEN_BIN_DIR ) then
145 _foamAddPath \$PARMGRIDGEN_BIN_DIR
146 endif
148 if ( -e \$PARMGRIDGEN_LIB_DIR ) then
149 _foamAddLib \$PARMGRIDGEN_LIB_DIR
150 endif
151 DOT_CSH_EOF
153 #finally, generate a .tgz file for systems where using rpm for installing packages
154 # as a non-root user might be a problem.
155 (mkdir -p %{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
158 %clean
159 rm -rf %{buildroot}
161 %Files
162 %defattr(-,root,root)
163 %{_installPrefix}/include
164 %{_installPrefix}/lib/*
165 %{_installPrefix}/etc/*