1 #------------------------------------------------------------------------------
3 # \\ / F ield | OpenFOAM: The Open Source CFD Toolbox
5 # \\ / A nd | Copyright held by original author
7 #------------------------------------------------------------------------------
9 # This file is part of OpenFOAM.
11 # OpenFOAM is free software; you can redistribute it and/or modify it
12 # under the terms of the GNU General Public License as published by the
13 # Free Software Foundation; either version 2 of the License, or (at your
14 # option) any later version.
16 # OpenFOAM is distributed in the hope that it will be useful, but WITHOUT
17 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
18 # FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
21 # You should have received a copy of the GNU General Public License
22 # along with OpenFOAM; if not, write to the Free Software Foundation,
23 # Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
26 # RPM spec file for m4-1.4.16
29 # RPM spec file for creating a relocatable RPM
32 # Martin Beaudoin, Hydro-Quebec, (2010)
34 #------------------------------------------------------------------------------
36 # We grab the value of WM_THIRD_PARTY and WM_OPTIONS from the environment variable
37 %{expand:%%define _WM_THIRD_PARTY_DIR %(echo $WM_THIRD_PARTY_DIR)}
38 %{expand:%%define _WM_OPTIONS %(echo $WM_OPTIONS)}
40 # The topdir needs to point to the $WM_THIRD_PARTY/rpmbuild directory
41 %define _topdir
%{_WM_THIRD_PARTY_DIR}/rpmBuild
42 %define _tmppath
%{_topdir}/tmp
44 # Will install the package directly $WM_THIRD_PARTY_DIR
45 # Some comments about package relocation:
46 # By using this prefix for the Prefix: parameter in thi file, you will make this
47 # package relocatable.
49 # This is fine, as long as your software is itself relocatable.
51 # Simply take note that libraries built with libtool are not relocatable because the
52 # prefix we specify will be hard-coded in the library .la files.
53 # Ref: http://sourceware.org/autobook/autobook/autobook_80.html
55 # In that case, if you ever change the value of the $WM_THIRD_PARTY_DIR, you will
56 # not be able to reutilize this RPM, even though it is relocatable. You will need to
59 %define _prefix
%{_WM_THIRD_PARTY_DIR}
62 %define release
%{_WM_OPTIONS}
63 %define version
1.4.16
65 %define buildroot
%{_topdir}/BUILD/%{name}-%{version}-root
67 BuildRoot: %{buildroot}
73 URL: http
://ftp.gnu.org
/gnu
/m4
74 Source: %url/%{name}-%{version}.tar.gz
76 Group: Development
/Tools
78 %define _installPrefix
%{_prefix}/packages/%{name}-%{version}/platforms/%{_WM_OPTIONS}
87 # export WM settings in a form that GNU configure recognizes
88 [ -n "$WM_CC"
] && export CC
="$WM_CC"
89 [ -n "$WM_CXX"
] && export CXX
="$WM_CXX"
90 [ -n "$WM_CFLAGS"
] && export CFLAGS
="$WM_CFLAGS"
91 [ -n "$WM_CXXFLAGS"
] && export CXXFLAGS
="$WM_CXXFLAGS"
92 [ -n "$WM_LDFLAGS"
] && export LDFLAGS
="$WM_LDFLAGS"
95 --prefix
=%{_installPrefix}
97 [ -z "$WM_NCOMPPROCS"
] && WM_NCOMPPROCS
=1
98 make -j $WM_NCOMPPROCS
101 make install DESTDIR
=$RPM_BUILD_ROOT
103 # Creation of OpenFOAM specific .csh and .sh files"
106 echo "Generating OpenFOAM specific .csh and .sh files
for the package
%{name}-%{version}"
109 # Generate package specific .sh file for OpenFOAM
111 mkdir -p $RPM_BUILD_ROOT
/%{_installPrefix}/etc
112 cat
<< DOT_SH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.sh
113 # Load %{name}-%{version} libraries and binaries if available
114 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
116 export M4_DIR
=\$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
118 [ -d \$M4_DIR
/lib
] && _foamAddLib \$M4_DIR
/lib
120 # Enable access to the package applications if present
121 [ -d \$M4_DIR
/bin
] && _foamAddPath \$M4_DIR
/bin
125 # Generate package specific .csh file for OpenFOAM
127 cat
<< DOT_CSH_EOF
> $RPM_BUILD_ROOT
/%{_installPrefix}/etc/%{name}-%{version}.csh
128 # Load %{name}-%{version} libraries and binaries if available
129 # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
130 setenv M4_DIR \$WM_THIRD_PARTY_DIR
/packages
/%{name}-%{version}/platforms
/\$WM_OPTIONS
132 if ( -e \$M4_DIR
/lib
) then
133 _foamAddLib \$M4_DIR
/lib
136 if ( -e \$M4_DIR
/bin
) then
137 _foamAddPath \$M4_DIR
/bin
141 #finally, generate a .tgz file for systems where using rpm for installing packages
142 # as a non-root user might be a problem.
143 (mkdir -p
%{_topdir}/TGZS/%{_target_cpu}; cd $RPM_BUILD_ROOT/%{_prefix}; tar -zcvf %{_topdir}/TGZS/%{_target_cpu}/%{name}-%{version}.tgz packages/%{name}-%{version})
150 %defattr(-,root
,root
)