1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
7 pkgdesc="Application development toolkit for controlling system-wide privileges"
8 url="https://gitlab.freedesktop.org/polkit/polkit"
11 depends=(glib2 pam expat systemd duktape)
12 makedepends=(meson gtk-doc gobject-introspection git)
13 checkdepends=(python-dbusmock)
14 provides=(libpolkit-{agent,gobject}-1.so)
15 backup=(etc/pam.d/polkit-1)
17 _commit=827b0ddac5b1ef00a47fca4526fcf057bee5f1db # tags/121
18 source=("git+https://gitlab.freedesktop.org/polkit/polkit.git#commit=$_commit")
23 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
36 -D session_tracking=libsystemd-login
40 arch-meson polkit build "${meson_options[@]}"
41 meson compile -C build
45 meson test -C build --print-errorlogs -t 3
49 meson install -C build --destdir "$pkgdir"
51 install -d -o root -g 102 -m 750 "$pkgdir"/{etc,usr/share}/polkit-1/rules.d
52 mv "$pkgdir"/{etc,usr/share}/polkit-1/rules.d/50-default.rules
54 install -Dm644 /dev/stdin "$pkgdir/usr/lib/sysusers.d/$pkgname.conf" <<END
55 u polkitd 102 "PolicyKit daemon"
60 # vim:set sw=2 sts=-1 et: