db-move: moved django from [testing] to [extra] (any)
[arch-packages.git] / libheif / trunk / PKGBUILD
bloba6b38827e1e45aeec124c6ca21891083df95f761
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Adam Fontenot <fontenot@ucla.edu>
4 pkgname=libheif
5 pkgver=1.13.0
6 pkgrel=2
7 pkgdesc='HEIF file format decoder and encoder'
8 arch=(x86_64)
9 url='https://github.com/strukturag/libheif'
10 license=(GPL3)
11 makedepends=(libjpeg libpng gdk-pixbuf2)
12 depends=(libde265 x265 aom)
13 optdepends=('libjpeg: for heif-convert and heif-enc' 'libpng: for heif-convert and heif-enc')
14 source=(https://github.com/strukturag/libheif/releases/download/v$pkgver/libheif-$pkgver.tar.gz)
15 sha256sums=('c20ae01bace39e89298f6352f1ff4a54b415b33b9743902da798e8a1e51d7ca1')
16 options=(debug)
18 build() {
19   cd $pkgname-$pkgver
20   ./configure \
21     --prefix=/usr \
22     --enable-static=no
23   make
26 package() {
27   cd $pkgname-$pkgver
28   make DESTDIR="$pkgdir" install