1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
6 pkgdesc="Web content engine for embedded devices"
7 url="https://wpewebkit.org"
10 depends=(cairo fontconfig freetype2 glib2 harfbuzz harfbuzz-icu icu libjpeg
11 libepoxy libgcrypt libsoup3 libxml2 zlib libpng sqlite libwebp libwpe
12 atk at-spi2-atk openjpeg2 woff2 libtasn1 libxslt libsystemd bubblewrap
13 libseccomp xdg-dbus-proxy gstreamer gst-plugins-base-libs libxkbcommon
14 wayland wpebackend-fdo)
15 makedepends=(cmake ninja gtk-doc python ruby systemd gst-plugins-bad gperf
17 optdepends=('geoclue: Geolocation support'
18 'gst-plugins-good: media decoding'
19 'gst-plugins-bad: media decoding'
20 'gst-libav: nonfree media decoding')
22 source=($url/releases/$pkgname-$pkgver.tar.xz{,.asc})
23 sha256sums=('e98a4eae2464ffaf4e5b53be08b9ae6386db511015c8002918b824d29f05d58f'
25 validpgpkeys=('D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3' # Carlos Garcia Campos <cgarcia@igalia.com>
26 '5AA3BC334FD7E3369E7C77B291C559DBE4C9123B') # Adrián Pérez de Castro <aperez@igalia.com>
33 # Produce minimal debug info: 4.3 GB of debug data makes the
34 # build too slow and is too much to package for debuginfod
38 cmake -S $pkgname-$pkgver -B build -G Ninja \
40 -DCMAKE_BUILD_TYPE=Release \
41 -DCMAKE_INSTALL_PREFIX=/usr \
42 -DCMAKE_INSTALL_LIBDIR=lib \
43 -DCMAKE_INSTALL_LIBEXECDIR=lib \
44 -DCMAKE_SKIP_RPATH=ON \
47 -DENABLE_MINIBROWSER=ON
52 depends+=(libwpe-1.0.so libWPEBackend-fdo-1.0.so)
53 provides+=(libWPEWebKit-1.1.so)
55 DESTDIR="$pkgdir" cmake --install build
58 find Source -name 'COPYING*' -or -name 'LICENSE*' -print0 | sort -z |
59 while IFS= read -d $'\0' -r _f; do
64 install -Dm644 /dev/stdin "$pkgdir/usr/share/licenses/$pkgname/LICENSE"