1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
4 pkgname=(dleyna dleyna-docs)
7 pkgdesc="Services and D-Bus APIs to access UPnP and DLNA media devices"
8 url="https://gitlab.gnome.org/World/dLeyna"
25 python-sphinx_rtd_theme
27 _commit=9444b8eb9e48a3985340c7f7e0d3a63d2b352302 # tags/v0.8.2^0
28 source=("git+https://gitlab.gnome.org/World/dLeyna.git#commit=$_commit")
33 git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
45 arch-meson dLeyna build "${meson_options[@]}"
46 meson compile -C build
47 meson compile -C build docs
51 meson test -C build --print-errorlogs
63 'dleyna-connector-dbus<=0.4.1-1'
64 'dleyna-core<=0.7.0-3'
65 'dleyna-renderer<=0.7.2-1'
66 'dleyna-server<=0.7.2-1'
68 conflicts=("${replaces[@]}")
70 meson install -C build --destdir "$pkgdir"
72 python -m compileall -d /usr/lib "$pkgdir/usr/lib"
73 python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"
76 package_dleyna-docs() {
77 pkgdesc+=" (documentation)"
80 mkdir -p "$pkgdir/usr/share/doc"
81 cp -a build/doc/docs "$pkgdir/usr/share/doc/$pkgbase"
84 # vim:set sw=2 sts=-1 et: