OCaml 4.14.0 rebuild
[arch-packages.git] / coreutils / repos / core-x86_64 / PKGBUILD
blob2bc2818583b7262df504fd64abd862e7b6321abf
1 # Maintainer: Sébastien "Seblu" Luttringer
2 # Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Allan McRae <allan@archlinux.org>
4 # Contributor: judd <jvinet@zeroflux.org>
6 pkgname=coreutils
7 pkgver=9.1
8 pkgrel=1
9 pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system'
10 arch=('x86_64')
11 license=('GPL3')
12 url='https://www.gnu.org/software/coreutils/'
13 depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl')
14 source=("https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
15 validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
16 sha256sums=('61a1f410d78ba7e7f37a5a4f50e6d1320aca33375484a3255eddf17a38580423'
17             'SKIP')
19 prepare() {
20   cd $pkgname-$pkgver
21   # apply patch from the source array (should be a pacman feature)
22   local filename
23   for filename in "${source[@]}"; do
24     if [[ "$filename" =~ \.patch$ ]]; then
25       echo "Applying patch ${filename##*/}"
26       patch -p1 -N -i "$srcdir/${filename##*/}"
27     fi
28   done
29   :
32 build() {
33   cd $pkgname-$pkgver
34   ./configure \
35       --prefix=/usr \
36       --libexecdir=/usr/lib \
37       --with-openssl \
38       --enable-no-install-program=groups,hostname,kill,uptime
39   make
42 check() {
43   cd $pkgname-$pkgver
44   make check
47 package() {
48   cd $pkgname-$pkgver
49   make DESTDIR="$pkgdir" install
52 # vim:set ts=2 sw=2 et: