1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Lukas Fleischer <lfleischer@archlinux.org>
3 # Contributor: Jan de Groot <jgc@archlinux.org>
5 pkgbase=adwaita-icon-theme
6 pkgname=(adwaita-icon-theme adwaita-cursors)
9 pkgdesc="GNOME standard icons"
10 url="https://gitlab.gnome.org/GNOME/adwaita-icon-theme"
12 license=(LGPL3 CCPL:by-sa)
13 depends=(hicolor-icon-theme gtk-update-icon-cache librsvg)
14 makedepends=(git gtk3)
15 _commit=3ea65342a846b2b29fe6feedcd13e2ecc5b5c2b2 # tags/43^0
16 source=("git+https://gitlab.gnome.org/GNOME/adwaita-icon-theme.git#commit=$_commit")
21 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
31 ./configure --prefix=/usr
40 package_adwaita-icon-theme() {
41 depends+=(adwaita-cursors)
43 make -C $pkgname DESTDIR="$pkgdir" install
45 mkdir -p cursors/usr/share/icons/Adwaita
46 mv {"$pkgdir",cursors}/usr/share/icons/Adwaita/cursors
49 package_adwaita-cursors() {
50 pkgdesc="GNOME standard cursors"
53 mv cursors/* "$pkgdir"
56 # vim:set sw=2 sts=-1 et: