sbcl rebuild
[arch-packages.git] / kpeople / repos / extra-x86_64 / PKGBUILD
blob52305becf5799b49d15631132344d5990e691c0a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
4 pkgname=kpeople
5 pkgver=5.99.0
6 pkgrel=1
7 pkgdesc='A library that provides access to all contacts and the people who hold them'
8 arch=(x86_64)
9 url='https://community.kde.org/Frameworks'
10 license=(LGPL)
11 depends=(kcoreaddons ki18n kwidgetsaddons kitemviews)
12 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc qt5-declarative)
13 optdepends=('qt5-declarative: QML bindings')
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('7f05f4059d85371fafb9bbd1023b5995b6f8986c3fc4745a65f60513f71b663d'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
19 options=(debug)
21 build() { 
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF \
24     -DBUILD_QCH=ON
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build