sbcl rebuild
[arch-packages.git] / libgee / trunk / PKGBUILD
blob662d0db0e11e3999b17a3317a3e11e86aab2ea8c
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
5 pkgname=libgee
6 pkgver=0.20.6
7 pkgrel=1
8 pkgdesc="A collection library providing GObject-based interfaces and classes for commonly used data structures"
9 url="https://gitlab.gnome.org/GNOME/libgee"
10 license=(LGPL2.1)
11 arch=(x86_64)
12 depends=(glib2)
13 makedepends=(gobject-introspection vala autoconf-archive git)
14 options=(debug)
15 _commit=7d332f82c750ba72a6c625f38e4bfd44b786a926  # tags/0.20.6^0
16 source=("git+https://gitlab.gnome.org/GNOME/libgee.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd libgee
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd libgee
26   NOCONFIGURE=1 ./autogen.sh
29 build() {
30   cd libgee
31   ./configure --prefix=/usr --disable-static
32   make
35 check() {
36   cd libgee
37   # generates a bazillion traps - make sure systemd's core_pattern
38   # is deactivated, or you'll DoS the journal and the system
39   #make check
42 package() {
43   depends+=(libg{lib,object,io}-2.0.so)
44   provides+=(libgee-0.8.so)
46   cd libgee
47   make DESTDIR="$pkgdir" install