archrelease: copy trunk to testing-x86_64
[arch-packages.git] / plasma-systemmonitor / trunk / PKGBUILD
blob3caca6ba98456c009cca32ea9d807af3c04de28c
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=plasma-systemmonitor
4 pkgver=5.25.4
5 pkgrel=1
6 pkgdesc='An interface for monitoring system sensors, process information and other system resources'
7 arch=(x86_64)
8 url='https://kde.org/plasma-desktop/'
9 license=(GPL LGPL)
10 source=(https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
11 depends=(ksystemstats kitemmodels qqc2-desktop-style kquickcharts kdeclarative)
12 makedepends=(extra-cmake-modules)
13 groups=(plasma)
14 sha256sums=('8cac03635311b493bfd05b518e854fc62de8e100f029952e71039ad9a4df40ba'
15             'SKIP')
16 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
17               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
18               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
19               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
20 options=(debug)
22 build() {
23   cmake -B build -S $pkgname-$pkgver
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build