db-move: moved gdm from [testing] to [extra] (x86_64)
[arch-packages.git] / gsettings-desktop-schemas / repos / extra-any / PKGBUILD
bloba1db2e5383cd0819171d1a511534226a9c3414ba
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
4 # Contributor: Adam Hani Schakaki (krzd) <krzd@krzd.net>
6 pkgname=gsettings-desktop-schemas
7 pkgver=44.0
8 pkgrel=1
9 pkgdesc="Shared GSettings schemas for the desktop"
10 url="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
11 arch=(any)
12 license=(GPL)
13 depends=(
14   adobe-source-code-pro-fonts
15   cantarell-fonts
16   dconf
17   glib2
19 makedepends=(
20   git
21   gobject-introspection
22   meson
24 _commit=eff0b3609ff745fcb58cba7198397c642702736e  # tags/44.0^0
25 source=("git+https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas.git#commit=$_commit")
26 b2sums=('SKIP')
28 pkgver() {
29   cd $pkgname
30   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
33 prepare() {
34   cd $pkgname
37 build() {
38   arch-meson $pkgname build
39   meson compile -C build
42 check() {
43   meson test -C build --print-errorlogs
46 package() {
47   meson install -C build --destdir "$pkgdir"
50 # vim:set sw=2 sts=-1 et: