db-move: moved adwaita-icon-theme from [testing] to [extra] (any)
[arch-packages.git] / liblc3 / repos / extra-x86_64 / PKGBUILD
blob6a499892311a8e14cc37741eab9f8c8531c7d149
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
3 # Contributor: Florian Hülsmann <fh@cbix.de>
5 pkgname=liblc3
6 pkgver=1.0.2
7 pkgrel=1
8 pkgdesc="Low Complexity Communication Codec library and tools"
9 url="https://github.com/google/liblc3"
10 arch=(x86_64)
11 license=(Apache)
12 depends=(glibc)
13 makedepends=(meson git)
14 provides=(liblc3.so)
15 _commit=f34f4654d6c319415de718f45ff6ec73135058de  # tags/v1.0.2
16 source=("git+$url#commit=$_commit")
17 b2sums=('SKIP')
19 pkgver() {
20   cd liblc3
21   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd liblc3
28 build() {
29   arch-meson liblc3 build -D tools=true
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"
39   install -Dt "$pkgdir/usr/share/doc/$pkgname" -m644 liblc3/README.md
42 # vim:set sw=2 sts=-1 et: