1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: OSAMC <https://github.com/osam-cologne/archlinux-proaudio>
3 # Contributor: Florian Hülsmann <fh@cbix.de>
8 pkgdesc="Low Complexity Communication Codec library and tools"
9 url="https://github.com/google/liblc3"
13 makedepends=(meson git)
15 _commit=f34f4654d6c319415de718f45ff6ec73135058de # tags/v1.0.2
16 source=("git+$url#commit=$_commit")
21 git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
29 arch-meson liblc3 build -D tools=true
30 meson compile -C build
34 meson test -C build --print-errorlogs
38 meson install -C build --destdir "$pkgdir"
39 install -Dt "$pkgdir/usr/share/doc/$pkgname" -m644 liblc3/README.md
42 # vim:set sw=2 sts=-1 et: