archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ibus-typing-booster / trunk / PKGBUILD
blob9de702eebbcd6e9ac28438dcb442b03dd4c34586
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=ibus-typing-booster
4 pkgver=2.15.15
5 pkgrel=1
6 pkgdesc="Predictive input method for the IBus platform"
7 url="https://mike-fabian.github.io/ibus-typing-booster/"
8 arch=(any)
9 license=(GPL3 Apache)
10 depends=(ibus python-gobject python-dbus python-pyenchant m17n-lib sqlite)
11 makedepends=(git)
12 _commit=d690b3362218c72eb3bee83a38ded0036c4e7192  # tags/2.15.15
13 source=("git+https://github.com/mike-fabian/ibus-typing-booster#commit=$_commit")
14 sha512sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
21 prepare() {
22   cd $pkgname
23   autoreconf -fvi
26 build() {
27   cd $pkgname
28   ./configure --prefix=/usr --libexec=/usr/lib/ibus
29   make
32 package() {
33   cd $pkgname
34   make DESTDIR="$pkgdir" install
36   cd "$pkgdir/usr/share/$pkgname/data"
37   gzip -nf --best *.{txt,json} annotations{,Derived}/*.xml