archrelease: copy trunk to extra-x86_64
[arch-packages.git] / ibus-typing-booster / trunk / PKGBUILD
blob23377ac4539d8dfbb78a25a8d68bfe6c5a62718e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=ibus-typing-booster
4 pkgver=2.11.2
5 pkgrel=2
6 pkgdesc="Predictive input method for the IBus platform"
7 url="https://mike-fabian.github.io/ibus-typing-booster/"
8 arch=(any)
9 license=(GPL3 Apache)
10 depends=(ibus python-gobject python-dbus python-pyenchant m17n-lib sqlite)
11 makedepends=(git)
12 _commit=2775f38616eddf414a2de8a1a1608ab8a0072c70  # tags/2.11.2
13 source=("git+https://github.com/mike-fabian/ibus-typing-booster#commit=$_commit")
14 sha512sums=('SKIP')
16 pkgver() {
17   cd $pkgname
18   git describe --tags | sed 's/-/+/g'
21 prepare() {
22   cd $pkgname
23   autoreconf -fvi
26 build() {
27   cd $pkgname
28   ./configure --prefix=/usr --libexec=/usr/lib/ibus
29   make
32 package() {
33   cd $pkgname
34   make DESTDIR="$pkgdir" install
36   cd "$pkgdir/usr/share/$pkgname/data"
37   gzip -nf --best *.{txt,json} annotations{,Derived}/*.xml