archrelease: copy trunk to extra-x86_64
[arch-packages.git] / pango / trunk / PKGBUILD
blobab78bcd516bc8903873faa6abf9c3f5d4700bda6
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgbase=pango
5 pkgname=(pango pango-docs)
6 pkgver=1.50.1
7 pkgrel=1
8 epoch=1
9 pkgdesc="A library for layout and rendering of text"
10 url="https://www.pango.org/"
11 arch=(x86_64)
12 license=(LGPL)
13 depends=(libthai cairo libxft harfbuzz fribidi)
14 makedepends=(gobject-introspection help2man git meson gi-docgen)
15 checkdepends=(ttf-dejavu cantarell-fonts)
16 _commit=fd62d3ff159232c4a8e7bedb5ce4ac01f1ec8eeb  # tags/1.50.1^0
17 source=("git+https://gitlab.gnome.org/GNOME/pango.git#commit=$_commit"
18         fix-test.diff)
19 sha256sums=('SKIP'
20             'e1c0638305c0f46653bd60b5dee0b3445dd6a6b9aff8cee70be7759c21ba1037')
22 pkgver() {
23   cd pango
24   git describe --tags | sed 's/-/+/g'
27 prepare() {
28   cd pango
30   # Fix tests... seems to be a rounding error
31   git apply -3 ../fix-test.diff
34 build() {
35   arch-meson pango build -D gtk_doc=true
36   meson compile -C build
39 check() {
40   meson test -C build --print-errorlogs
43 package_pango() {
44   provides=(libpango{,cairo,ft2,xft}-1.0.so)
46   meson install -C build --destdir "$pkgdir"
48   mkdir -p doc/usr/share
49   mv {"$pkgdir",doc}/usr/share/doc
52 package_pango-docs() {
53   pkgdesc+=" (documentation)"
54   depends=()
56   mv doc/* "$pkgdir"
59 # vim:set sw=2 et: