1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
5 pkgname=(pango pango-docs)
9 pkgdesc="A library for layout and rendering of text"
10 url="https://www.pango.org/"
13 depends=(libthai cairo libxft harfbuzz fribidi)
14 makedepends=(gobject-introspection help2man git meson gi-docgen)
15 checkdepends=(ttf-dejavu cantarell-fonts)
16 _commit=fd62d3ff159232c4a8e7bedb5ce4ac01f1ec8eeb # tags/1.50.1^0
17 source=("git+https://gitlab.gnome.org/GNOME/pango.git#commit=$_commit"
20 'e1c0638305c0f46653bd60b5dee0b3445dd6a6b9aff8cee70be7759c21ba1037')
24 git describe --tags | sed 's/-/+/g'
30 # Fix tests... seems to be a rounding error
31 git apply -3 ../fix-test.diff
35 arch-meson pango build -D gtk_doc=true
36 meson compile -C build
40 meson test -C build --print-errorlogs
44 provides=(libpango{,cairo,ft2,xft}-1.0.so)
46 meson install -C build --destdir "$pkgdir"
48 mkdir -p doc/usr/share
49 mv {"$pkgdir",doc}/usr/share/doc
52 package_pango-docs() {
53 pkgdesc+=" (documentation)"