1 # Maintainer: Christian Hesse <mail@eworm.de>
4 _tag='1a2d16c0bd161481cbf0acc06dceb1ce788f0d09' # git rev-parse v${pkgver}
7 pkgdesc='A fast and versatile file copying tool for remote and local files'
9 url='https://rsync.samba.org/'
11 depends=('acl' 'libacl.so' 'lz4' 'openssl' 'perl' 'popt' 'xxhash' 'libxxhash.so'
13 makedepends=('git' 'python-commonmark')
14 backup=('etc/rsyncd.conf'
16 validpgpkeys=('0048C8B026D4C96F0E589C2F6C859FB14B96A8C5') # Wayne Davison <wayned@users.sourceforge.net>
17 source=("git+https://github.com/WayneD/rsync#tag=${_tag}?signed"
20 '733ccb571721433c3a6262c58b658253ca6553bec79c2bdd0011810bb4f2156b')
25 # rsync-ssl: Verify the hostname in the certificate when using openssl.
26 git cherry-pick -n c3f7414c450faaf6a8281cc4a4403529aeb7d859
28 # Force HAVE_LCHMOD off for Linux (for now).
29 # Work around glibc's lchmod() issue a better way.
31 85b8dc8abaca96fc3ea7421e09101b6ac41b6718 \
32 9dd62525f3b98d692e031f22c02be8f775966503
34 # Add test and fix regression for --delay-updates (#192) (#204)
35 git cherry-pick -n efc81c93a9fca45ba08119145a2d282f477f01b4
44 --with-included-popt=no \
45 --with-included-zlib=no
58 make DESTDIR="$pkgdir" install
59 install -Dm0644 ../rsyncd.conf "$pkgdir/etc/rsyncd.conf"
60 install -Dm0644 packaging/lsb/rsync.xinetd "$pkgdir/etc/xinetd.d/rsync"
61 install -Dm0644 packaging/systemd/rsync.service "$pkgdir/usr/lib/systemd/system/rsyncd.service"
62 install -Dm0644 packaging/systemd/rsync.socket "$pkgdir/usr/lib/systemd/system/rsyncd.socket"
63 install -Dm0644 packaging/systemd/rsync@.service "$pkgdir/usr/lib/systemd/system/rsyncd@.service"
64 install -Dm0755 support/rrsync "$pkgdir/usr/lib/rsync/rrsync"