OCaml 4.14.0 rebuild: ocaml-ctypes 0.20.1-1
[arch-packages.git] / libmythes / trunk / PKGBUILD
blob9b709f42b959780f19b6403810f5934c28338836
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
3 pkgname=libmythes
4 pkgver=1.2.4
5 pkgrel=5
6 epoch=1
7 pkgdesc="a simple thesaurus"
8 arch=('x86_64')
9 url="https://hunspell.github.io/"
10 license=('custom')
11 depends=('glibc' 'perl')
12 makedepends=('hunspell')
13 provides=('mythes')
14 source=(https://downloads.sourceforge.net/hunspell/${pkgname/lib/}-${pkgver}.tar.gz)
15 sha512sums=('a04da39812bcfb1391a2cba7de73e955eafe141679ec03ed6657d03bebf360b432480d0037dff9ed72a1dfda5a70d77d44ac2bb14cdb109fd8e2a38376feee21')
17 build() {
18   cd "${pkgname/lib/}"-$pkgver
19   ./configure --prefix=/usr --disable-static
20   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
21   make
24 check() {
25   cd "${pkgname/lib/}"-$pkgver
26   # run the example program:
27   ./example th_en_US_new.idx th_en_US_new.dat checkme.lst
28   # run the example program with stemming and morphological generation:
29   # e.g. to check mouse, mice, rodents, eats, eaten, ate, eating etc. words
30   ./example morph.idx morph.dat morph.lst morph.aff morph.dic
33 package() {
34   cd "${pkgname/lib/}"-$pkgver
35   make DESTDIR="$pkgdir" install
36   # license
37   install -Dm644 "${srcdir}"/${pkgname/lib/}-$pkgver/COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING