archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-backgrounds / trunk / PKGBUILD
blobc9cc1d3e25072edfd0540c7c5ac20b2d59c0c14b
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-backgrounds
5 pkgver=42.0
6 pkgrel=1
7 pkgdesc="Background images and data for GNOME"
8 url="https://gitlab.gnome.org/GNOME/gnome-backgrounds"
9 arch=(any)
10 makedepends=(glib2 meson)
11 license=(CCPL:by-sa)
12 groups=(gnome)
13 source=(https://download.gnome.org/sources/$pkgname/${pkgver%%.*}/$pkgname-$pkgver.tar.xz)
14 sha256sums=('4c7fe1a09f459c5f77189a5982524fce05d888944955d679910f234606c1295d')
16 build() {
17   arch-meson $pkgname-$pkgver build
18   meson compile -C build
21 check() {
22   meson test -C build --print-errorlogs
25 package() {
26   meson install -C build --destdir "$pkgdir"
29 # vim:set sw=2 et: